oktavpua

Untitled

Oct 16th, 2020
51
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. [root@master portage]$ emerge --info
  2. Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/17.0, gcc-4.8.3, glibc-2.20-r2, 3.16.5-gentoo x86_64)
  3. =================================================================
  4. System uname: Linux-3.16.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2697_v2_@_2.70GHz-with-gentoo-2.2
  5. KiB Mem: 397030452 total, 3578172 free
  6. KiB Swap: 0 total, 0 free
  7. Timestamp of tree: Fri, 16 Oct 2020 11:00:01 +0000
  8. ld GNU ld (Gentoo 2.24 p1.4) 2.24
  9. app-shells/bash: 4.3_p30-r1
  10. dev-java/java-config: 2.2.0
  11. dev-lang/perl: 5.20.1-r2
  12. dev-lang/python: 2.7.8, 3.3.5-r1, 3.4.2
  13. dev-util/cmake: 3.2.2
  14. dev-util/pkgconfig: 0.28-r2
  15. sys-apps/baselayout: 2.2
  16. sys-apps/openrc: 0.13.4
  17. sys-apps/sandbox: 2.6-r1
  18. sys-devel/autoconf: 2.69
  19. sys-devel/automake: 1.11.6-r2, 1.13.4, 1.14.1, 1.15-r1
  20. sys-devel/binutils: 2.24-r3
  21. sys-devel/gcc: 4.8.3
  22. sys-devel/gcc-config: 1.8
  23. sys-devel/libtool: 2.4.3-r2
  24. sys-devel/make: 4.1-r1
  25. sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
  26. sys-libs/glibc: 2.20-r2
  27. Repositories: gentoo science godin
  28. ACCEPT_KEYWORDS="amd64 ~amd64"
  29. ACCEPT_LICENSE="@FREE"
  30. CBUILD="x86_64-pc-linux-gnu"
  31. CFLAGS="-O2 -pipe -march=native"
  32. CHOST="x86_64-pc-linux-gnu"
  33. CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
  34. CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
  35. CXXFLAGS="-O2 -pipe -march=native"
  36. DISTDIR="/usr/portage/distfiles"
  37. EMERGE_DEFAULT_OPTS="--jobs=8"
  38. FCFLAGS="-O2 -pipe"
  39. FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
  40. FFLAGS="-O2 -pipe"
  41. GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ http://gentoo.bloodhost.ru/ "
  42. LANG="en_US.UTF-8"
  43. LDFLAGS="-Wl,-O1 -Wl,--as-needed"
  44. MAKEOPTS="-j8"
  45. PKGDIR="/usr/portage/packages"
  46. PORTAGE_CONFIGROOT="/"
  47. PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
  48. PORTAGE_TMPDIR="/var/tmp"
  49. PORTDIR="/usr/portage"
  50. PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/godin"
  51. USE="acl acpi amd64 bash-completion berkdb bzip2 cli crypt dri fortran gdbm iconv ipv6 keymap libglvnd libtirpc logrotate multilib ncurses nls nptl nptls openmp pam pcre readline seccomp split-usr ssl tcpd threads unicode vim-syntax xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFED_DRIVERS="mlx5" OFFICE_IMPLEMENTATION="libreoffice" OPENMPI_FABRICS="knem ofed" OPENMPI_OFED_FEATURES="rdmacm connectx-xrc" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
  52. Unset: CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
  53.  
  54.  
  55.  
  56.  
  57. [root@master portage]$ emerge --ask sys-apps/lm-sensors
  58. !!! Invalid news item: /usr/portage/metadata/news/2018-04-08-radicale-2-requires-pre-install-migration/2018-04-08-radicale-2-requires-pre-install-migration.en.txt
  59. !!! line 5: News-Item-Format: 2.0
  60. !!! Invalid news item: /usr/portage/metadata/news/2020-03-30-stable-ia64-keywords-removed/2020-03-30-stable-ia64-keywords-removed.en.txt
  61. !!! line 5: News-Item-Format: 2.0
  62. !!! Invalid news item: /usr/portage/metadata/news/2020-06-24-xorg-server-dropping-default-suid/2020-06-24-xorg-server-dropping-default-suid.en.txt
  63. !!! line 5: News-Item-Format: 2.0
  64. !!! Invalid news item: /usr/portage/metadata/news/2020-04-04-new-ppc64le-profiles/2020-04-04-new-ppc64le-profiles.en.txt
  65. !!! line 5: News-Item-Format: 2.0
  66. !!! Invalid news item: /usr/portage/metadata/news/2018-08-07-openssh-ldap-migration/2018-08-07-openssh-ldap-migration.en.txt
  67. !!! line 5: News-Item-Format: 2.0
  68. !!! Invalid news item: /usr/portage/metadata/news/2019-08-30-php-5_6-deprecation/2019-08-30-php-5_6-deprecation.en.txt
  69. !!! line 5: News-Item-Format: 2.0
  70. !!! Invalid news item: /usr/portage/metadata/news/2018-01-23-systemd-blocker/2018-01-23-systemd-blocker.en.txt
  71. !!! line 5: News-Item-Format: 2.0
  72. !!! Invalid news item: /usr/portage/metadata/news/2020-09-28-python-2-7-cleanup/2020-09-28-python-2-7-cleanup.en.txt
  73. !!! line 5: News-Item-Format: 2.0
  74. !!! Invalid news item: /usr/portage/metadata/news/2020-02-19-openssh-8_2-service-breakage/2020-02-19-openssh-8_2-service-breakage.en.txt
  75. !!! line 5: News-Item-Format: 2.0
  76. !!! Invalid news item: /usr/portage/metadata/news/2018-01-30-portage-rsync-verification/2018-01-30-portage-rsync-verification.en.txt
  77. !!! line 5: News-Item-Format: 2.0
  78. !!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
  79. !!! line 5: News-Item-Format: 2.0
  80. !!! Invalid news item: /usr/portage/metadata/news/2019-06-05-amd64-17-1-profiles-are-now-stable/2019-06-05-amd64-17-1-profiles-are-now-stable.en.txt
  81. !!! line 5: News-Item-Format: 2.0
  82. !!! Invalid news item: /usr/portage/metadata/news/2020-04-22-opencl-upgrade-file-collisions/2020-04-22-opencl-upgrade-file-collisions.en.txt
  83. !!! line 5: News-Item-Format: 2.0
  84. !!! Invalid news item: /usr/portage/metadata/news/2018-01-14-gnucash/2018-01-14-gnucash.en.txt
  85. !!! line 5: News-Item-Format: 2.0
  86. !!! Invalid news item: /usr/portage/metadata/news/2020-10-06-k8s-split-packages/2020-10-06-k8s-split-packages.en.txt
  87. !!! line 5: News-Item-Format: 2.0
  88. !!! Invalid news item: /usr/portage/metadata/news/2018-07-11-portage-sync-allow-hardlinks/2018-07-11-portage-sync-allow-hardlinks.en.txt
  89. !!! line 5: News-Item-Format: 2.0
  90. !!! Invalid news item: /usr/portage/metadata/news/2020-01-23-stable-alpha-keywords-removed/2020-01-23-stable-alpha-keywords-removed.en.txt
  91. !!! line 5: News-Item-Format: 2.0
  92. !!! Invalid news item: /usr/portage/metadata/news/2020-04-03-deprecation-of-legacy-x11-input-drivers/2020-04-03-deprecation-of-legacy-x11-input-drivers.en.txt
  93. !!! line 5: News-Item-Format: 2.0
  94. !!! Invalid news item: /usr/portage/metadata/news/2017-11-21-old-wine-versions-moving-to-overlay/2017-11-21-old-wine-versions-moving-to-overlay.en.txt
  95. !!! line 5: News-Item-Format: 2.0
  96. !!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
  97. !!! line 6: News-Item-Format: 2.0
  98. !!! Invalid news item: /usr/portage/metadata/news/2020-04-14-elogind-default/2020-04-14-elogind-default.en.txt
  99. !!! line 5: News-Item-Format: 2.0
  100. !!! Invalid news item: /usr/portage/metadata/news/2020-06-23-upgrade-to-sys-libs_pam-1_4_0/2020-06-23-upgrade-to-sys-libs_pam-1_4_0.en.txt
  101. !!! line 6: News-Item-Format: 2.0
  102. !!! Invalid news item: /usr/portage/metadata/news/2019-05-23-accept_license/2019-05-23-accept_license.en.txt
  103. !!! line 6: News-Item-Format: 2.0
  104. !!! Invalid news item: /usr/portage/metadata/news/2020-09-06-riscv-multilib-going-away/2020-09-06-riscv-multilib-going-away.en.txt
  105. !!! line 5: News-Item-Format: 2.0
  106. !!! Invalid news item: /usr/portage/metadata/news/2020-04-22-python3-7/2020-04-22-python3-7.en.txt
  107. !!! line 5: News-Item-Format: 2.0
  108. !!! Invalid news item: /usr/portage/metadata/news/2019-10-29-cryfs-0_10-update/2019-10-29-cryfs-0_10-update.en.txt
  109. !!! line 5: News-Item-Format: 2.0
  110. !!! Invalid news item: /usr/portage/metadata/news/2018-05-22-python3-6/2018-05-22-python3-6.en.txt
  111. !!! line 5: News-Item-Format: 2.0
  112. !!! Invalid news item: /usr/portage/metadata/news/2019-02-13-virtual-mysql-depenedency/2019-02-13-virtual-mysql-depenedency.en.txt
  113. !!! line 5: News-Item-Format: 2.0
  114. !!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
  115. !!! line 5: News-Item-Format: 2.0
  116. !!! Invalid news item: /usr/portage/metadata/news/2019-12-30-genkernel-4-default-filenames/2019-12-30-genkernel-4-default-filenames.en.txt
  117. !!! line 5: News-Item-Format: 2.0
  118. !!! Invalid news item: /usr/portage/metadata/news/2019-09-11-cpu_flags_ppc-introduction/2019-09-11-cpu_flags_ppc-introduction.en.txt
  119. !!! line 5: News-Item-Format: 2.0
  120. !!! Invalid news item: /usr/portage/metadata/news/2019-07-18-syncthing-update-incompatibility/2019-07-18-syncthing-update-incompatibility.en.txt
  121. !!! line 5: News-Item-Format: 2.0
  122. !!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
  123. !!! line 5: News-Item-Format: 2.0
  124. !!! Invalid news item: /usr/portage/metadata/news/2017-11-30-new-17-profiles/2017-11-30-new-17-profiles.en.txt
  125. !!! line 5: News-Item-Format: 2.0
  126.  
  127. * IMPORTANT: 16 news items need reading for repository 'gentoo'.
  128. * Use eselect news to read news items.
  129.  
  130. * IMPORTANT: 6 config files in '/etc/portage' need updating.
  131. * See the CONFIGURATION FILES section of the emerge
  132. * man page to learn how to update config files.
  133.  
  134. These are the packages that would be merged, in order:
  135.  
  136. Calculating dependencies | * ERROR: sci-libs/mkl-11.2.0.090::science failed (depend phase):
  137. * intel-sdp.eclass could not be found by inherit() - *
  138. * Call stack: - * ebuild.sh, line 550: Called source '/var/lib/layman/science/sci-libs/mkl/mkl-11.2.0.090.ebuild' | * mkl-11.2.0.090.ebuild, line 13: Called inherit 'intel-sdp' 'multilib' 'alternatives-2'
  139. * ebuild.sh, line 257: Called die
  140. * The specific snippet of code: / * [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
  141. *
  142. * If you need support, post the output of `emerge --info '=sci-libs/mkl-11.2.0.090::science'`, / * the complete build log and the output of `emerge -pqv '=sci-libs/mkl-11.2.0.090::science'`.
  143. * Working directory: '/usr/lib64/python3.3/site-packages'
  144. * S: '/var/tmp/portage/sci-libs/mkl-11.2.0.090/work/mkl-11.2.0.090' ... done!
  145.  
  146. !!! All ebuilds that could satisfy "sys-apps/lm-sensors" have been masked.
  147. !!! One of the following masked packages is required to complete your request:
  148. - sys-apps/lm-sensors-3.6.0::gentoo (masked by: EAPI 7)
  149. - sys-apps/lm-sensors-3.5.0_p20190505::gentoo (masked by: EAPI 7)
  150. - sys-apps/lm-sensors-3.5.0::gentoo (masked by: EAPI 6)
  151.  
  152. The current version of portage supports EAPI '5'. You must upgrade to a
  153. newer version of portage before EAPI masked packages can be installed.
  154. For more information, see the MASKED PACKAGES section in the emerge
  155. man page or refer to the Gentoo Handbook.
  156.  
  157.  
  158.  
  159.  
  160. [root@master portage]$ emerge --ask --oneshot --update sys-apps/portage
  161. !!! Invalid news item: /usr/portage/metadata/news/2018-04-08-radicale-2-requires-pre-install-migration/2018-04-08-radicale-2-requires-pre-install-migration.en.txt
  162. !!! line 5: News-Item-Format: 2.0
  163. !!! Invalid news item: /usr/portage/metadata/news/2020-03-30-stable-ia64-keywords-removed/2020-03-30-stable-ia64-keywords-removed.en.txt
  164. !!! line 5: News-Item-Format: 2.0
  165. !!! Invalid news item: /usr/portage/metadata/news/2020-06-24-xorg-server-dropping-default-suid/2020-06-24-xorg-server-dropping-default-suid.en.txt
  166. !!! line 5: News-Item-Format: 2.0
  167. !!! Invalid news item: /usr/portage/metadata/news/2020-04-04-new-ppc64le-profiles/2020-04-04-new-ppc64le-profiles.en.txt
  168. !!! line 5: News-Item-Format: 2.0
  169. !!! Invalid news item: /usr/portage/metadata/news/2018-08-07-openssh-ldap-migration/2018-08-07-openssh-ldap-migration.en.txt
  170. !!! line 5: News-Item-Format: 2.0
  171. !!! Invalid news item: /usr/portage/metadata/news/2019-08-30-php-5_6-deprecation/2019-08-30-php-5_6-deprecation.en.txt
  172. !!! line 5: News-Item-Format: 2.0
  173. !!! Invalid news item: /usr/portage/metadata/news/2018-01-23-systemd-blocker/2018-01-23-systemd-blocker.en.txt
  174. !!! line 5: News-Item-Format: 2.0
  175. !!! Invalid news item: /usr/portage/metadata/news/2020-09-28-python-2-7-cleanup/2020-09-28-python-2-7-cleanup.en.txt
  176. !!! line 5: News-Item-Format: 2.0
  177. !!! Invalid news item: /usr/portage/metadata/news/2020-02-19-openssh-8_2-service-breakage/2020-02-19-openssh-8_2-service-breakage.en.txt
  178. !!! line 5: News-Item-Format: 2.0
  179. !!! Invalid news item: /usr/portage/metadata/news/2018-01-30-portage-rsync-verification/2018-01-30-portage-rsync-verification.en.txt
  180. !!! line 5: News-Item-Format: 2.0
  181. !!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
  182. !!! line 5: News-Item-Format: 2.0
  183. !!! Invalid news item: /usr/portage/metadata/news/2019-06-05-amd64-17-1-profiles-are-now-stable/2019-06-05-amd64-17-1-profiles-are-now-stable.en.txt
  184. !!! line 5: News-Item-Format: 2.0
  185. !!! Invalid news item: /usr/portage/metadata/news/2020-04-22-opencl-upgrade-file-collisions/2020-04-22-opencl-upgrade-file-collisions.en.txt
  186. !!! line 5: News-Item-Format: 2.0
  187. !!! Invalid news item: /usr/portage/metadata/news/2018-01-14-gnucash/2018-01-14-gnucash.en.txt
  188. !!! line 5: News-Item-Format: 2.0
  189. !!! Invalid news item: /usr/portage/metadata/news/2020-10-06-k8s-split-packages/2020-10-06-k8s-split-packages.en.txt
  190. !!! line 5: News-Item-Format: 2.0
  191. !!! Invalid news item: /usr/portage/metadata/news/2018-07-11-portage-sync-allow-hardlinks/2018-07-11-portage-sync-allow-hardlinks.en.txt
  192. !!! line 5: News-Item-Format: 2.0
  193. !!! Invalid news item: /usr/portage/metadata/news/2020-01-23-stable-alpha-keywords-removed/2020-01-23-stable-alpha-keywords-removed.en.txt
  194. !!! line 5: News-Item-Format: 2.0
  195. !!! Invalid news item: /usr/portage/metadata/news/2020-04-03-deprecation-of-legacy-x11-input-drivers/2020-04-03-deprecation-of-legacy-x11-input-drivers.en.txt
  196. !!! line 5: News-Item-Format: 2.0
  197. !!! Invalid news item: /usr/portage/metadata/news/2017-11-21-old-wine-versions-moving-to-overlay/2017-11-21-old-wine-versions-moving-to-overlay.en.txt
  198. !!! line 5: News-Item-Format: 2.0
  199. !!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
  200. !!! line 6: News-Item-Format: 2.0
  201. !!! Invalid news item: /usr/portage/metadata/news/2020-04-14-elogind-default/2020-04-14-elogind-default.en.txt
  202. !!! line 5: News-Item-Format: 2.0
  203. !!! Invalid news item: /usr/portage/metadata/news/2020-06-23-upgrade-to-sys-libs_pam-1_4_0/2020-06-23-upgrade-to-sys-libs_pam-1_4_0.en.txt
  204. !!! line 6: News-Item-Format: 2.0
  205. !!! Invalid news item: /usr/portage/metadata/news/2019-05-23-accept_license/2019-05-23-accept_license.en.txt
  206. !!! line 6: News-Item-Format: 2.0
  207. !!! Invalid news item: /usr/portage/metadata/news/2020-09-06-riscv-multilib-going-away/2020-09-06-riscv-multilib-going-away.en.txt
  208. !!! line 5: News-Item-Format: 2.0
  209. !!! Invalid news item: /usr/portage/metadata/news/2020-04-22-python3-7/2020-04-22-python3-7.en.txt
  210. !!! line 5: News-Item-Format: 2.0
  211. !!! Invalid news item: /usr/portage/metadata/news/2019-10-29-cryfs-0_10-update/2019-10-29-cryfs-0_10-update.en.txt
  212. !!! line 5: News-Item-Format: 2.0
  213. !!! Invalid news item: /usr/portage/metadata/news/2018-05-22-python3-6/2018-05-22-python3-6.en.txt
  214. !!! line 5: News-Item-Format: 2.0
  215. !!! Invalid news item: /usr/portage/metadata/news/2019-02-13-virtual-mysql-depenedency/2019-02-13-virtual-mysql-depenedency.en.txt
  216. !!! line 5: News-Item-Format: 2.0
  217. !!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
  218. !!! line 5: News-Item-Format: 2.0
  219. !!! Invalid news item: /usr/portage/metadata/news/2019-12-30-genkernel-4-default-filenames/2019-12-30-genkernel-4-default-filenames.en.txt
  220. !!! line 5: News-Item-Format: 2.0
  221. !!! Invalid news item: /usr/portage/metadata/news/2019-09-11-cpu_flags_ppc-introduction/2019-09-11-cpu_flags_ppc-introduction.en.txt
  222. !!! line 5: News-Item-Format: 2.0
  223. !!! Invalid news item: /usr/portage/metadata/news/2019-07-18-syncthing-update-incompatibility/2019-07-18-syncthing-update-incompatibility.en.txt
  224. !!! line 5: News-Item-Format: 2.0
  225. !!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
  226. !!! line 5: News-Item-Format: 2.0
  227. !!! Invalid news item: /usr/portage/metadata/news/2017-11-30-new-17-profiles/2017-11-30-new-17-profiles.en.txt
  228. !!! line 5: News-Item-Format: 2.0
  229.  
  230. * IMPORTANT: 16 news items need reading for repository 'gentoo'.
  231. * Use eselect news to read news items.
  232.  
  233. * IMPORTANT: 6 config files in '/etc/portage' need updating.
  234. * See the CONFIGURATION FILES section of the emerge
  235. * man page to learn how to update config files.
  236.  
  237. These are the packages that would be merged, in order:
  238.  
  239. Calculating dependencies \ * ERROR: sci-libs/mkl-11.2.0.090::science failed (depend phase):
  240. * intel-sdp.eclass could not be found by inherit() - *
  241. * Call stack: \ * ebuild.sh, line 550: Called source '/var/lib/layman/science/sci-libs/mkl/mkl-11.2.0.090.ebuild' / * mkl-11.2.0.090.ebuild, line 13: Called inherit 'intel-sdp' 'multilib' 'alternatives-2' - * ebuild.sh, line 257: Called die
  242. * The specific snippet of code:
  243. * [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()" | *
  244. * If you need support, post the output of `emerge --info '=sci-libs/mkl-11.2.0.090::science'`,
  245. * the complete build log and the output of `emerge -pqv '=sci-libs/mkl-11.2.0.090::science'`. | * Working directory: '/usr/lib64/python3.3/site-packages'
  246. * S: '/var/tmp/portage/sci-libs/mkl-11.2.0.090/work/mkl-11.2.0.090' | * ERROR: sci-libs/mkl-11.2.0.090::science failed (depend phase):
  247. * intel-sdp.eclass could not be found by inherit()
  248. *
  249. * Call stack:
  250. * ebuild.sh, line 550: Called source '/var/lib/layman/science/sci-libs/mkl/mkl-11.2.0.090.ebuild'
  251. * mkl-11.2.0.090.ebuild, line 13: Called inherit 'intel-sdp' 'multilib' 'alternatives-2'
  252. * ebuild.sh, line 257: Called die
  253. * The specific snippet of code:
  254. * [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
  255. *
  256. * If you need support, post the output of `emerge --info '=sci-libs/mkl-11.2.0.090::science'`,
  257. * the complete build log and the output of `emerge -pqv '=sci-libs/mkl-11.2.0.090::science'`.
  258. * Working directory: '/usr/lib64/python3.3/site-packages'
  259. * S: '/var/tmp/portage/sci-libs/mkl-11.2.0.090/work/mkl-11.2.0.090' ... done!
  260.  
  261. !!! The following update has been skipped due to unsatisfied dependencies:
  262.  
  263. sys-apps/portage:0
  264.  
  265. !!! All ebuilds that could satisfy "dev-lang/python:3.7[ssl(+)]" have been masked.
  266. !!! One of the following masked packages is required to complete your request:
  267. - dev-lang/python-3.10.0_alpha1::gentoo (masked by: EAPI 7)
  268. - dev-lang/python-3.9.0::gentoo (masked by: EAPI 7)
  269. - dev-lang/python-3.8.6::gentoo (masked by: EAPI 7)
  270. - dev-lang/python-3.8.5::gentoo (masked by: EAPI 7)
  271. - dev-lang/python-3.8.4-r1::gentoo (masked by: EAPI 7)
  272. - dev-lang/python-3.7.9::gentoo (masked by: EAPI 7)
  273. - dev-lang/python-3.7.8-r2::gentoo (masked by: EAPI 7)
  274. - dev-lang/python-3.6.12::gentoo (masked by: EAPI 7)
  275. - dev-lang/python-3.6.11-r2::gentoo (masked by: EAPI 7)
  276. - dev-lang/python-2.7.18-r4::gentoo (masked by: EAPI 7)
  277.  
  278. The current version of portage supports EAPI '5'. You must upgrade to a
  279. newer version of portage before EAPI masked packages can be installed.
  280. (dependency required by "sys-apps/portage-2.3.99-r2[python_targets_python3_7,-build]" [ebuild])
  281. For more information, see the MASKED PACKAGES section in the emerge
  282. man page or refer to the Gentoo Handbook.
  283.  
  284.  
  285.  
  286. !!! The following installed packages are masked:
  287. - dev-perl/TermReadKey-2.300.200-r1::gentoo (masked by: TermReadKey license(s))
  288. - sys-block/megacli-8.07.14-r1::gentoo (masked by: LSI license(s))
  289. A copy of the 'LSI' license is located at '/usr/portage/licenses/LSI'.
  290.  
  291. - dev-java/osgi-core-api-5.0.0::gentoo (masked by: OSGi-Specification-2.0 license(s))
  292. A copy of the 'OSGi-Specification-2.0' license is located at '/usr/portage/licenses/OSGi-Specification-2.0'.
  293.  
  294. - sys-kernel/gentoo-sources-3.16.5::gentoo (masked by: freedist license(s))
  295. A copy of the 'freedist' license is located at '/usr/portage/licenses/freedist'.
  296.  
  297. - sys-kernel/gentoo-sources-3.17.2::gentoo (masked by: freedist license(s))
  298. For more information, see the MASKED PACKAGES section in the emerge
  299. man page or refer to the Gentoo Handbook.
  300.  
  301.  
  302. Nothing to merge; quitting.
RAW Paste Data