SHARE
TWEET

simple-scan root

mesmariusz Jan 24th, 2019 84 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. HP Linux Imaging and Printing System (ver. 3.18.12)
  2. Self Diagnse Utility and Healing Utility ver. 1.0
  3.  
  4. Copyright (c) 2001-15 HP Development Company, LP
  5. This software comes with ABSOLUTELY NO WARRANTY.
  6. This is free software, and you are welcome to distribute it
  7. under certain conditions. See COPYING file for more details.
  8.  
  9.  
  10. HP Linux Imaging and Printing System (ver. 3.18.12)
  11. Self Diagnse Utility and Healing Utility ver. 1.0
  12.  
  13. Copyright (c) 2001-15 HP Development Company, LP
  14. This software comes with ABSOLUTELY NO WARRANTY.
  15. This is free software, and you are welcome to distribute it
  16. under certain conditions. See COPYING file for more details.
  17.  
  18. /Gtk-Message: 19:42:11.728: Failed to load module "canberra-gtk-module"
  19. -Gtk-Message: 19:42:11.754: Failed to load module "canberra-gtk-module"
  20.  
  21.  
  22. Checking for Deprecated items....
  23. No Deprecated items are found
  24.  
  25.  
  26. Checking for HPLIP updates....
  27.  
  28. HP Linux Imaging and Printing System (ver. 3.18.12)
  29. HPLIP upgrade latest version ver. 1.0
  30.  
  31. Copyright (c) 2001-15 HP Development Company, LP
  32. This software comes with ABSOLUTELY NO WARRANTY.
  33. This is free software, and you are welcome to distribute it
  34. under certain conditions. See COPYING file for more details.
  35.  
  36. Latest version of HPLIP is already installed.
  37.  
  38.  
  39. Checking for Dependencies....
  40.  
  41. ---------------
  42. | SYSTEM INFO |
  43. ---------------
  44.  
  45.  Kernel: 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 GNU/Linux
  46.  Host: Krystyna-Desktop
  47.  Proc: 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 GNU/Linux
  48.  Distribution: 12 18.04
  49.  Bitness: 64 bit
  50.  
  51.  
  52. -----------------------
  53. | HPLIP CONFIGURATION |
  54. -----------------------
  55.  
  56. HPLIP-Version: HPLIP 3.18.12
  57. HPLIP-Home: /usr/share/hplip
  58. HPLIP-Installation: Auto installation is supported for ubuntu distro  18.04 version
  59.  
  60. Current contents of '/etc/hp/hplip.conf' file:
  61. # hplip.conf.  Generated from hplip.conf.in by configure.
  62.  
  63. [hplip]
  64. version=3.18.12
  65.  
  66. [dirs]
  67. home=/usr/share/hplip
  68. run=/var/run
  69. ppd=/usr/share/ppd/HP
  70. ppdbase=/usr/share/ppd
  71. doc=/usr/share/doc/hplip-3.18.12
  72. html=/usr/share/doc/hplip-3.18.12
  73. icon=/usr/share/applications
  74. cupsbackend=/usr/lib/cups/backend
  75. cupsfilter=/usr/lib/cups/filter
  76. drv=/usr/share/cups/drv/hp
  77. bin=/usr/bin
  78. apparmor=/etc/apparmor.d
  79. # Following values are determined at configure time and cannot be changed.
  80. [configure]
  81. network-build=yes
  82. libusb01-build=no
  83. pp-build=no
  84. gui-build=yes
  85. scanner-build=yes
  86. fax-build=yes
  87. dbus-build=yes
  88. cups11-build=no
  89. doc-build=yes
  90. shadow-build=no
  91. hpijs-install=no
  92. foomatic-drv-install=no
  93. foomatic-ppd-install=no
  94. foomatic-rip-hplip-install=no
  95. hpcups-install=yes
  96. cups-drv-install=yes
  97. cups-ppd-install=no
  98. internal-tag=3.18.12
  99. restricted-build=no
  100. ui-toolkit=qt4
  101. qt3=no
  102. qt4=yes
  103. qt5=no
  104. policy-kit=no
  105. lite-build=no
  106. udev_sysfs_rules=no
  107. hpcups-only-build=no
  108. hpijs-only-build=no
  109. apparmor_build=yes
  110. class-driver=no
  111.  
  112.  
  113. Current contents of '/var/lib/hp/hplip.state' file:
  114. Plugins are not installed. Could not access file: Nie ma takiego pliku ani katalogu
  115.  
  116. Current contents of '~/.hplip/hplip.conf' file:
  117. [upgrade]
  118. notify_upgrade = true
  119. last_upgraded_time = 1548321795
  120. pending_upgrade_time = 0
  121. latest_available_version = 3.17.10
  122.  
  123. [settings]
  124. systray_visible = 0
  125. systray_messages = 0
  126.  
  127. [last_used]
  128. device_uri = "hp:/usb/Deskjet_F4200_series?serial=CN8882F33005C3"
  129. printer_name =
  130. working_dir = .
  131.  
  132. [commands]
  133. scan = /usr/bin/xsane -V %SANE_URI%
  134.  
  135. [refresh]
  136. rate = 30
  137. enable = false
  138. type = 1
  139.  
  140. [polling]
  141. enable = false
  142. interval = 5
  143. device_list =
  144.  
  145. [fax]
  146. voice_phone =
  147. email_address =
  148.  
  149. [installation]
  150. date_time = 24.01.2019 19:42:12
  151. version = 3.18.12
  152.  
  153.  
  154.  <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
  155.  
  156. --------------
  157. | COMPILEDEP |
  158. --------------
  159.  
  160.  gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               7.3.0           OK         -
  161.  make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.1             OK         -
  162.  libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
  163.  
  164. ------------------------
  165. | General Dependencies |
  166. ------------------------
  167.  
  168.  libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.0           OK         -
  169.  python-xml           Python XML libraries                                         REQUIRED        -               2.2.5           OK         -
  170.  libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.3           OK         -
  171.  sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
  172.  pil                  PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
  173.  pyqt4-dbus           PyQt 4 DBus - DBus Support for PyQt4                         REQUIRED        4.0             4.12.1          OK         -
  174.  libpthread           libpthread - POSIX threads library                           REQUIRED        -               2.27            OK         -
  175.  python-devel         Python devel - Python development files                      REQUIRED        2.2             2.7.15          OK         -
  176.  cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.2.7           OK         -
  177.  python-dbus          Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.6           OK         -
  178.  cups-ddk             CUPS DDK - CUPS driver development kit                       OPTIONAL        -               -               OK         -
  179.  reportlab            Reportlab - PDF library for Python                           OPTIONAL        2.0             3.4.0           OK         -
  180.  pyqt4                PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.12.1          OK         -
  181.  libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
  182.  cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.2.7           OK         -
  183.  python2X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             2.7.15          OK         -
  184.  python-notify        Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
  185.  libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
  186.  sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
  187.  
  188. ----------------------
  189. | Scan Configuration |
  190. ----------------------
  191.  
  192.  scanext              Scan-SANE-Extension                                          REQUIRED        -               3.18.12         OK         -
  193.  hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.18.12         OK         'hpaio found in /etc/sane.d/dll.conf'
  194.  
  195. -------------------------
  196. | External Dependencies |
  197. -------------------------
  198.  
  199.  gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.26            OK         -
  200.  scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
  201.  cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.2.7           OK         'CUPS Scheduler is running'
  202.  network              network -wget                                                OPTIONAL        -               1.19.4          OK         -
  203.  policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
  204. Gtk-Message: 19:42:22.106: Failed to load module "canberra-gtk-module"
  205. Gtk-Message: 19:42:22.126: Failed to load module "canberra-gtk-module"
  206.  xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
  207.  dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.2          OK         -
  208.  avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -
  209.  
  210. ---------------------
  211. | Python Extentions |
  212. ---------------------
  213.  
  214.  hpmudext             IO-Extension                                                 REQUIRED        -               3.18.12         OK         -
  215.  cupsext              CUPS-Extension                                               REQUIRED        -               3.18.12         OK         -
  216.  
  217. ------------------------------
  218. | DISCOVERED SCANNER DEVICES |
  219. ------------------------------
  220.  
  221. No Scanner found.
  222.  
  223. --------------------------
  224. | DISCOVERED USB DEVICES |
  225. --------------------------
  226.  
  227. No devices found.
  228.  
  229. ---------------------------------
  230. | INSTALLED CUPS PRINTER QUEUES |
  231. ---------------------------------
  232.  
  233.  
  234. Deskjet-F4200-series
  235. --------------------
  236. Type: Printer
  237. Device URI: hp:/usb/Deskjet_F4200_series?serial=CN8882F33005C3
  238. PPD: /etc/cups/ppd/Deskjet-F4200-series.ppd
  239. warning: Failed to read /etc/cups/ppd/Deskjet-F4200-series.ppd ppd file
  240. PPD Description:
  241. Printer status: printer Deskjet-F4200-series is idle.  enabled since śro, 23 sty 2019, 16:14:21
  242. error: Unable to communicate with device (code=12): hp:/usb/Deskjet_F4200_series?serial=CN8882F33005C3
  243. error: Device not found
  244. error: Communication status: Failed
  245.  
  246.  
  247. --------------
  248. | PERMISSION |
  249. --------------
  250.  
  251.  
  252.  
  253. Checking Permissions....
  254.  
  255.  
  256. Checking for Configured Queues....
  257. warning: Fail to read ppd=/etc/cups/ppd/Deskjet-F4200-series.ppd file
  258. warning: Insufficient permission to access file /etc/cups/ppd/Deskjet-F4200-series.ppd
  259. warning: Could not complete Queue(s) configuration check
  260.  
  261.  
  262. Checking for HP Properitery Plugin's....
  263. No plug-in printers are configured.
  264.  
  265.  
  266. Checking for Printer Status....
  267. error: 'Deskjet-F4200-series' Printer is either Powered-OFF or Failed to communicate.
  268. Turn On Printer and re-run hp-doctor
  269.  
  270. Diagnose completed...
  271.  
  272.  
  273.  
  274. More information on Troubleshooting,How-To's and Support is available on http://hplipopensource.com/hplip-web/index.html
  275.  
  276.  
  277. Please close this terminal manually.
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top