SHARE
TWEET

4_62A

a guest Sep 18th, 2018 180 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo Ogalvao()
  2.       declare ncp, m, f, vin4:inteiro;
  3.       declare s:literal;
  4.       escreva("Informe o número de crianças nascidas no período: ");
  5.       leia(ncp);
  6.       vin4 <- 0;
  7.       faca
  8.                    
  9.          
  10.              escreva("Informe o sexo [M/F]: ");
  11.              leia(s);
  12.              se (s <> 'vazio') entao
  13.                 se (s == m) entao
  14.                     m <- m + 1;
  15.                 senao
  16.                     f <- f + 1;
  17.                 fimse
  18.                 escreva("Informe o número de meses de vida da criança: ");
  19.                 leia(mv);
  20.                 se (mv <= 24) entao
  21.                     vin4 <- vin4 +  1;
  22.                 fimse
  23.             fimse
  24.       enquanto (s != 'vazio')
  25.       escreval("A porcentagem de crianças mortas nesse período é: ", (((m+f)*100))/ncp));
  26.       escreval("A porcentagem de crianças do sexo masculino, mortas nesse período é: ", (((m)*100))/ncp));
  27.       escreval("A porcentagem de crianças que viveram 24 meses ou menos é: ", (((vin4)*100))ncp));
  28. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top