daily pastebin goal
31%
SHARE
TWEET

4_61

a guest Sep 18th, 2018 186 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo AnaoDesgracadoDoKRLFDPSemPai()
  2.       declare cu, sbt, glo, rec, red, ban:inteiro;
  3.       declare r:literal;
  4.       faca
  5.             se (r != 'Fim') entao
  6.                escolha (r)
  7.                        caso 'Cultura':
  8.                             cu <- cu + 1;
  9.                        caso 'SBT':
  10.                             sbt <- sbt + 1;
  11.                        caso 'Globo':
  12.                             glo <- glo + 1;
  13.                        caso 'Record':
  14.                             rec <- rec + 1;
  15.                        caso 'Rede':
  16.                             red <- red + 1;
  17.                        caso 'Bandeirantes':
  18.                             ban <- ban + 1;
  19.                fimescolha
  20.                se ((cu > sbt) E (cu > glo) E (cu > rec) E (cu > red) E (cu > ban)) entao
  21.                   escreva("A emissora com maior audiência foi TV Cultura.");
  22.                senao
  23.                     se ((sbt > glo) E (sbt > rec) E (sbt > red) E (sbt > ban)) entao
  24.                        escreva("A emissora com maior audiência foi TV sbt.");
  25.                     senao
  26.                          se ((rec > glo) E (rec > red) E (rec > ban)) entao
  27.                             escreva("A emissora com maior audiência foi TV record.");
  28.                          senao
  29.                               se ((red > glo) E (red > ban)) entao
  30.                                  escreva("A emissora com maior audiência foi TV rede.");
  31.                               senao
  32.                                    se (glo > ban) entao
  33.                                       escreva("A emissora com maior audiência foi TV globo.");
  34.                                    senao
  35.                                         escreva("A emissora com maior audiência foi TV bandeirantes.");
  36.                                    fimse
  37.                               fimse
  38.                          fimse
  39.                      fimse
  40.                   fimse
  41.                fimse
  42.             fimse
  43.       enquanto(r != 'Fim');
  44.       t <- cu+sbt+glo+rec+red+ban;
  45.       escreval("A soma total é igual a: ", t);
  46. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top