SHARE
TWEET

conjure-up bug 'Could not determine LXD version'

drpanwe Jun 19th, 2017 47 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. The current `snap` flavors of `conjure-up`:
  2.  
  3. ```bash
  4. drpaneas@ubuntu1704:~$ sudo snap info conjure-up
  5. name:      conjure-up
  6. summary:   "Package runtime for conjure-up spells"
  7. publisher: canonical
  8. contact:   https://github.com/conjure-up/conjure-up
  9. description: |
  10.   This package provides conjure-up, an interface to installing spells that
  11.   provide the user with an end to end walkthrough experience for installing and
  12.   using big software.
  13.  
  14. channels:                                          
  15.   latest/stable:    2.2.0                    (453) 88MB classic
  16.   latest/candidate: 2.2.1-20170619.2006      (461) 92MB classic
  17.   latest/beta:      2.2.0                    (432) 88MB classic
  18.   latest/edge:      2.3-alpha1-20170619.1906 (460) 92MB classic
  19. ```
  20.  
  21. I am going to install the latest one, which in that context, I mean *2.3-alpha1-20170619.1906*.
  22.  
  23. ```bash
  24. drpaneas@ubuntu1704:~$ sudo snap install conjure-up --edge
  25. error: This revision of snap "conjure-up" was published using classic confinement and thus may perform
  26.        arbitrary system changes outside of the security sandbox that snaps are usually confined to, which
  27.        may put your system at risk.
  28.  
  29.        If you understand and want to proceed repeat the command including --classic.
  30. ```
  31.  
  32. Well, I am pretty *OK* with ignoring this *warning*, so let's roll the dice:
  33.  
  34. ```bash
  35. drpaneas@ubuntu1704:~$ sudo snap install conjure-up --edge --classic
  36. 2017-06-20T00:14:07+02:00 INFO cannot auto connect core:core-support-plug to core:core-support: (slot auto-connection), existing connection state "core:core-support-plug core:core-support" in the way
  37. 2017-06-20T00:14:07+02:00 INFO Waiting for restart...
  38. 2017-06-20T00:14:07+02:00 INFO cannot auto connect core:core-support-plug to core:core-support: (slot auto-connection), existing connection state "core:core-support-plug core:core-support" in the way
  39. conjure-up (edge) 2.3-alpha1-20170619.1906 from 'canonical' installed
  40. ```
  41.  
  42. So, as you can see, I've got it installed, along with *core*:
  43.  
  44. ```bash
  45. drpaneas@ubuntu1704:~$ sudo snap list
  46. Name        Version                   Rev   Developer  Notes
  47. conjure-up  2.3-alpha1-20170619.1906  460   canonical  classic
  48. core        16-2                      1689  canonical  -
  49. ```
  50.  
  51. Now let's try to run it:
  52.  
  53. ```bash
  54. drpaneas@ubuntu1704:~$ conjure-up
  55. Traceback (most recent call last):
  56.  File "/snap/conjure-up/460/bin/conjure-up", line 11, in <module>
  57.    load_entry_point('conjure-up==2.3a1', 'console_scripts', 'conjure-up')()
  58.  File "/snap/conjure-up/460/lib/python3.6/site-packages/conjureup/app.py", line 241, in main
  59.    utils.lxd_version(),
  60.  File "/snap/conjure-up/460/lib/python3.6/site-packages/conjureup/utils.py", line 205, in lxd_version
  61.    raise Exception("Could not determine LXD version.")
  62. Exception: Could not determine LXD version.
  63. ```
  64.  
  65. As you can see, it complains about not able to determine the LXD version -- which actually makes sense because I don't even have LXD installed in my machine:
  66.  
  67. ```bash
  68. drpaneas@ubuntu1704:~$ dpkg-query -L lxd
  69. dpkg-query: package 'lxd' is not installed
  70. ```
RAW Paste Data
Want to get better at Bash?
Learn to code Bash in 2017
Pastebin PRO Summer Special!
Get 40% OFF on Pastebin PRO accounts!
Top