SHARE
TWEET

Untitled

a guest Oct 12th, 2017 53 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. programa
  2. {
  3.     funcao inicio()
  4.     {
  5.         inteiro n, a, b
  6.         escreva("-- digite a, b, n --\n")
  7.         leia(a)
  8.         leia(b)
  9.         leia(n)
  10.         se(n==1){
  11.             escreva(a,"\n")
  12.         }
  13.         senao se(n==2){
  14.             escreva(b,"\n")
  15.         }senao{
  16.             inteiro f[1000]
  17.             f[0]=a
  18.             f[1]=b
  19.             para(inteiro i=2; i<n; i++){
  20.                 f[i] = f[i-1]+f[i-2]
  21.             }
  22.             escreva(f[n-1],"\n")
  23.         }
  24.     }
  25. }
RAW Paste Data
Top