Advertisement
Guest User

WMS-20200409

a guest
Apr 9th, 2020
223
0
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
Bash 1.16 KB | None | 0 0
  1. #LOGGING, true/false#
  2. :local iDebug "true"
  3. #WLAN INTERFACE#
  4. :local iFace "wlan1"
  5. #GW ID#
  6. :local gwId "WAG-D4-GBL"
  7. #WLAN ID#
  8. :local wlanId "PTPATXXXXX-N/TLK-CI-XXXXX:XX"
  9. #USERNAME, note: word sebelum @freeMS di bagian fetch itu random / acak, terserah mau diganti / tidak.#
  10. :local userId "user"
  11. #PASSWORD#
  12. :local passId "password"
  13.  
  14. :if ($iDebug = "true") do={:log warning "init, release dhcp-client..."};
  15. /ip dns cache flush
  16. /ip dhcp-client release [find interface=$iFace];
  17. :delay 10
  18. :local ipAdd [/ip address get [/ip address find interface=$iFace] address];
  19. :local ipAddr [put [:pick $ipAdd 0 [:find $ipAdd "/"]]];
  20. :local macAddr [/interface wireless get [find default-name=$iFace] mac-address];
  21. :local iUrl ("https://welcome2.wifi.id/wms/auth/authnew/autologin-free/quarantine.php\?ipc=$ipAddr&gw_id=$gwId&mac=$macAddr$redirect=&wlan=$wlanId&landURL=&username_=$userId&username=$userId.1QWl@freeMS&password=$passId")
  22. /tool fetch http-header-field="user-agent: Mozilla/5.0" url="$iUrl" dst-path=wms.txt
  23. :delay 5
  24. :if ($iDebug = "true") do={
  25.  :local iRes [/file get wms.txt contents];
  26.  :log warning $iRes
  27.  :file remove wms.txt
  28. } else={[/file remove wms.txt]};
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement