Advertisement
rootplg3544

ROTING GGC OM PILIP

Dec 9th, 2018
483
0
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
text 7.00 KB | None | 0 0
  1. /ip route rule
  2. add comment=Google dst-address=1.0.0.0/24 table=YOUTUBE-ROUTING
  3. add comment=Google dst-address=1.1.1.0/24 table=YOUTUBE-ROUTING
  4. add comment=Google dst-address=1.2.3.0/24 table=YOUTUBE-ROUTING
  5. add comment=Google dst-address=8.0.0.0/8 table=YOUTUBE-ROUTING
  6. add comment=Google dst-address=72.14.240.0/20 table=YOUTUBE-ROUTING
  7. add comment=Google dst-address=74.125.0.0/18 table=YOUTUBE-ROUTING
  8. add comment=Google dst-address=173.194.0.0/16 table=YOUTUBE-ROUTING
  9. add comment=Google dst-address=209.85.192.0/18 table=YOUTUBE-ROUTING
  10. add comment=Google dst-address=208.117.224.0/19 table=YOUTUBE-ROUTING
  11. add comment=Google dst-address=173.194.209.0/24 table=YOUTUBE-ROUTING
  12. add comment=Google dst-address=173.194.210.0/24 table=YOUTUBE-ROUTING
  13. add comment=Google dst-address=173.194.211.0/24 table=YOUTUBE-ROUTING
  14. add comment=Google dst-address=173.194.214.0/24 table=YOUTUBE-ROUTING
  15. add comment=Google dst-address=216.239.32.0/19 table=YOUTUBE-ROUTING
  16. add comment=Google dst-address=172.217.0.0/16 table=YOUTUBE-ROUTING
  17. add comment=Google dst-address=216.58.192.0/19 table=YOUTUBE-ROUTING
  18. add comment=Google dst-address=175.28.1.0/24 table=YOUTUBE-ROUTING
  19. add comment=Google dst-address=173.194.38.0/24 table=YOUTUBE-ROUTING
  20. add comment=Google dst-address=208.117.224.0/24 table=YOUTUBE-ROUTING
  21. add comment=Google dst-address=208.117.225.0/24 table=YOUTUBE-ROUTING
  22. add comment=Google dst-address=208.117.228.0/24 table=YOUTUBE-ROUTING
  23. add comment=Google dst-address=208.117.229.0/24 table=YOUTUBE-ROUTING
  24. add comment=Google dst-address=208.117.232.0/24 table=YOUTUBE-ROUTING
  25. add comment=Google dst-address=208.117.233.0/24 table=YOUTUBE-ROUTING
  26. add comment=Google dst-address=208.117.234.0/24 table=YOUTUBE-ROUTING
  27. add comment=Google dst-address=208.117.238.0/24 table=YOUTUBE-ROUTING
  28. add comment=Google dst-address=208.65.152.0/24 table=YOUTUBE-ROUTING
  29. add comment=Google dst-address=208.65.153.0/24 table=YOUTUBE-ROUTING
  30. add comment=Google dst-address=208.65.154.0/24 table=YOUTUBE-ROUTING
  31. add comment=Google dst-address=64.15.112.0/20 table=YOUTUBE-ROUTING
  32. add comment=Google dst-address=208.117.236.0/24 table=YOUTUBE-ROUTING
  33. add comment=Google dst-address=74.125.96.0/19 table=YOUTUBE-ROUTING
  34. add comment=Google dst-address=72.14.221.0/24 table=YOUTUBE-ROUTING
  35. add comment=Google dst-address=84.53.128.0/18 table=YOUTUBE-ROUTING
  36. add comment=Google dst-address=87.248.192.0/19 table=YOUTUBE-ROUTING
  37. add comment=Google dst-address=216.155.128.0/19 table=YOUTUBE-ROUTING
  38. add comment=Google dst-address=208.73.208.0/21 table=YOUTUBE-ROUTING
  39. add comment=Google dst-address=66.55.140.0/23 table=YOUTUBE-ROUTING
  40. add comment=Google dst-address=74.125.208.0/24 table=YOUTUBE-ROUTING
  41.  
  42.  
  43.  
  44.  
  45. upps kebetulan
  46. ane juga ingin belajar pisah jalur untuk youtube.
  47.  
  48. ane buat:
  49. /ip firewall filter> pr
  50. 1 chain=forward action=add-dst-to-address-list protocol=tcp address-list=youlist address-list-timeout=0s dst-port=80 content=youtube
  51.  
  52. /ip firewall mangle> pr
  53. 9 X ;;; ----------YOUTUBE
  54. chain=prerouting action=mark-connection new-connection-mark=youmangle passthrough=yes protocol=tcp src-address-list=Local dst-address-list=youlist
  55.  
  56. 10 X ;;; PAKET & ROUTING MARK YOUTUBE
  57. chain=prerouting action=mark-routing new-routing-mark=Youtube passthrough=yes src-address-list=Local connection-mark=youmangle
  58.  
  59.  
  60. /ip firewall address-list> pr
  61. 45 D youlist 74.125.235.38
  62. 46 D youlist 74.125.235.46
  63. 47 D youlist 74.125.236.74
  64. 48 D youlist 74.125.236.67
  65. 49 D youlist 74.125.236.64
  66. 50 D youlist 74.125.235.35
  67.  
  68. untuk address-list sudah ketangkap, tp masih tetap tidak bisa, Click here to enlarge
  69. untuk para suhu mohon bimbingannya.
  70.  
  71. makasih sebelumnya
  72. Ane pernah coba, mungkin bisa membantu :
  73. kalo dah dapet ipnya, bla bla bla sampai pada routing mark. Nah routing mark itu yang kita pakai di ip-route.
  74. Semoga membantu..
  75.  
  76.  
  77. cari tadu dulu default gateway nya ip public dari isp A dan isp B
  78. disini saya pake squid, jadi routing marknya in-interface squid aja, hehe.
  79.  
  80. tangkep lewat ip- firewall filter
  81.  
  82. contoh :
  83.  
  84. Code:
  85. chain=forward action=add-dst-to-address-list protocol=tcp
  86. address-list=squid-fm address-list-timeout=10m in-interface=ether3
  87. dst-port=80 content=youtube
  88.  
  89. abis itu buat mangle nya untuk routing mark
  90.  
  91. Code:
  92. chain=prerouting action=mark-routing new-routing-mark=fm.mr passthrough=no
  93. dst-address-list=squid-fm in-interface=ether3
  94.  
  95.  
  96. setelah itu tinggal routing statis di ip-route
  97.  
  98. Code:
  99. dst-address=0.0.0.0/0 gateway=192.168.125.1
  100. gateway-status=192.168.125.1 reachable eth1-FM distance=1 scope=30
  101. target-scope=10 routing-mark=fm.mr
  102. sampai sini sudah bisa jalan kok routing nya.
  103.  
  104.  
  105. permasalahan
  106. 2 ISP yang berbeda akan mempunyai IP tujuan yang berbeda, karena DNS biasanya di ambil dari proses routing yang tedekat dari ISP tersebut.
  107.  
  108. sebut saja telkom dan maxindo. hasil dns lookup mereka untuk beberapa domain tertentu pasti berbeda,
  109. dan terkadang IP tersebut hanya bisa di akses oleh block IP tertentu saja,
  110.  
  111. jadi gimana cara ngakalinnya ?
  112. pake DNS global, 8.8.8.8
  113.  
  114.  
  115.  
  116.  
  117. semoga membantu,
  118. salam hangat,
  119. fadhli.
  120.  
  121.  
  122.  
  123. Click here to enlarge Originally Posted by tukang kuli Click here to enlarge
  124. upps kebetulan
  125. ane juga ingin belajar pisah jalur untuk youtube.
  126.  
  127. ane buat:
  128. /ip firewall filter> pr
  129. 1 chain=forward action=add-dst-to-address-list protocol=tcp address-list=youlist address-list-timeout=0s dst-port=80 content=youtube
  130.  
  131. /ip firewall mangle> pr
  132. 9 X ;;; ----------YOUTUBE
  133. chain=prerouting action=mark-connection new-connection-mark=youmangle passthrough=yes protocol=tcp src-address-list=Local dst-address-list=youlist
  134.  
  135. 10 X ;;; PAKET & ROUTING MARK YOUTUBE
  136. chain=prerouting action=mark-routing new-routing-mark=Youtube passthrough=yes src-address-list=Local connection-mark=youmangle
  137.  
  138.  
  139. /ip firewall address-list> pr
  140. 45 D youlist 74.125.235.38
  141. 46 D youlist 74.125.235.46
  142. 47 D youlist 74.125.236.74
  143. 48 D youlist 74.125.236.67
  144. 49 D youlist 74.125.236.64
  145. 50 D youlist 74.125.235.35
  146.  
  147. untuk address-list sudah ketangkap, tp masih tetap tidak bisa, Click here to enlarge
  148. untuk para suhu mohon bimbingannya.
  149.  
  150. makasih sebelumnya
  151. kebetulan gan,,,,sya juga juga lagi mikirin itu, dan kebetulan ketemu dengan thread ini,,, jadi saya cobain,, dan sementara saya coba berhasil,,,
  152.  
  153. Saya coba nambahin dikit di dst-port 80 pada mangle nya kaya gini
  154. chain=prerouting action=mark-connection new-connection-mark=conyoutube passthrough=yes protocol=tcp dst-address-list=listyutub dst-port=80
  155.  
  156. chain=prerouting action=mark-routing new-routing-mark=linkyutub passthrough=yes protocol=tcp dst-port=80 connection-mark=conyoutube
  157.  
  158. Lalu di rout nya di di buatin, getway isp yg mau buat youtube di arahin ke routing marknya
  159.  
  160. ip route add gateway=192.168.10.1 routing-mark="linkyutub"
  161.  
  162. saya buat 1 link khusus buat yutub an saja dan 1 linknya lagi untuk web-web lainnya,,, dengan begitu, saat ini masih berjalan, dan masih di uji coba,,,
  163. Maaf kao saya salah, atau kalimatnya suakar di mengerti,,,saya juga lagi belajar dngn cara membca dan mencoba contoh yg sudah ada.
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement