SHARE
TWEET

1c

a guest Nov 14th, 2018 127 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Процедура ОбработкаПроведения(Отказ, Режим)
  2.     //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
  3.     // Данный фрагмент построен конструктором.
  4.     // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
  5.  
  6.     // регистр ОстаткиМатериалов Приход
  7.     Движения.ОстаткиМатериалов.Записывать = Истина;
  8.     Движения.СтоимостьМатериалов.Записывать = Истина;
  9.     Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
  10.         Движение = Движения.ОстаткиМатериалов.Добавить();
  11.         Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
  12.         Движение.Период = Дата;
  13.         Движение.Материал = ТекСтрокаМатериалы.Материал;
  14.         Движение.Склад = Склад;
  15.         Движение.Количество = ТекСтрокаМатериалы.Количество;
  16.        
  17.         Движение = Движения.СтоимостьМатериалов.Добавить();
  18.         Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
  19.         Движение.Период = Дата;
  20.         Движение.Материал = ТекСтрокаМатериалы.Материал;
  21.         Движение.Стоимость = ТекСтрокаМатериалы.Сумма;
  22.     КонецЦикла;
  23.  
  24.     //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
  25. КонецПроцедуры
  26.  
  27.  
  28. Процедура ОбработкаПроведения(Отказ, Режим)
  29.     //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
  30.     // Данный фрагмент построен конструктором.
  31.     // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
  32.  
  33.     // регистр ОстаткиМатериалов Расход
  34.     Движения.ОстаткиМатериалов.Записывать = Истина;
  35.     Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
  36.         Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда
  37.             Движение = Движения.ОстаткиМатериалов.Добавить();
  38.             Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
  39.             Движение.Период = Дата;
  40.             Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
  41.             Движение.Склад = Склад;
  42.             Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
  43.         КонецЕсли;
  44.     КонецЦикла;
  45.  
  46.     //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
  47. КонецПроцедуры
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top