Advertisement
Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- frr version 7.5.1
- frr defaults traditional
- hostname ga-router
- !
- ip router-id 10.0.26.1
- ip route 0.0.0.0/0 103.152.112.1 nexthop-vrf Hanataba
- ipv6 route ::/0 2602:feda:30:ae86::ae86 nexthop-vrf Hanataba
- ipv6 route 64:ff9b::/96 fe80::707b:b0ff:fed6:5266 eth1
- ipv6 route 2602:feda:30:ae86::ae86/128 eth0 nexthop-vrf Hanataba
- !
- vrf Hanataba
- ip route 0.0.0.0/0 103.152.112.1
- ip route 10.0.26.0/24 eth1 nexthop-vrf default
- ipv6 route ::/0 2602:feda:30:ae86::ae86
- exit-vrf
- !
- interface eth0 vrf Hanataba
- ipv6 address 2602:feda:30:ae86::3:22dc/64
- !
- interface BkGre
- ip address 10.0.26.1 peer 10.0.25.1/32
- ipv6 address fd29:22da:98ac:f37e:10:0:26:1/64
- !
- interface Cs
- ip address 10.0.26.1 peer 10.0.41.1/32
- ipv6 address fe80:a076:561e:c471:10:0:26:1/64
- !
- interface F
- ip address 10.0.26.1 peer 10.0.40.1/32
- ipv6 address fe80:b4a4:db58:29cc:10:0:26:1/64
- !
- interface Hs
- ip address 10.0.26.1 peer 10.0.0.1/32
- ipv6 address fe80:9d6f:1a9e:9596:10:0:26:1/64
- !
- interface La
- ip address 10.0.26.1 peer 10.0.1.1/32
- ip address 10.0.26.1 peer 10.0.11.1/32
- ipv6 address fe80:3552:b03a:a534:10:0:26:1/64
- !
- interface eth1
- ip address 10.0.26.1/24
- ipv6 address 2a0b:4340:a0:26::1/64
- no ipv6 nd suppress-ra
- !
- router bgp 65026
- no bgp ebgp-requires-policy
- no bgp default ipv4-unicast
- bgp default show-hostname
- bgp disable-ebgp-connected-route-check
- bgp confederation identifier 205532
- bgp confederation peers 65000 65025 65040 65041 65001
- no bgp network import-check
- neighbor 10.0.0.1 remote-as 65000
- neighbor 10.0.0.1 description Hs
- neighbor 10.0.0.1 bfd
- neighbor 10.0.0.1 bfd check-control-plane-failure
- neighbor 10.0.0.1 solo
- neighbor 10.0.0.1 capability dynamic
- neighbor 10.0.0.1 capability extended-nexthop
- neighbor 10.0.25.1 remote-as 65025
- neighbor 10.0.25.1 description Bk
- neighbor 10.0.25.1 bfd
- neighbor 10.0.25.1 bfd check-control-plane-failure
- neighbor 10.0.25.1 solo
- neighbor 10.0.25.1 capability dynamic
- neighbor 10.0.25.1 capability extended-nexthop
- neighbor fd29:22da:98ac:f37e:10:0:25:1 remote-as 65025
- neighbor fd29:22da:98ac:f37e:10:0:25:1 bfd
- neighbor fd29:22da:98ac:f37e:10:0:25:1 bfd check-control-plane-failure
- neighbor fd29:22da:98ac:f37e:10:0:25:1 capability dynamic
- neighbor fd29:22da:98ac:f37e:10:0:25:1 capability extended-nexthop
- neighbor fe80:3552:b03a:a534:10:0:1:1 remote-as 65001
- neighbor fe80:3552:b03a:a534:10:0:1:1 bfd
- neighbor fe80:3552:b03a:a534:10:0:1:1 bfd check-control-plane-failure
- neighbor fe80:3552:b03a:a534:10:0:1:1 interface La
- neighbor fe80:3552:b03a:a534:10:0:1:1 disable-connected-check
- neighbor fe80:3552:b03a:a534:10:0:1:1 capability dynamic
- neighbor fe80:3552:b03a:a534:10:0:1:1 capability extended-nexthop
- neighbor fe80:9d6f:1a9e:9596:10::1 remote-as 65000
- neighbor fe80:9d6f:1a9e:9596:10::1 description Hs
- neighbor fe80:9d6f:1a9e:9596:10::1 bfd
- neighbor fe80:9d6f:1a9e:9596:10::1 bfd check-control-plane-failure
- neighbor fe80:9d6f:1a9e:9596:10::1 interface Hs
- neighbor fe80:9d6f:1a9e:9596:10::1 disable-connected-check
- neighbor fe80:9d6f:1a9e:9596:10::1 capability dynamic
- neighbor fe80:9d6f:1a9e:9596:10::1 capability extended-nexthop
- neighbor fe80:a076:561e:c471:10:0:41:1 remote-as 65041
- neighbor fe80:a076:561e:c471:10:0:41:1 description Cs
- neighbor fe80:a076:561e:c471:10:0:41:1 bfd
- neighbor fe80:a076:561e:c471:10:0:41:1 bfd check-control-plane-failure
- neighbor fe80:a076:561e:c471:10:0:41:1 interface Cs
- neighbor fe80:a076:561e:c471:10:0:41:1 disable-connected-check
- neighbor fe80:a076:561e:c471:10:0:41:1 capability dynamic
- neighbor fe80:a076:561e:c471:10:0:41:1 capability extended-nexthop
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 remote-as 65040
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 bfd
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 bfd check-control-plane-failure
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 interface F
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 disable-connected-check
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 capability dynamic
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 capability extended-nexthop
- !
- address-family ipv4 unicast
- network 10.0.26.0/24
- network 10.1.26.0/24
- neighbor 10.0.0.1 activate
- neighbor 10.0.0.1 next-hop-self force
- neighbor 10.0.0.1 soft-reconfiguration inbound
- neighbor 10.0.25.1 activate
- neighbor 10.0.25.1 next-hop-self force
- neighbor 10.0.25.1 soft-reconfiguration inbound
- neighbor fd29:22da:98ac:f37e:10:0:25:1 activate
- neighbor fd29:22da:98ac:f37e:10:0:25:1 next-hop-self force
- neighbor fd29:22da:98ac:f37e:10:0:25:1 soft-reconfiguration inbound
- neighbor fe80:3552:b03a:a534:10:0:1:1 activate
- neighbor fe80:3552:b03a:a534:10:0:1:1 next-hop-self force
- neighbor fe80:3552:b03a:a534:10:0:1:1 soft-reconfiguration inbound
- neighbor fe80:9d6f:1a9e:9596:10::1 activate
- neighbor fe80:9d6f:1a9e:9596:10::1 next-hop-self force
- neighbor fe80:9d6f:1a9e:9596:10::1 soft-reconfiguration inbound
- neighbor fe80:a076:561e:c471:10:0:41:1 activate
- neighbor fe80:a076:561e:c471:10:0:41:1 next-hop-self force
- neighbor fe80:a076:561e:c471:10:0:41:1 soft-reconfiguration inbound
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 activate
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 next-hop-self force
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 soft-reconfiguration inbound
- exit-address-family
- !
- address-family ipv6 unicast
- network 64:ff9b::/96
- network 2a0b:4340:a0:26::/64
- neighbor 10.0.0.1 activate
- neighbor 10.0.0.1 next-hop-self force
- neighbor 10.0.0.1 soft-reconfiguration inbound
- neighbor 10.0.25.1 activate
- neighbor 10.0.25.1 next-hop-self force
- neighbor 10.0.25.1 soft-reconfiguration inbound
- neighbor fd29:22da:98ac:f37e:10:0:25:1 activate
- neighbor fd29:22da:98ac:f37e:10:0:25:1 next-hop-self force
- neighbor fd29:22da:98ac:f37e:10:0:25:1 soft-reconfiguration inbound
- neighbor fe80:3552:b03a:a534:10:0:1:1 activate
- neighbor fe80:3552:b03a:a534:10:0:1:1 next-hop-self force
- neighbor fe80:3552:b03a:a534:10:0:1:1 soft-reconfiguration inbound
- neighbor fe80:9d6f:1a9e:9596:10::1 activate
- neighbor fe80:9d6f:1a9e:9596:10::1 next-hop-self force
- neighbor fe80:9d6f:1a9e:9596:10::1 soft-reconfiguration inbound
- neighbor fe80:a076:561e:c471:10:0:41:1 activate
- neighbor fe80:a076:561e:c471:10:0:41:1 next-hop-self force
- neighbor fe80:a076:561e:c471:10:0:41:1 soft-reconfiguration inbound
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 activate
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 next-hop-self force
- neighbor fe80:b4a4:db58:29cc:10:0:40:1 soft-reconfiguration inbound
- import vrf Hanataba
- exit-address-family
- !
- router bgp 205532 vrf Hanataba
- no bgp ebgp-requires-policy
- no bgp default ipv4-unicast
- bgp default show-hostname
- bgp disable-ebgp-connected-route-check
- no bgp network import-check
- neighbor 2602:feda:30:ae86::ae86 remote-as 46997
- neighbor 2602:feda:30:ae86::ae86 interface eth0
- neighbor 2602:feda:30:ae86::ae86 disable-connected-check
- neighbor 2602:feda:30:ae86::ae86 capability dynamic
- neighbor 2602:feda:30:ae86::ae86 capability extended-nexthop
- !
- address-family ipv4 unicast
- neighbor 2602:feda:30:ae86::ae86 activate
- import vrf route-map UplinkVrf
- import vrf default
- exit-address-family
- !
- address-family ipv6 unicast
- network 2602:feda:20::/44
- network 2a0b:4340:a0::/44
- network 2a0b:4340:a0::/48
- neighbor 2602:feda:30:ae86::ae86 activate
- neighbor 2602:feda:30:ae86::ae86 next-hop-self force
- neighbor 2602:feda:30:ae86::ae86 soft-reconfiguration inbound
- neighbor 2602:feda:30:ae86::ae86 route-map PublicBgp out
- import vrf route-map UplinkVrf
- import vrf default
- exit-address-family
- !
- ip prefix-list PublicOut seq 10 deny 10.0.0.0/8
- ip prefix-list PublicOut seq 90 permit 0.0.0.0/0 ge 8 le 24
- ip prefix-list PublicOut seq 100 deny any
- !
- ipv6 prefix-list PublicOut seq 10 deny fd00::/8
- ipv6 prefix-list PublicOut seq 90 permit ::/0 ge 16 le 48
- ipv6 prefix-list PublicOut seq 100 deny any
- !
- bgp as-path access-list PublicOut permit 205532$
- bgp as-path access-list PublicOut permit 138037$
- bgp as-path access-list PublicOut permit 134575$
- bgp as-path access-list PublicOut permit ^$
- bgp as-path access-list PublicOut permit ^(\([(0-9 ]+\))?$
- !
- route-map PublicBgp permit 10
- match as-path PublicOut
- match ip address prefix-list PublicOut
- !
- route-map PublicBgp permit 20
- match as-path PublicOut
- match ipv6 address prefix-list PublicOut
- !
- route-map UplinkVrf permit 10
- match as-path PublicOut
- !
- line vty
- !
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement