SHARE
TWEET

Error "Yarn"

a guest Apr 11th, 2019 88 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Microsoft Windows [Version 10.0.17134.706]
  2. (c) 2018 Microsoft Corporation. All rights reserved.
  3.  
  4. E:\WestgateXL>yarn
  5. yarn install v1.15.2
  6. info No lockfile found.
  7. $ node ./internals/scripts/CheckYarn.js
  8. warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
  9. [1/4] Resolving packages...
  10. warning antd > create-react-context > fbjs > core-js@1.2.7: core-js@<2.6.5 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
  11. warning electron > electron-download > nugget > progress-stream > through2 > xtend > object-keys@0.4.0:
  12. warning stylefmt > stylelint > stylehacks > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
  13. warning stylefmt > stylelint > autoprefixer > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
  14. warning stylefmt > stylelint > doiuse > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
  15. warning stylefmt > stylelint > file-entry-cache > flat-cache > circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
  16. [2/4] Fetching packages...
  17. info fsevents@1.2.7: The platform "win32" is incompatible with this module.
  18. info "fsevents@1.2.7" is an optional dependency and failed compatibility check. Excluding it from installation.
  19. [3/4] Linking dependencies...
  20. warning " > connected-react-router@6.3.2" has unmet peer dependency "prop-types@^15.0.0 || ^16.0.0".
  21. warning " > discord-rpc@3.0.1" has unmet peer dependency "register-scheme@github:devsnek/node-register-scheme".
  22. warning " > react-contextmenu@2.11.0" has unmet peer dependency "prop-types@^15.0.0".
  23. warning " > react-sortable-hoc@1.8.3" has unmet peer dependency "prop-types@^15.5.7".
  24. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-config-prettier@^3.3.0".
  25. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-import-resolver-webpack@^0.10.1".
  26. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-plugin-compat@^2.6.3".
  27. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-plugin-jsx-a11y@6.1.2".
  28. warning " > eslint-plugin-prettier@3.0.1" has unmet peer dependency "prettier@>= 1.13.0".
  29. warning " > postcss-syntax@0.36.2" has unmet peer dependency "postcss@>=5.0.0".
  30. [4/4] Building fresh packages...
  31. success Saved lockfile.
  32. $ yarn flow-typed && cross-env ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true cross-env ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true electron-builder install-app-deps package.json && yarn build-dll
  33. yarn run v1.15.2
  34. $ rimraf flow-typed/npm && flow-typed install --overwrite || true
  35. [before-after-hook]: "Hook()" repurposing warning, use "Hook.Collection()". Read more: https://git.io/upgrade-before-after-hook-to-1.4
  36. • Found 149 dependencies in package.json to install libdefs for. Searching...
  37. • rebasing flow-typed cache...
  38. ERROR: Unable to rebase the local cache repo. Unable to find `git` installed on this system: not found: git
  39.  
  40. NOTE: Unable to rebase local cache! If you don't currently have internet connectivity, no worries -- we'll update the local cache the next time you do.
  41.  
  42. • Installing 23 libDefs...
  43.   !! Failed to install antd at E:\WestgateXL\flow-typed\npm\antd_v3.x.x.js
  44.   ERROR: Unable to find `git` installed on this system: not found: git
  45.   !! Failed to install bluebird at E:\WestgateXL\flow-typed\npm\bluebird_v3.x.x.js
  46.   ERROR: Unable to find `git` installed on this system: not found: git
  47.   !! Failed to install axios at E:\WestgateXL\flow-typed\npm\axios_v0.18.x.js
  48.   ERROR: Unable to find `git` installed on this system: not found: git
  49.   !! Failed to install react-transition-group at E:\WestgateXL\flow-typed\npm\react-transition-group_v2.x.x.js
  50.   ERROR: Unable to find `git` installed on this system: not found: git
  51.   !! Failed to install lodash at E:\WestgateXL\flow-typed\npm\lodash_v4.x.x.js
  52.   ERROR: Unable to find `git` installed on this system: not found: git
  53.   !! Failed to install fs-extra at E:\WestgateXL\flow-typed\npm\fs-extra_v7.x.x.js
  54.   ERROR: Unable to find `git` installed on this system: not found: git
  55.   !! Failed to install directory-tree at E:\WestgateXL\flow-typed\npm\directory-tree_v2.x.x.js
  56.   ERROR: Unable to find `git` installed on this system: not found: git
  57.   !! Failed to install react-hot-loader at E:\WestgateXL\flow-typed\npm\react-hot-loader_v4.6.x.js
  58.   ERROR: Unable to find `git` installed on this system: not found: git
  59.   !! Failed to install redux at E:\WestgateXL\flow-typed\npm\redux_v4.x.x.js
  60.   ERROR: Unable to find `git` installed on this system: not found: git
  61.   !! Failed to install jest at E:\WestgateXL\flow-typed\npm\jest_v24.x.x.js
  62.   ERROR: Unable to find `git` installed on this system: not found: git
  63.   !! Failed to install react-router at E:\WestgateXL\flow-typed\npm\react-router_v4.x.x.js
  64.   ERROR: Unable to find `git` installed on this system: not found: git
  65.   !! Failed to install minimist at E:\WestgateXL\flow-typed\npm\minimist_v1.x.x.js
  66.   ERROR: Unable to find `git` installed on this system: not found: git
  67.   !! Failed to install history at E:\WestgateXL\flow-typed\npm\history_v4.x.x.js
  68.   ERROR: Unable to find `git` installed on this system: not found: git
  69.   !! Failed to install chalk at E:\WestgateXL\flow-typed\npm\chalk_v2.x.x.js
  70.   ERROR: Unable to find `git` installed on this system: not found: git
  71.   !! Failed to install webpack at E:\WestgateXL\flow-typed\npm\webpack_v4.x.x.js
  72.   ERROR: Unable to find `git` installed on this system: not found: git
  73.   !! Failed to install react-loadable at E:\WestgateXL\flow-typed\npm\react-loadable_v5.x.x.js
  74.   ERROR: Unable to find `git` installed on this system: not found: git
  75.   !! Failed to install rimraf at E:\WestgateXL\flow-typed\npm\rimraf_v2.x.x.js
  76.   ERROR: Unable to find `git` installed on this system: not found: git
  77.   !! Failed to install flow-bin at E:\WestgateXL\flow-typed\npm\flow-bin_v0.x.x.js
  78.   ERROR: Unable to find `git` installed on this system: not found: git
  79.  
  80. E:\WestgateXL>yarn
  81. yarn install v1.15.2
  82. [1/4] Resolving packages...
  83. success Nothing to install.
  84. success Saved lockfile.
  85. Done in 0.32s.
  86.  
  87. E:\WestgateXL>yarn
  88. yarn install v1.15.2
  89. $ node ./internals/scripts/CheckYarn.js
  90. [1/4] Resolving packages...
  91. [2/4] Fetching packages...
  92. info fsevents@1.2.7: The platform "win32" is incompatible with this module.
  93. info "fsevents@1.2.7" is an optional dependency and failed compatibility check. Excluding it from installation.
  94. [3/4] Linking dependencies...
  95. warning "antd > @ant-design/icons-react@1.1.2" has incorrect peer dependency "@ant-design/icons@~1.1.0".
  96. warning " > connected-react-router@6.3.2" has unmet peer dependency "prop-types@^15.0.0 || ^16.0.0".
  97. warning " > discord-rpc@3.0.1" has unmet peer dependency "register-scheme@github:devsnek/node-register-scheme".
  98. warning " > react-contextmenu@2.10.0" has unmet peer dependency "prop-types@^15.0.0".
  99. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-config-prettier@^3.3.0".
  100. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-import-resolver-webpack@^0.10.1".
  101. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-plugin-compat@^2.6.3".
  102. warning " > eslint-config-erb@0.0.2" has incorrect peer dependency "eslint-plugin-jsx-a11y@6.1.2".
  103. warning " > eslint-plugin-prettier@3.0.1" has unmet peer dependency "prettier@>= 1.13.0".
  104. warning "jest > jest-cli > @jest/core > jest-resolve-dependencies@24.5.0" has unmet peer dependency "jest-resolve@^24.1.0".
  105. warning "jest > jest-cli > jest-config > jest-resolve@24.5.0" has unmet peer dependency "jest-haste-map@^24.0.0".
  106. warning " > postcss-syntax@0.36.2" has unmet peer dependency "postcss@>=5.0.0".
  107. [4/4] Building fresh packages...
  108. $ yarn flow-typed && cross-env ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true cross-env ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true electron-builder install-app-deps package.json && yarn build-dll
  109. yarn run v1.15.2
  110. $ rimraf flow-typed/npm && flow-typed install --overwrite || true
  111. [before-after-hook]: "Hook()" repurposing warning, use "Hook.Collection()". Read more: https://git.io/upgrade-before-after-hook-to-1.4
  112. • Found 149 dependencies in package.json to install libdefs for. Searching...
  113. • rebasing flow-typed cache...
  114. ERROR: Unable to rebase the local cache repo. Unable to find `git` installed on this system: not found: git
  115.  
  116. NOTE: Unable to rebase local cache! If you don't currently have internet connectivity, no worries -- we'll update the local cache the next time you do.
  117.  
  118. • Installing 23 libDefs...
  119.   !! Failed to install antd at E:\WestgateXL\flow-typed\npm\antd_v3.x.x.js
  120.   ERROR: Unable to find `git` installed on this system: not found: git
  121.   !! Failed to install fs-extra at E:\WestgateXL\flow-typed\npm\fs-extra_v7.x.x.js
  122.   ERROR: Unable to find `git` installed on this system: not found: git
  123.   !! Failed to install directory-tree at E:\WestgateXL\flow-typed\npm\directory-tree_v2.x.x.js
  124.   ERROR: Unable to find `git` installed on this system: not found: git
  125.   !! Failed to install react-router at E:\WestgateXL\flow-typed\npm\react-router_v4.x.x.js
  126.   ERROR: Unable to find `git` installed on this system: not found: git
  127.   !! Failed to install enzyme at E:\WestgateXL\flow-typed\npm\enzyme_v3.x.x.js
  128.   ERROR: Unable to find `git` installed on this system: not found: git
  129.   !! Failed to install react-router-dom at E:\WestgateXL\flow-typed\npm\react-router-dom_v4.x.x.js
  130.   ERROR: Unable to find `git` installed on this system: not found: git
  131.   !! Failed to install react-color at E:\WestgateXL\flow-typed\npm\react-color_v2.x.x.js
  132.   ERROR: Unable to find `git` installed on this system: not found: git
  133.   !! Failed to install bluebird at E:\WestgateXL\flow-typed\npm\bluebird_v3.x.x.js
  134.   ERROR: Unable to find `git` installed on this system: not found: git
  135.   !! Failed to install register at E:\WestgateXL\flow-typed\npm\@babel\register_v7.x.x.js
  136.   ERROR: Unable to find `git` installed on this system: not found: git
  137.   !! Failed to install lodash at E:\WestgateXL\flow-typed\npm\lodash_v4.x.x.js
  138.   ERROR: Unable to find `git` installed on this system: not found: git
  139.   !! Failed to install axios at E:\WestgateXL\flow-typed\npm\axios_v0.18.x.js
  140.   ERROR: Unable to find `git` installed on this system: not found: git
  141.   !! Failed to install react-loadable at E:\WestgateXL\flow-typed\npm\react-loadable_v5.x.x.js
  142.   ERROR: Unable to find `git` installed on this system: not found: git
  143.   !! Failed to install react-test-renderer at E:\WestgateXL\flow-typed\npm\react-test-renderer_v16.x.x.js
  144.   ERROR: Unable to find `git` installed on this system: not found: git
  145.   !! Failed to install history at E:\WestgateXL\flow-typed\npm\history_v4.x.x.js
  146.   ERROR: Unable to find `git` installed on this system: not found: git
  147.   !! Failed to install rimraf at E:\WestgateXL\flow-typed\npm\rimraf_v2.x.x.js
  148.   ERROR: Unable to find `git` installed on this system: not found: git
  149.   !! Failed to install minimist at E:\WestgateXL\flow-typed\npm\minimist_v1.x.x.js
  150.   ERROR: Unable to find `git` installed on this system: not found: git
  151.   !! Failed to install react-hot-loader at E:\WestgateXL\flow-typed\npm\react-hot-loader_v4.6.x.js
  152.   ERROR: Unable to find `git` installed on this system: not found: git
  153.   !! Failed to install redux at E:\WestgateXL\flow-typed\npm\redux_v4.x.x.js
  154.   ERROR: Unable to find `git` installed on this system: not found: git
  155.   !! Failed to install webpack at E:\WestgateXL\flow-typed\npm\webpack_v4.x.x.js
  156.   ERROR: Unable to find `git` installed on this system: not found: git
  157.   !! Failed to install chalk at E:\WestgateXL\flow-typed\npm\chalk_v2.x.x.js
  158.   ERROR: Unable to find `git` installed on this system: not found: git
  159.   !! Failed to install jest at E:\WestgateXL\flow-typed\npm\jest_v24.x.x.js
  160.   ERROR: Unable to find `git` installed on this system: not found: git
  161.   !! Failed to install react-transition-group at E:\WestgateXL\flow-typed\npm\react-transition-group_v2.x.x.js
  162.   ERROR: Unable to find `git` installed on this system: not found: git
  163.   !! Failed to install flow-bin at E:\WestgateXL\flow-typed\npm\flow-bin_v0.x.x.js
  164.   ERROR: Unable to find `git` installed on this system: not found: git
  165. 'true' is not recognized as an internal or external command,
  166. operable program or batch file.
  167. error Command failed with exit code 1.
  168. info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
  169. error Command failed with exit code 1.
  170. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top