jeromeonweb

Magento 2 - Installation through composer on Windows

Dec 17th, 2014
432
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Loading composer repositories with package information
  2. Installing dependencies (including require-dev)
  3. Your requirements could not be resolved to an installable set of packages.
  4.  
  5. Problem 1
  6. - The requested package php could not be found in any version, there may be
  7. a typo in the package name.
  8. Problem 2
  9. - The requested package php could not be found in any version, there may be
  10. a typo in the package name.
  11. Problem 3
  12. - Installation request for zendframework/zend-stdlib 2.3.1 -> satisfiable by
  13. zendframework/zend-stdlib[2.3.1].
  14. - zendframework/zend-stdlib 2.3.1 requires php >=5.3.23 -> no matching packa
  15. ge found.
  16. Problem 4
  17. - Installation request for zendframework/zend-code 2.3.1 -> satisfiable by z
  18. endframework/zend-code[2.3.1].
  19. - zendframework/zend-code 2.3.1 requires php >=5.3.23 -> no matching package
  20. found.
  21. Problem 5
  22. - Installation request for zendframework/zend-server 2.3.1 -> satisfiable by
  23. zendframework/zend-server[2.3.1].
  24. - zendframework/zend-server 2.3.1 requires php >=5.3.23 -> no matching packa
  25. ge found.
  26. Problem 6
  27. - Installation request for zendframework/zend-soap 2.3.1 -> satisfiable by z
  28. endframework/zend-soap[2.3.1].
  29. - zendframework/zend-soap 2.3.1 requires php >=5.3.23 -> no matching package
  30. found.
  31. Problem 7
  32. - Installation request for zendframework/zend-uri 2.3.1 -> satisfiable by ze
  33. ndframework/zend-uri[2.3.1].
  34. - zendframework/zend-uri 2.3.1 requires php >=5.3.23 -> no matching package
  35. found.
  36. Problem 8
  37. - Installation request for zendframework/zend-validator 2.3.1 -> satisfiable
  38. by zendframework/zend-validator[2.3.1].
  39. - zendframework/zend-validator 2.3.1 requires php >=5.3.23 -> no matching pa
  40. ckage found.
  41. Problem 9
  42. - Installation request for zendframework/zend-console 2.3.1 -> satisfiable b
  43. y zendframework/zend-console[2.3.1].
  44. - zendframework/zend-console 2.3.1 requires php >=5.3.23 -> no matching pack
  45. age found.
  46. Problem 10
  47. - Installation request for zendframework/zend-modulemanager 2.3.1 -> satisfi
  48. able by zendframework/zend-modulemanager[2.3.1].
  49. - zendframework/zend-modulemanager 2.3.1 requires php >=5.3.23 -> no matchin
  50. g package found.
  51. Problem 11
  52. - Installation request for zendframework/zend-mvc 2.3.1 -> satisfiable by ze
  53. ndframework/zend-mvc[2.3.1].
  54. - zendframework/zend-mvc 2.3.1 requires php >=5.3.23 -> no matching package
  55. found.
  56. Problem 12
  57. - Installation request for zendframework/zend-text 2.3.1 -> satisfiable by z
  58. endframework/zend-text[2.3.1].
  59. - zendframework/zend-text 2.3.1 requires php >=5.3.23 -> no matching package
  60. found.
  61. Problem 13
  62. - Installation request for zendframework/zend-eventmanager 2.3.1 -> satisfia
  63. ble by zendframework/zend-eventmanager[2.3.1].
  64. - zendframework/zend-eventmanager 2.3.1 requires php >=5.3.23 -> no matching
  65. package found.
  66. Problem 14
  67. - Installation request for zendframework/zend-view 2.3.1 -> satisfiable by z
  68. endframework/zend-view[2.3.1].
  69. - zendframework/zend-view 2.3.1 requires php >=5.3.23 -> no matching package
  70. found.
  71. Problem 15
  72. - Installation request for zendframework/zend-servicemanager 2.3.1 -> satisf
  73. iable by zendframework/zend-servicemanager[2.3.1].
  74. - zendframework/zend-servicemanager 2.3.1 requires php >=5.3.23 -> no matchi
  75. ng package found.
  76. Problem 16
  77. - Installation request for zendframework/zend-json 2.3.1 -> satisfiable by z
  78. endframework/zend-json[2.3.1].
  79. - zendframework/zend-json 2.3.1 requires php >=5.3.23 -> no matching package
  80. found.
  81. Problem 17
  82. - Installation request for zendframework/zend-config 2.3.1 -> satisfiable by
  83. zendframework/zend-config[2.3.1].
  84. - zendframework/zend-config 2.3.1 requires php >=5.3.23 -> no matching packa
  85. ge found.
  86. Problem 18
  87. - Installation request for zendframework/zend-form 2.3.1 -> satisfiable by z
  88. endframework/zend-form[2.3.1].
  89. - zendframework/zend-form 2.3.1 requires php >=5.3.23 -> no matching package
  90. found.
  91. Problem 19
  92. - Installation request for zendframework/zend-di 2.3.1 -> satisfiable by zen
  93. dframework/zend-di[2.3.1].
  94. - zendframework/zend-di 2.3.1 requires php >=5.3.23 -> no matching package f
  95. ound.
  96. Problem 20
  97. - Installation request for zendframework/zend-serializer 2.3.1 -> satisfiabl
  98. e by zendframework/zend-serializer[2.3.1].
  99. - zendframework/zend-serializer 2.3.1 requires php >=5.3.23 -> no matching p
  100. ackage found.
  101. Problem 21
  102. - Installation request for zendframework/zend-log 2.3.1 -> satisfiable by ze
  103. ndframework/zend-log[2.3.1].
  104. - zendframework/zend-log 2.3.1 requires php >=5.3.23 -> no matching package
  105. found.
  106. Problem 22
  107. - Installation request for zendframework/zend-http 2.3.1 -> satisfiable by z
  108. endframework/zend-http[2.3.1].
  109. - zendframework/zend-http 2.3.1 requires php >=5.3.23 -> no matching package
  110. found.
  111. Problem 23
  112. - Installation request for magento/zendframework1 1.12.9 -> satisfiable by m
  113. agento/zendframework1[1.12.9].
  114. - magento/zendframework1 1.12.9 requires php >=5.2.11 -> no matching package
  115. found.
  116. Problem 24
  117. - Installation request for composer/composer 1.0.0-alpha8 -> satisfiable by
  118. composer/composer[1.0.0-alpha8].
  119. - composer/composer 1.0.0-alpha8 requires php >=5.3.2 -> no matching package
  120. found.
  121. Problem 25
  122. - Installation request for phpunit/phpunit 4.1.0 -> satisfiable by phpunit/p
  123. hpunit[4.1.0].
  124. - phpunit/phpunit 4.1.0 requires php >=5.3.3 -> no matching package found.
  125. Problem 26
  126. - Installation request for squizlabs/php_codesniffer 1.5.3 -> satisfiable by
  127. squizlabs/php_codesniffer[1.5.3].
  128. - squizlabs/php_codesniffer 1.5.3 requires php >=5.1.2 -> no matching packag
  129. e found.
  130. Problem 27
  131. - phpmd/phpmd 2.1.3 requires php >=5.3.0 -> no matching package found.
  132. - phpmd/phpmd 2.1.2 requires php >=5.3.0 -> no matching package found.
  133. - phpmd/phpmd 2.1.1 requires php >=5.3.0 -> no matching package found.
  134. - phpmd/phpmd 2.0.0 requires php >=5.3.0 -> no matching package found.
  135. - phpmd/phpmd 1.5.1 requires php >=5.3.0 -> no matching package found.
  136. - phpmd/phpmd 1.5.0 requires php >=5.3.0 -> no matching package found.
  137. - phpmd/phpmd 1.4.1 requires php >=5.3.0 -> no matching package found.
  138. - phpmd/phpmd 1.4.0 requires php >=5.3.0 -> no matching package found.
  139. - Installation request for phpmd/phpmd @stable -> satisfiable by phpmd/phpmd
  140. [1.4.0, 1.4.1, 1.5.0, 1.5.1, 2.0.0, 2.1.1, 2.1.2, 2.1.3].
  141.  
  142. Potential causes:
  143. - A typo in the package name
  144. - The package is not available in a stable-enough version according to your min
  145. imum-stability setting
  146. see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> f
  147. or more details.
  148.  
  149. Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common
  150. problems.
RAW Paste Data