SHARE
TWEET

4_47

a guest Aug 27th, 2018 160 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "semnome"
  2.  
  3. var
  4.    num, valor:inteiro
  5.    resultado:caracter
  6. inicio
  7.    escreval ("Digite um valor Decimal: ")
  8.    leia(num)
  9.    valor <- (num)
  10.    enquanto (num > 0) faca
  11.             escolha (num%16)
  12.                     caso 1
  13.                     resultado <- ("1" + resultado)
  14.                     caso 2
  15.                     resultado <- ("2" + resultado)
  16.                     caso 3
  17.                     resultado <- ("3" + resultado)
  18.                     caso 4
  19.                     resultado <- ("4" + resultado)
  20.                     caso 5
  21.                     resultado <- ("5" + resultado)
  22.                     caso 6
  23.                     resultado <- ("6" + resultado)
  24.                     caso 7
  25.                     resultado <- ("7" + resultado)
  26.                     caso 8
  27.                     resultado <- ("8" + resultado)
  28.                     caso 9
  29.                     resultado <- ("9" + resultado)
  30.                     caso 10
  31.                     resultado <- ("A" + resultado)
  32.                     caso 11
  33.                     resultado <- ("B" + resultado)
  34.                     caso 12
  35.                     resultado <- ("C" + resultado)
  36.                     caso 13
  37.                     resultado <- ("D" + resultado)
  38.                     caso 14
  39.                     resulado <- ("E" + resultado)
  40.                     caso 15
  41.                     resultado <- ("F" + resultado)
  42.             fimEscolha
  43.             num <- (num \ 16)
  44.    fimenquanto
  45.    escreval ("O valor: ", valor, " em é: ", resultado, " em hexadecimal ")
  46. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top