Advertisement
rootplg3544

ICMP MANTAP

Oct 30th, 2018
444
0
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
text 2.18 KB | None | 0 0
  1. 1- CONTOH DARI PING / ICMP ANTRIAN MENGGUNAKAN SINGKAT SIMPEL QUEUE
  2. ###########################################
  3. # PING/ICMP Priority Script for Mikrotik
  4. # Syed Jahanzaib / aacable @ hotmail . com
  5. # https://aacable.wordpress.com
  6. ###########################################
  7.  
  8. # Connection PACKET marking for ICMP, valid for both 5.x and 6.x ROS versions
  9. /ip firewall mangle
  10. add chain=prerouting protocol=icmp action=mark-connection new-connection-mark=icmp-con passthrough=yes comment="" disabled=no
  11. # PACKET marking for ICMP, valid for both 5.x and 6.x ROS versions
  12. add chain=prerouting protocol=icmp connection-mark=icmp-con action=mark-packet new-packet-mark=icmp-pkt passthrough=no comment="" disabled=no
  13.  
  14. # QUEUE TREE For Mikrotik 5.x Version to allow 128k Bandwidth for ICMP/PING Packets
  15. /queue tree
  16. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k max-limit=128k name=Hi-Prio-to-icmp-aacable packet-mark=icmp-pkt parent=global-out priority=1 queue=default
  17. # For 5.x All Done. Now check your PING results. t.c
  18.  
  19. ###################################################################
  20. # IF you are using Mikrotik 6.x then above queue wont work,instead use SIMPLE queue
  21. # SIMPLE QUEUE approach is valid For both 5.x and 6.x Versions.
  22. # DO Make sure to move it on TOP [order wise 0]
  23.  
  24. /queue simple
  25. add max-limit=128k/128k name=ICMP_Priority packet-marks=icmp-pkt target=""
  26.  
  27. 2- SECOND EXAMPLE OF PING/ICMP QUEUE USING PCQ TREE | (FOR PER USER DISTRIBUTION)
  28. /ip firewall mangle
  29. add action=mark-packet chain=prerouting comment="Mark ICMP I / zaib" new-packet-mark=ping_pkts_i protocol=icmp
  30. add action=mark-packet chain=postrouting comment="Mark ICMP O / zaib" new-packet-mark=ping_pkts_o protocol=icmp
  31.  
  32. /queue type
  33. add kind=pcq name="ping_pkts_i_32K" pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=32k pcq-src-address6-mask=64
  34. add kind=pcq name="ping_pkts_o_32K" pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=32k pcq-src-address6-mask=64
  35.  
  36.  
  37. /queue tree
  38. add name=ping_pkts_i packet-mark=ping_pkts_i parent=global-out queue="ping_pkts_i_32K / zaib"
  39. add name=ping_pkts_o packet-mark=ping_pkts_o parent=global-out queue="ping_pkts_o_32K / zaib"
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement