SHARE
TWEET

Untitled

a guest Jun 18th, 2019 48 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. python27 setup.py build_ext -i  -I /usr/include/libxml2 --with-xslt-config=/opt/xslt/bin/xslt-config
  2.      
  3. /opt/python27/lib/python2.7/site-packages/Cython-0.14.1-py2.7-linux-x86_64.egg/Cython/Includes/libc/string.pxd
  4. Compiling src/lxml/lxml.etree.pyx because it changed.
  5. Compiling src/lxml/lxml.objectify.pyx because it changed.
  6.  
  7. Error compiling Cython file:
  8. ------------------------------------------------------------
  9. ...
  10. u"""The ``lxml.etree`` module implements the extended ElementTree API
  11. for XML.
  12. """
  13.  
  14. from __future__ import absolute_import
  15.                       ^
  16. ------------------------------------------------------------
  17.  
  18. /var/www/html/djangosites/SERVER/temp/lxml-lxml-a9e9f15/src/lxml/lxml.etree.pyx:5:23: future feature absolute_import is not defined
  19. Traceback (most recent call last):
  20.   File "setup.py", line 218, in <module>
  21.     **setup_extra_options()
  22.   File "setup.py", line 130, in setup_extra_options
  23.     STATIC_CFLAGS, STATIC_BINARIES)
  24.   File "/var/www/html/djangosites/SERVER/temp/lxml-lxml-a9e9f15/setupinfo.py", line 147, in ext_modules
  25.     result = cythonize(result)
  26.   File "/opt/python27/lib/python2.7/site-packages/Cython-0.14.1-py2.7-linux-x86_64.egg/Cython/Build/Dependencies.py", line 505, in cythonize
  27.     cythonize_one(pyx_file, c_file, options)
  28.   File "/opt/python27/lib/python2.7/site-packages/Cython-0.14.1-py2.7-linux-x86_64.egg/Cython/Build/Dependencies.py", line 526, in cythonize_one
  29.     raise CompileError(None, pyx_file)
  30. Cython.Compiler.Errors.CompileError: src/lxml/lxml.etree.pyx
  31.      
  32. ]# python27
  33. Python 2.7 (r27:82500, May 26 2011, 17:42:13)
  34. [GCC 4.1.2 20080704 (Red Hat 4.1.2-50)] on linux2
  35. Type "help", "copyright", "credits" or "license" for more information.
  36. >>> from __future__ import absolute_import
  37. >>>
  38.      
  39. pip install "Cython>=0.18"
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top