daily pastebin goal
54%
SHARE
TWEET

4_48

a guest Aug 27th, 2018 149 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "semnome"
  2.  
  3. var
  4.    n, cdn, cd, b:inteiro
  5.    aux1, aux1r, aux2, aux2r, aux3, aux3r:inteiro
  6.    aux4, aux4r:inteiro
  7. inicio
  8.       escreva("Informe o número em binário: ")
  9.       leia(n)
  10.       cdn <- n
  11.       repita
  12.             cd <- cd + 1
  13.             cdn <- cdn\10
  14.       ate(cdn = 0)
  15.       escolha (cd)
  16.               caso 1
  17.                    b <- n * 1
  18.               caso 2
  19.                    b <- ((n\10)*2)   + ((n%10)*1)
  20.               caso 3
  21.                    b <- ((n\100)*4)   + ((n%100)\10)*2) + ((n%100)%10)*1)
  22.               caso 4
  23.                    aux1 <- (n\1000)*8
  24.                    aux1r <- (n%1000)
  25.                    aux2 <- (aux1r\100) * 4
  26.                    aux2r <- aux1r%100
  27.                    aux3 <- (aux2r\10) * 2
  28.                    aux3r <- (aux2r%10) * 1
  29.                    b <- aux1 + aux2 + aux3 + aux3r
  30.               caso 5
  31.                    aux1 <- (n\10000)*16
  32.                    aux1r <- (n%10000)
  33.                    aux2 <- (aux1r\1000) * 8
  34.                    aux2r <- aux1r%1000
  35.                    aux3 <- (aux2r\100) * 4
  36.                    aux3r <- (aux2r%100)
  37.                    aux4 <- (aux3r\10) * 2
  38.                    aux4r <- (aux3r%10) * 1
  39.                    b <- aux1 + aux2 + aux3 + aux3r + aux4 + aux4r
  40.       fimescolha
  41.       escreva(b)
  42. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top