SHARE
TWEET

Untitled

smeh Mar 6th, 2018 105 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Если PSer = "314" ИЛИ PSer = "315" ИЛИ PSer = "364" ИЛИ PSer = "365" ИЛИ PSer = "368" ИЛИ PSer = "369"
  2.         ИЛИ PSer = "316" ИЛИ PSer = "366"Тогда
  3.        
  4.         Если idri = "4" Тогда
  5.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000066");
  6.         Иначе
  7.            
  8.             Если InsProgram = "1" Тогда
  9.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  10.             ИначеЕсли InsProgram = "2" Тогда
  11.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  12.             ИначеЕсли InsProgram = "3" Тогда
  13.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  14.             ИначеЕсли InsProgram = "4" Тогда
  15.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000005");
  16.             ИначеЕсли InsProgram = "5" Тогда
  17.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  18.             Иначе
  19.                 Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  20.             КонецЕсли;
  21.            
  22.         КонецЕсли;    
  23.        
  24.     ИначеЕсли PSer = "319" ИЛИ PSer = "320" ИЛИ PSer = "321" ИЛИ PSer = "322" ИЛИ PSer = "323" ИЛИ
  25.        
  26.         PSer = "336" Тогда    
  27.        
  28.         Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000111");
  29.        
  30.     ИначеЕсли PSer = "250" ИЛИ PSer = "251" ИЛИ PSer = "252" ИЛИ PSer = "253" ИЛИ PSer = "255"  ИЛИ PSer = "291" ИЛИ PSer = "293" ИЛИ
  31.         PSer = "294" ИЛИ PSer = "295" ИЛИ PSer = "296" ИЛИ PSer = "Е53" Тогда
  32.        
  33.         Если InsProgram = "1" Тогда
  34.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");
  35.         ИначеЕсли InsProgram = "3" Тогда
  36.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");
  37.         ИначеЕсли InsProgram = "4" Тогда
  38.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");
  39.         ИначеЕсли InsProgram = "5" Тогда
  40.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");
  41.         Иначе
  42.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");
  43.         КонецЕсли;
  44.        
  45.     ИначеЕсли PSer = "249" ИЛИ PSer = "256" ИЛИ PSer = "Е54" ИЛИ PSer = "Е56" ИЛИ PSer = "Е57" Тогда
  46.         Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000112");    
  47.     ИначеЕсли PSer = "257"  Тогда
  48.         Возврат Справочники.скСтраховыеРиски.НайтиПоНаименованию("Эксперт");
  49.        
  50.     ИначеЕсли PSer = "215"  Тогда
  51.         Если idri = "4" Тогда
  52.             Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000066");
  53.         КонецЕсли;
  54.     ИначеЕсли PSer = "ССС" ИЛИ PSer = "ЕЕЕ" ИЛИ PSer = "ХХХ" Тогда
  55.         Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000036");
  56.     Иначе
  57.         Возврат Справочники.скСтраховыеРиски.НайтиПоКоду("ICC (С)000000020");
  58.     КонецЕсли;
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top