daily pastebin goal
45%
SHARE
TWEET

Untitled

a guest Mar 19th, 2019 45 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. var
  2.  
  3. Notafim, Faltas, nota1, nota2, nota3: Real
  4.  
  5. Idade, notatrab, Media, Peso1, Peso2: Real
  6.  
  7. Result, Reprovado: Caractere
  8.  
  9. inicio
  10. // Seção de Comandos
  11.  
  12. Escreva ("Digite o número de faltas: ")
  13. Leia (Faltas)
  14.  
  15. Escreva ("Digite a nota da primeiroa prova: ")
  16. Leia (nota1)
  17.  
  18. Escreva ("Digite a nota da segunda prova: ")
  19. Leia (nota2)
  20.  
  21. Escreva ("Digite a nota da terceira prova: ")
  22. Leia (nota3)
  23.  
  24. Escreva ("Digite a nota do trabalho final: ")
  25. Leia (notatrab)
  26.  
  27. Limpatela
  28.  
  29. Se (nota1>nota2) e (nota2>nota3) entao
  30.    Media <- (nota1+nota2) / 2
  31. Senao
  32.    Se(nota1>nota2) e (nota2<nota3) entao
  33.       Media <- (nota1+nota3) / 2
  34.    Senao
  35.       Media <- (nota2+nota3) / 2
  36.    Fimse
  37. Fimse
  38.  
  39. Se Faltas < 5 entao
  40.    Peso1 <- 3
  41. Senao
  42.    Se (Faltas > 5) e (Faltas < 10) entao
  43.       Peso1 <- 2
  44.    Senao
  45.       Peso1 <- 1
  46.    Fimse
  47. Fimse
  48.  
  49. Se Idade <= 17 entao
  50.    Peso2 <- 1
  51. Senao
  52.    Se Idade >= 18 <= 50 entao
  53.       Peso2 <- 2
  54.    Senao
  55.       Peso2 <- 3
  56.    Fimse
  57. Fimse
  58.  
  59. Notafim <- Media * Peso1 + notatrab * Peso2
  60.  
  61. Se Notafim <= 50 entao
  62.    Result <- Reprovado
  63. Senao
  64.    Se (Nofim > 50) e (Notafim < 70) entao
  65.       Result <- Regular
  66.    Senao
  67.       Se (Nofim > 70) e (Notafim < 80) entao
  68.          Result <- Bom
  69.       Senao
  70.          Se (Nofim > 80) e (Notafim < 90) entao
  71.             Result <- Muito Bom
  72.          Senao
  73.             Result <- Excelente
  74.          Fimse
  75.       Fimse
  76.    Fimse
  77. Fimse
  78.  
  79. Escreval
  80. Escreval ("Este foi o resultado do aluno",Result)
  81. Escreval
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top