Ledger Nano X - The secure hardware wallet
SHARE
TWEET

Install Redmine on Ubuntu 12.10

Juc1 Feb 16th, 2014 119 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.02.16 21:20:29 =~=~=~=~=~=~=~=~=~=~=~=
  2. login as: root
  3. root@999.999.99.121's password:
  4. Welcome to Ubuntu 12.10 (GNU/Linux 3.5.0-17-generic x86_64)
  5.  
  6.  * Documentation:  https://help.ubuntu.com/
  7. root@redmine:~# export DEBIAN_FRONTEND=noninteractive
  8. root@redmine:~# apt-get update
  9. ...
  10.  
  11. root@redmine:~# apt-get install -y apache2 mysql-server mysql-client libapache2-mod-passenger software-properties-common librmagick-ruby rub
  12. y-rmagick redmine redmine-mysql
  13.  
  14. Reading package lists... 0%
  15.  
  16. Reading package lists... 100%
  17.  
  18. Reading package lists... Done
  19.  
  20.  
  21. Building dependency tree... 0%
  22.  
  23. Building dependency tree... 0%
  24.  
  25. Building dependency tree... 50%
  26.  
  27. Building dependency tree... 50%
  28.  
  29. Building dependency tree      
  30.  
  31.  
  32. Reading state information... 0%
  33.  
  34. Reading state information... 0%
  35.  
  36. Reading state information... Done
  37.  
  38. The following extra packages will be installed:
  39.   apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common build-essential bundler cpp cpp-4.6 cpp-4.7 dbconfig-common dpkg-dev
  40.   fakeroot fontconfig-config g++ g++-4.7 gcc gcc-4.6 gcc-4.6-base gcc-4.7 ghostscript gir1.2-glib-2.0 gsfonts imagemagick-common
  41.   javascript-common libaio1 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libapr1 libaprutil1
  42.   libaprutil1-dbd-sqlite3 libaprutil1-ldap libavahi-client3 libc-bin libc-dev-bin libc6 libc6-dev libcups2 libcupsimage2 libdbd-mysql-perl
  43.   libdbi-perl libdpkg-perl libev4 libfftw3-3 libfile-fcntllock-perl libfontconfig1 libgirepository-1.0-1 libgmp10 libgs9 libgs9-common
  44.   libhtml-template-perl libijs-0.35 libitm1 libjasper1 libjbig0 libjbig2dec0 libjpeg-turbo8 libjpeg8 libjs-prototype libjs-scriptaculous
  45.   liblcms2-2 liblqr-1-0 libltdl7 libmagickcore5 libmpc2 libmpfr4 libmysql-ruby libmysqlclient18 libnet-daemon-perl libpaper-utils
  46.   libpaper1 libplrpc-perl libquadmath0 libreadline5 libruby1.8 libstdc++6-4.7-dev libterm-readkey-perl libtiff5 linux-libc-dev make
  47.   manpages-dev mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5 patch poppler-data python3-apt
  48.   python3-dbus python3-gi python3-software-properties rake ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3
  49.   ruby-activeresource-2.3 ruby-activesupport-2.3 ruby-blankslate ruby-builder ruby-coderay ruby-fastercsv ruby-i18n ruby-memcache-client
  50.   ruby-mysql ruby-net-ldap ruby-passenger ruby-rack ruby-rails-2.3 ruby-rchardet ruby-text-format ruby-tmail ruby-tzinfo ruby1.8
  51.   ruby1.8-dev rubygems rubygems-integration ttf-dejavu-core unattended-upgrades wwwconfig-common zip
  52. Suggested packages:
  53.   apache2-doc apache2-suexec apache2-suexec-custom ufw cpp-doc gcc-4.6-locales gcc-4.7-locales debian-keyring g++-multilib
  54.   g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg gcc-multilib autoconf automake1.9 libtool flex bison gdb gcc-doc gcc-4.6-multilib
  55.   libmudflap0-4.6-dev gcc-4.6-doc libgcc1-dbg libgomp1-dbg libquadmath0-dbg libmudflap0-dbg binutils-gold gcc-4.7-multilib
  56.   libmudflap0-4.7-dev libitm1-dbg ghostscript-cups ghostscript-x hpijs glibc-doc cups-common libfftw3-bin libfftw3-dev fonts-droid
  57.   libipc-sharedcache-perl libjasper-runtime liblcms2-utils libmagickcore5-extra libstdc++6-4.7-doc make-doc tinyca ed diffutils-doc
  58.   poppler-utils fonts-japanese-mincho fonts-ipafont-mincho fonts-japanese-gothic fonts-ipafont-gothic fonts-arphic-ukai fonts-arphic-uming
  59.   fonts-unfonts-core python3-apt-dbg python-apt-doc python-dbus-doc python3-dbus-dbg ruby-openid bzr cvs darcs git mercurial subversion
  60.   rails ruby-passenger-doc ruby1.8-examples ri1.8 ruby-switch bsd-mailx mail-transport-agent postgresql-client
  61. Recommended packages:
  62.   ruby-dev
  63. The following NEW packages will be installed:
  64.   apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common build-essential bundler cpp cpp-4.6 cpp-4.7 dbconfig-common
  65.   dpkg-dev fakeroot fontconfig-config g++ g++-4.7 gcc gcc-4.6 gcc-4.6-base gcc-4.7 ghostscript gir1.2-glib-2.0 gsfonts imagemagick-common
  66.   javascript-common libaio1 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libapache2-mod-passenger libapr1
  67.   libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libavahi-client3 libc-dev-bin libc6-dev libcups2 libcupsimage2 libdbd-mysql-perl
  68.   libdbi-perl libdpkg-perl libev4 libfftw3-3 libfile-fcntllock-perl libfontconfig1 libgirepository-1.0-1 libgmp10 libgs9 libgs9-common
  69.   libhtml-template-perl libijs-0.35 libitm1 libjasper1 libjbig0 libjbig2dec0 libjpeg-turbo8 libjpeg8 libjs-prototype libjs-scriptaculous
  70.   liblcms2-2 liblqr-1-0 libltdl7 libmagickcore5 libmpc2 libmpfr4 libmysql-ruby libmysqlclient18 libnet-daemon-perl libpaper-utils
  71.   libpaper1 libplrpc-perl libquadmath0 libreadline5 librmagick-ruby libruby1.8 libstdc++6-4.7-dev libterm-readkey-perl libtiff5
  72.   linux-libc-dev make manpages-dev mysql-client mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server mysql-server-5.5
  73.   mysql-server-core-5.5 patch poppler-data python3-apt python3-dbus python3-gi python3-software-properties rake redmine redmine-mysql
  74.   ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3 ruby-activeresource-2.3 ruby-activesupport-2.3 ruby-blankslate
  75.   ruby-builder ruby-coderay ruby-fastercsv ruby-i18n ruby-memcache-client ruby-mysql ruby-net-ldap ruby-passenger ruby-rack ruby-rails-2.3
  76.   ruby-rchardet ruby-rmagick ruby-text-format ruby-tmail ruby-tzinfo ruby1.8 ruby1.8-dev rubygems rubygems-integration
  77.   software-properties-common ttf-dejavu-core unattended-upgrades wwwconfig-common zip
  78. The following packages will be upgraded:
  79.   libc-bin libc6
  80. 2 upgraded, 128 newly installed, 0 to remove and 67 not upgraded.
  81. Need to get 111 MB of archives.
  82. After this operation, 322 MB of additional disk space will be used.
  83.  
  84. ...
  85.  
  86. (Reading database ... 22694 files and directories currently installed.)
  87. Unpacking mysql-server-5.5 (from .../mysql-server-5.5_5.5.35-0ubuntu0.12.10.2_amd64.deb) ...
  88. Selecting previously unselected package poppler-data.
  89. Unpacking poppler-data (from .../poppler-data_0.4.5-10_all.deb) ...
  90. Selecting previously unselected package libmpc2:amd64.
  91. Unpacking libmpc2:amd64 (from .../libmpc2_0.9-4build1_amd64.deb) ...
  92. Selecting previously unselected package libruby1.8.
  93. Unpacking libruby1.8 (from .../libruby1.8_1.8.7.358-4ubuntu0.4_amd64.deb) ...
  94. Selecting previously unselected package ruby1.8.
  95. Unpacking ruby1.8 (from .../ruby1.8_1.8.7.358-4ubuntu0.4_amd64.deb) ...
  96. Selecting previously unselected package rake.
  97. Unpacking rake (from .../rake_0.9.2.2-4_all.deb) ...
  98. Selecting previously unselected package libjs-prototype.
  99. Unpacking libjs-prototype (from .../libjs-prototype_1.7.0-2_all.deb) ...
  100. Selecting previously unselected package libjs-scriptaculous.
  101. Unpacking libjs-scriptaculous (from .../libjs-scriptaculous_1.9.0-2_all.deb) ...
  102. Selecting previously unselected package ruby-blankslate.
  103. Unpacking ruby-blankslate (from .../ruby-blankslate_2.1.2.4-4_all.deb) ...
  104. Selecting previously unselected package ruby-builder.
  105. Unpacking ruby-builder (from .../ruby-builder_3.0.0-3_all.deb) ...
  106. Selecting previously unselected package ruby-i18n.
  107. Unpacking ruby-i18n (from .../ruby-i18n_0.6.0-3_all.deb) ...
  108. Selecting previously unselected package ruby-memcache-client.
  109. Unpacking ruby-memcache-client (from .../ruby-memcache-client_1.8.5-2_all.deb) ...
  110. Selecting previously unselected package ruby-tzinfo.
  111. Unpacking ruby-tzinfo (from .../ruby-tzinfo_0.3.33-3_all.deb) ...
  112. Selecting previously unselected package ruby-activesupport-2.3.
  113. Unpacking ruby-activesupport-2.3 (from .../ruby-activesupport-2.3_2.3.14-4ubuntu0.2_all.deb) ...
  114. Selecting previously unselected package ruby-activerecord-2.3.
  115. Unpacking ruby-activerecord-2.3 (from .../ruby-activerecord-2.3_2.3.14-2ubuntu0.1_all.deb) ...
  116. Selecting previously unselected package ruby-rack.
  117. Unpacking ruby-rack (from .../ruby-rack_1.4.1-2_all.deb) ...
  118. Selecting previously unselected package ruby-actionpack-2.3.
  119. Unpacking ruby-actionpack-2.3 (from .../ruby-actionpack-2.3_2.3.14-4_all.deb) ...
  120. Selecting previously unselected package ruby-text-format.
  121. Unpacking ruby-text-format (from .../ruby-text-format_1.0.0-3_all.deb) ...
  122. Selecting previously unselected package ruby-rchardet.
  123. Unpacking ruby-rchardet (from .../ruby-rchardet_1.3-3_all.deb) ...
  124. Selecting previously unselected package ruby-tmail.
  125. Unpacking ruby-tmail (from .../ruby-tmail_1.2.7.1-3~build1_amd64.deb) ...
  126. Selecting previously unselected package ruby-actionmailer-2.3.
  127. Unpacking ruby-actionmailer-2.3 (from .../ruby-actionmailer-2.3_2.3.14-3_all.deb) ...
  128. Selecting previously unselected package ruby-activeresource-2.3.
  129. Unpacking ruby-activeresource-2.3 (from .../ruby-activeresource-2.3_2.3.14-2_all.deb) ...
  130. Selecting previously unselected package ruby-rails-2.3.
  131. Unpacking ruby-rails-2.3 (from .../ruby-rails-2.3_2.3.14-4_all.deb) ...
  132. Selecting previously unselected package dbconfig-common.
  133. Unpacking dbconfig-common (from .../dbconfig-common_1.8.47+nmu1_all.deb) ...
  134. Selecting previously unselected package ruby-mysql.
  135. Unpacking ruby-mysql (from .../ruby-mysql_2.8.2+gem2deb-3_amd64.deb) ...
  136. Selecting previously unselected package libmysql-ruby.
  137. Unpacking libmysql-ruby (from .../libmysql-ruby_2.8.2+gem2deb-3_all.deb) ...
  138. Selecting previously unselected package mysql-client.
  139. Unpacking mysql-client (from .../mysql-client_5.5.35-0ubuntu0.12.10.2_all.deb) ...
  140. Selecting previously unselected package redmine-mysql.
  141. Unpacking redmine-mysql (from .../redmine-mysql_1.4.4+dfsg1-1_all.deb) ...
  142. Selecting previously unselected package ruby-coderay.
  143. Unpacking ruby-coderay (from .../ruby-coderay_1.0.6-2_all.deb) ...
  144. Selecting previously unselected package ruby-net-ldap.
  145. Unpacking ruby-net-ldap (from .../ruby-net-ldap_0.3.1-2_all.deb) ...
  146. Selecting previously unselected package ruby-fastercsv.
  147. Unpacking ruby-fastercsv (from .../ruby-fastercsv_1.5.5-1_all.deb) ...
  148. Selecting previously unselected package bundler.
  149. Unpacking bundler (from .../bundler_1.1.4-5_all.deb) ...
  150. Selecting previously unselected package redmine.
  151. Unpacking redmine (from .../redmine_1.4.4+dfsg1-1_all.deb) ...
  152. Selecting previously unselected package libgirepository-1.0-1.
  153. Unpacking libgirepository-1.0-1 (from .../libgirepository-1.0-1_1.33.14-1_amd64.deb) ...
  154. Selecting previously unselected package gir1.2-glib-2.0.
  155. Unpacking gir1.2-glib-2.0 (from .../gir1.2-glib-2.0_1.33.14-1_amd64.deb) ...
  156. Selecting previously unselected package python3-apt.
  157. Unpacking python3-apt (from .../python3-apt_0.8.7ubuntu4.1_amd64.deb) ...
  158. Selecting previously unselected package python3-dbus.
  159. Unpacking python3-dbus (from .../python3-dbus_1.1.1-1ubuntu0.1_amd64.deb) ...
  160. Selecting previously unselected package python3-gi.
  161. Unpacking python3-gi (from .../python3-gi_3.4.0-1ubuntu0.1_amd64.deb) ...
  162. Selecting previously unselected package libapr1.
  163. Unpacking libapr1 (from .../libapr1_1.4.6-3_amd64.deb) ...
  164. Selecting previously unselected package libaprutil1.
  165. Unpacking libaprutil1 (from .../libaprutil1_1.4.1-3_amd64.deb) ...
  166. Selecting previously unselected package libaprutil1-dbd-sqlite3.
  167. Unpacking libaprutil1-dbd-sqlite3 (from .../libaprutil1-dbd-sqlite3_1.4.1-3_amd64.deb) ...
  168. Selecting previously unselected package libaprutil1-ldap.
  169. Unpacking libaprutil1-ldap (from .../libaprutil1-ldap_1.4.1-3_amd64.deb) ...
  170. Selecting previously unselected package apache2.2-bin.
  171. Unpacking apache2.2-bin (from .../apache2.2-bin_2.2.22-6ubuntu2.3_amd64.deb) ...
  172. Selecting previously unselected package apache2-utils.
  173. Unpacking apache2-utils (from .../apache2-utils_2.2.22-6ubuntu2.3_amd64.deb) ...
  174. Selecting previously unselected package apache2.2-common.
  175. Unpacking apache2.2-common (from .../apache2.2-common_2.2.22-6ubuntu2.3_amd64.deb) ...
  176. Selecting previously unselected package apache2-mpm-worker.
  177. Unpacking apache2-mpm-worker (from .../apache2-mpm-worker_2.2.22-6ubuntu2.3_amd64.deb) ...
  178. Selecting previously unselected package apache2.
  179. Unpacking apache2 (from .../apache2_2.2.22-6ubuntu2.3_amd64.deb) ...
  180. Selecting previously unselected package libc-dev-bin.
  181. Unpacking libc-dev-bin (from .../libc-dev-bin_2.15-0ubuntu20.2_amd64.deb) ...
  182. Selecting previously unselected package linux-libc-dev:amd64.
  183. Unpacking linux-libc-dev:amd64 (from .../linux-libc-dev_3.5.0-45.68_amd64.deb) ...
  184. Selecting previously unselected package libc6-dev:amd64.
  185. Unpacking libc6-dev:amd64 (from .../libc6-dev_2.15-0ubuntu20.2_amd64.deb) ...
  186. Selecting previously unselected package cpp-4.7.
  187. Unpacking cpp-4.7 (from .../cpp-4.7_4.7.2-2ubuntu1_amd64.deb) ...
  188. Selecting previously unselected package cpp.
  189. Unpacking cpp (from .../cpp_4%3a4.7.2-1ubuntu2_amd64.deb) ...
  190. Selecting previously unselected package gcc-4.7.
  191. Unpacking gcc-4.7 (from .../gcc-4.7_4.7.2-2ubuntu1_amd64.deb) ...
  192. Selecting previously unselected package gcc.
  193. Unpacking gcc (from .../gcc_4%3a4.7.2-1ubuntu2_amd64.deb) ...
  194. Selecting previously unselected package libstdc++6-4.7-dev.
  195. Unpacking libstdc++6-4.7-dev (from .../libstdc++6-4.7-dev_4.7.2-2ubuntu1_amd64.deb) ...
  196. Selecting previously unselected package g++-4.7.
  197. Unpacking g++-4.7 (from .../g++-4.7_4.7.2-2ubuntu1_amd64.deb) ...
  198. Selecting previously unselected package g++.
  199. Unpacking g++ (from .../g++_4%3a4.7.2-1ubuntu2_amd64.deb) ...
  200. Selecting previously unselected package make.
  201. Unpacking make (from .../make_3.81-8.2ubuntu2_amd64.deb) ...
  202. Selecting previously unselected package libdpkg-perl.
  203. Unpacking libdpkg-perl (from .../libdpkg-perl_1.16.7ubuntu6_all.deb) ...
  204. Selecting previously unselected package patch.
  205. Unpacking patch (from .../patch_2.6.1-3ubuntu1_amd64.deb) ...
  206. Selecting previously unselected package dpkg-dev.
  207. Unpacking dpkg-dev (from .../dpkg-dev_1.16.7ubuntu6_all.deb) ...
  208. Selecting previously unselected package build-essential.
  209. Unpacking build-essential (from .../build-essential_11.5ubuntu3_amd64.deb) ...
  210. Selecting previously unselected package gcc-4.6-base:amd64.
  211. Unpacking gcc-4.6-base:amd64 (from .../gcc-4.6-base_4.6.3-10ubuntu1_amd64.deb) ...
  212. Selecting previously unselected package cpp-4.6.
  213. Unpacking cpp-4.6 (from .../cpp-4.6_4.6.3-10ubuntu1_amd64.deb) ...
  214. Selecting previously unselected package fakeroot.
  215. Unpacking fakeroot (from .../fakeroot_1.18.4-2_amd64.deb) ...
  216. Selecting previously unselected package gcc-4.6.
  217. Unpacking gcc-4.6 (from .../gcc-4.6_4.6.3-10ubuntu1_amd64.deb) ...
  218. Selecting previously unselected package libijs-0.35.
  219. Unpacking libijs-0.35 (from .../libijs-0.35_0.35-8build1_amd64.deb) ...
  220. Selecting previously unselected package libjbig2dec0.
  221. Unpacking libjbig2dec0 (from .../libjbig2dec0_0.11-1ubuntu2_amd64.deb) ...
  222. Selecting previously unselected package libgs9-common.
  223. Unpacking libgs9-common (from .../libgs9-common_9.06~dfsg-0ubuntu4_all.deb) ...
  224. Selecting previously unselected package libgs9.
  225. Unpacking libgs9 (from .../libgs9_9.06~dfsg-0ubuntu4_amd64.deb) ...
  226. Selecting previously unselected package gsfonts.
  227. Unpacking gsfonts (from .../gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.2ubuntu1_all.deb) ...
  228. Selecting previously unselected package ghostscript.
  229. Unpacking ghostscript (from .../ghostscript_9.06~dfsg-0ubuntu4_amd64.deb) ...
  230. Selecting previously unselected package wwwconfig-common.
  231. Unpacking wwwconfig-common (from .../wwwconfig-common_0.2.2_all.deb) ...
  232. Selecting previously unselected package javascript-common.
  233. Unpacking javascript-common (from .../javascript-common_8_all.deb) ...
  234. Selecting previously unselected package libalgorithm-diff-perl.
  235. Unpacking libalgorithm-diff-perl (from .../libalgorithm-diff-perl_1.19.02-2_all.deb) ...
  236. Selecting previously unselected package libalgorithm-diff-xs-perl.
  237. Unpacking libalgorithm-diff-xs-perl (from .../libalgorithm-diff-xs-perl_0.04-2build3_amd64.deb) ...
  238. Selecting previously unselected package libalgorithm-merge-perl.
  239. Unpacking libalgorithm-merge-perl (from .../libalgorithm-merge-perl_0.08-2_all.deb) ...
  240. Selecting previously unselected package libev4.
  241. Unpacking libev4 (from .../libev4_1%3a4.11-1_amd64.deb) ...
  242. Selecting previously unselected package rubygems.
  243. Unpacking rubygems (from .../rubygems_1.8.24-1ubuntu1_all.deb) ...
  244. Selecting previously unselected package ruby-passenger.
  245. Unpacking ruby-passenger (from .../ruby-passenger_3.0.13debian-1_amd64.deb) ...
  246. Selecting previously unselected package libapache2-mod-passenger.
  247. Unpacking libapache2-mod-passenger (from .../libapache2-mod-passenger_3.0.13debian-1_amd64.deb) ...
  248. Selecting previously unselected package libfile-fcntllock-perl.
  249. Unpacking libfile-fcntllock-perl (from .../libfile-fcntllock-perl_0.14-2_amd64.deb) ...
  250. Selecting previously unselected package libhtml-template-perl.
  251. Unpacking libhtml-template-perl (from .../libhtml-template-perl_2.91-1_all.deb) ...
  252. Selecting previously unselected package libpaper-utils.
  253. Unpacking libpaper-utils (from .../libpaper-utils_1.1.24+nmu2_amd64.deb) ...
  254. Selecting previously unselected package ruby-rmagick.
  255. Unpacking ruby-rmagick (from .../ruby-rmagick_2.13.1-6build1_amd64.deb) ...
  256. Selecting previously unselected package librmagick-ruby.
  257. Unpacking librmagick-ruby (from .../librmagick-ruby_2.13.1-6build1_all.deb) ...
  258. Selecting previously unselected package manpages-dev.
  259. Unpacking manpages-dev (from .../manpages-dev_3.40-0.1ubuntu3_all.deb) ...
  260. Selecting previously unselected package mysql-server.
  261. Unpacking mysql-server (from .../mysql-server_5.5.35-0ubuntu0.12.10.2_all.deb) ...
  262. Selecting previously unselected package unattended-upgrades.
  263. Unpacking unattended-upgrades (from .../unattended-upgrades_0.79.3ubuntu4_all.deb) ...
  264. Selecting previously unselected package python3-software-properties.
  265. Unpacking python3-software-properties (from .../python3-software-properties_0.92.9.3_all.deb) ...
  266. Selecting previously unselected package ruby1.8-dev.
  267. Unpacking ruby1.8-dev (from .../ruby1.8-dev_1.8.7.358-4ubuntu0.4_amd64.deb) ...
  268. Selecting previously unselected package rubygems-integration.
  269. Unpacking rubygems-integration (from .../rubygems-integration_1.1_all.deb) ...
  270. Selecting previously unselected package software-properties-common.
  271. Unpacking software-properties-common (from .../software-properties-common_0.92.9.3_all.deb) ...
  272. Selecting previously unselected package zip.
  273. Unpacking zip (from .../archives/zip_3.0-6_amd64.deb) ...
  274. Processing triggers for ureadahead ...
  275. ureadahead will be reprofiled on next reboot
  276. Processing triggers for man-db ...
  277. Setting up ttf-dejavu-core (2.33-2ubuntu1) ...
  278. Setting up fontconfig-config (2.10.1-0ubuntu3) ...
  279. Setting up imagemagick-common (8:6.7.7.10-2ubuntu4.1) ...
  280. Setting up libaio1:amd64 (0.3.109-2ubuntu1) ...
  281. Setting up libavahi-client3:amd64 (0.6.31-1ubuntu2) ...
  282. Setting up libcups2:amd64 (1.6.1-0ubuntu11.5) ...
  283. Setting up libcupsimage2:amd64 (1.6.1-0ubuntu11.5) ...
  284. Setting up libfftw3-3:amd64 (3.3.2-3.1ubuntu1) ...
  285. Setting up libfontconfig1:amd64 (2.10.1-0ubuntu3) ...
  286. Setting up libgmp10:amd64 (2:5.0.2+dfsg-2ubuntu2) ...
  287. Setting up libitm1:amd64 (4.7.2-2ubuntu1) ...
  288. Setting up libjpeg-turbo8:amd64 (1.2.1-0ubuntu2.12.10.1) ...
  289. Setting up libjpeg8:amd64 (8c-2ubuntu7) ...
  290. Setting up libjasper1:amd64 (1.900.1-13build1) ...
  291. Setting up liblcms2-2:amd64 (2.2+git20110628-2ubuntu4.1) ...
  292. Setting up liblqr-1-0:amd64 (0.4.1-2) ...
  293. Setting up libltdl7:amd64 (2.4.2-1ubuntu2) ...
  294. Setting up libjbig0:amd64 (2.0-2ubuntu1) ...
  295. Setting up libtiff5:amd64 (4.0.2-1ubuntu2.2) ...
  296. Setting up libmagickcore5:amd64 (8:6.7.7.10-2ubuntu4.1) ...
  297. Setting up libmpfr4:amd64 (3.1.0-3ubuntu3) ...
  298. Setting up libmysqlclient18:amd64 (5.5.35-0ubuntu0.12.10.2) ...
  299. Setting up libpaper1:amd64 (1.1.24+nmu2) ...
  300.  
  301. Creating config file /etc/papersize with new version
  302. Setting up libquadmath0:amd64 (4.7.2-2ubuntu1) ...
  303. Setting up libreadline5:amd64 (5.2-12) ...
  304. Setting up libnet-daemon-perl (0.48-1) ...
  305. Setting up libplrpc-perl (0.2020-2) ...
  306. Setting up libdbi-perl (1.622-1) ...
  307. Setting up libdbd-mysql-perl (4.021-1) ...
  308. Setting up mysql-client-core-5.5 (5.5.35-0ubuntu0.12.10.2) ...
  309. Setting up libterm-readkey-perl (2.30-4build4) ...
  310. Setting up mysql-client-5.5 (5.5.35-0ubuntu0.12.10.2) ...
  311. Setting up mysql-server-core-5.5 (5.5.35-0ubuntu0.12.10.2) ...
  312. Setting up mysql-server-5.5 (5.5.35-0ubuntu0.12.10.2) ...
  313. mysql start/running, process 8829
  314. Setting up poppler-data (0.4.5-10) ...
  315. Setting up libmpc2:amd64 (0.9-4build1) ...
  316. Setting up libruby1.8 (1.8.7.358-4ubuntu0.4) ...
  317. Setting up ruby1.8 (1.8.7.358-4ubuntu0.4) ...
  318. update-alternatives: using /usr/bin/ruby1.8 to provide /usr/bin/ruby (ruby) in auto mode
  319. Setting up rake (0.9.2.2-4) ...
  320. Setting up libjs-prototype (1.7.0-2) ...
  321. Setting up libjs-scriptaculous (1.9.0-2) ...
  322. Setting up ruby-blankslate (2.1.2.4-4) ...
  323. Setting up ruby-builder (3.0.0-3) ...
  324. Setting up ruby-i18n (0.6.0-3) ...
  325. Setting up ruby-memcache-client (1.8.5-2) ...
  326. Setting up ruby-tzinfo (0.3.33-3) ...
  327. Setting up ruby-activesupport-2.3 (2.3.14-4ubuntu0.2) ...
  328. Setting up ruby-activerecord-2.3 (2.3.14-2ubuntu0.1) ...
  329. Setting up ruby-rack (1.4.1-2) ...
  330. Setting up ruby-actionpack-2.3 (2.3.14-4) ...
  331. Setting up ruby-text-format (1.0.0-3) ...
  332. Setting up ruby-rchardet (1.3-3) ...
  333. Setting up ruby-tmail (1.2.7.1-3~build1) ...
  334. Setting up ruby-actionmailer-2.3 (2.3.14-3) ...
  335. Setting up ruby-activeresource-2.3 (2.3.14-2) ...
  336. Setting up ruby-rails-2.3 (2.3.14-4) ...
  337. Setting up dbconfig-common (1.8.47+nmu1) ...
  338.  
  339. Creating config file /etc/dbconfig-common/config with new version
  340. Setting up ruby-mysql (2.8.2+gem2deb-3) ...
  341. Setting up libmysql-ruby (2.8.2+gem2deb-3) ...
  342. Setting up mysql-client (5.5.35-0ubuntu0.12.10.2) ...
  343. Setting up redmine-mysql (1.4.4+dfsg1-1) ...
  344. Setting up ruby-coderay (1.0.6-2) ...
  345. Setting up ruby-net-ldap (0.3.1-2) ...
  346. Setting up ruby-fastercsv (1.5.5-1) ...
  347. Setting up bundler (1.1.4-5) ...
  348. Setting up redmine (1.4.4+dfsg1-1) ...
  349. dbconfig-common: writing config to /etc/dbconfig-common/redmine/instances/default.conf
  350.  
  351. Creating config file /etc/dbconfig-common/redmine/instances/default.conf with new version
  352.  
  353. Creating config file /etc/redmine/default/database.yml.new with new version
  354. granting access to database redmine_default for redmine@localhost: success.
  355. verifying access for redmine@localhost: success.
  356. creating database redmine_default: success.
  357. verifying database redmine_default exists: success.
  358. dbconfig-common: flushing administrative password
  359.  
  360. Creating config file /etc/redmine/default/database.yml with new version
  361. NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
  362. Gem.source_index called from /usr/share/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
  363. Please install RDoc 2.4.2+ to generate documentation.
  364.  
  365. Creating config file /etc/redmine/default/session.yml with new version
  366. A new secret session key has been generated in /etc/redmine/default/session.yml
  367. Populating database for redmine instance "default".
  368. This may take a while.
  369. NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
  370. Gem.source_index called from /usr/share/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
  371. Please install RDoc 2.4.2+ to generate documentation.
  372. Done.
  373. NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
  374. Gem.source_index called from /usr/share/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
  375. Please install RDoc 2.4.2+ to generate documentation.
  376. Default configuration data loaded.
  377. NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
  378. Gem.source_index called from /usr/share/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
  379. Please install RDoc 2.4.2+ to generate documentation.
  380. Migrating engines...
  381. Migrating acts_as_activity_provider...
  382. Migrating acts_as_attachable...
  383. Migrating acts_as_customizable...
  384. Migrating acts_as_event...
  385. Migrating acts_as_list...
  386. Migrating acts_as_searchable...
  387. Migrating acts_as_tree...
  388. Migrating acts_as_versioned...
  389. Migrating acts_as_watchable...
  390. Migrating awesome_nested_set...
  391. Migrating classic_pagination...
  392. Migrating gravatar...
  393. Migrating open_id_authentication...
  394. Migrating prepend_engine_views...
  395. Migrating rfpdf...
  396. Setting up libgirepository-1.0-1 (1.33.14-1) ...
  397. Setting up gir1.2-glib-2.0 (1.33.14-1) ...
  398. Setting up python3-apt (0.8.7ubuntu4.1) ...
  399. Setting up python3-dbus (1.1.1-1ubuntu0.1) ...
  400. Setting up python3-gi (3.4.0-1ubuntu0.1) ...
  401. Setting up libapr1 (1.4.6-3) ...
  402. Setting up libaprutil1 (1.4.1-3) ...
  403. Setting up libaprutil1-dbd-sqlite3 (1.4.1-3) ...
  404. Setting up libaprutil1-ldap (1.4.1-3) ...
  405. Setting up apache2.2-bin (2.2.22-6ubuntu2.3) ...
  406. Setting up apache2-utils (2.2.22-6ubuntu2.3) ...
  407. Setting up apache2.2-common (2.2.22-6ubuntu2.3) ...
  408. Enabling site default.
  409. Enabling module alias.
  410. Enabling module autoindex.
  411. Enabling module dir.
  412. Enabling module env.
  413. Enabling module mime.
  414. Enabling module negotiation.
  415. Enabling module setenvif.
  416. Enabling module status.
  417. Enabling module auth_basic.
  418. Enabling module deflate.
  419. Enabling module authz_default.
  420. Enabling module authz_user.
  421. Enabling module authz_groupfile.
  422. Enabling module authn_file.
  423. Enabling module authz_host.
  424. Enabling module reqtimeout.
  425. Setting up libc-dev-bin (2.15-0ubuntu20.2) ...
  426. Setting up linux-libc-dev:amd64 (3.5.0-45.68) ...
  427. Setting up libc6-dev:amd64 (2.15-0ubuntu20.2) ...
  428. Setting up cpp-4.7 (4.7.2-2ubuntu1) ...
  429. Setting up cpp (4:4.7.2-1ubuntu2) ...
  430. Setting up gcc-4.7 (4.7.2-2ubuntu1) ...
  431. Setting up gcc (4:4.7.2-1ubuntu2) ...
  432. Setting up make (3.81-8.2ubuntu2) ...
  433. Setting up libdpkg-perl (1.16.7ubuntu6) ...
  434. Setting up patch (2.6.1-3ubuntu1) ...
  435. Setting up dpkg-dev (1.16.7ubuntu6) ...
  436. Setting up gcc-4.6-base:amd64 (4.6.3-10ubuntu1) ...
  437. Setting up cpp-4.6 (4.6.3-10ubuntu1) ...
  438. Setting up fakeroot (1.18.4-2) ...
  439. update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode
  440. Setting up gcc-4.6 (4.6.3-10ubuntu1) ...
  441. Setting up libijs-0.35 (0.35-8build1) ...
  442. Setting up libjbig2dec0 (0.11-1ubuntu2) ...
  443. Setting up libgs9-common (9.06~dfsg-0ubuntu4) ...
  444. update-alternatives: using /usr/share/ghostscript/9.06 to provide /usr/share/ghostscript/current (ghostscript-current) in auto mode
  445. Setting up libgs9 (9.06~dfsg-0ubuntu4) ...
  446. Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1) ...
  447. Setting up ghostscript (9.06~dfsg-0ubuntu4) ...
  448. Setting up wwwconfig-common (0.2.2) ...
  449. Setting up javascript-common (8) ...
  450. Setting up libalgorithm-diff-perl (1.19.02-2) ...
  451. Setting up libalgorithm-diff-xs-perl (0.04-2build3) ...
  452. Setting up libalgorithm-merge-perl (0.08-2) ...
  453. Setting up libev4 (1:4.11-1) ...
  454. Setting up rubygems (1.8.24-1ubuntu1) ...
  455. Setting up ruby-passenger (3.0.13debian-1) ...
  456. Setting up libfile-fcntllock-perl (0.14-2) ...
  457. Setting up libhtml-template-perl (2.91-1) ...
  458. Setting up libpaper-utils (1.1.24+nmu2) ...
  459. Setting up ruby-rmagick (2.13.1-6build1) ...
  460. Setting up librmagick-ruby (2.13.1-6build1) ...
  461. Setting up manpages-dev (3.40-0.1ubuntu3) ...
  462. Setting up unattended-upgrades (0.79.3ubuntu4) ...
  463. Setting up ruby1.8-dev (1.8.7.358-4ubuntu0.4) ...
  464. Setting up rubygems-integration (1.1) ...
  465. Setting up zip (3.0-6) ...
  466. Processing triggers for ureadahead ...
  467. Setting up mysql-server (5.5.35-0ubuntu0.12.10.2) ...
  468. Setting up python3-software-properties (0.92.9.3) ...
  469. Setting up software-properties-common (0.92.9.3) ...
  470. Setting up apache2-mpm-worker (2.2.22-6ubuntu2.3) ...
  471.  * Starting web server apache2        apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
  472.  
  473. [ OK ]
  474. Setting up apache2 (2.2.22-6ubuntu2.3) ...
  475. Setting up libapache2-mod-passenger (3.0.13debian-1) ...
  476.  * Reloading web server config        apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
  477.  
  478. [ OK ]
  479. Setting up libstdc++6-4.7-dev (4.7.2-2ubuntu1) ...
  480. Setting up g++-4.7 (4.7.2-2ubuntu1) ...
  481. Setting up g++ (4:4.7.2-1ubuntu2) ...
  482. update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
  483. Setting up build-essential (11.5ubuntu3) ...
  484. Processing triggers for libc-bin ...
  485. ldconfig deferred processing now taking place
  486. root@redmine:~# gem install bundler mysql2
  487. Fetching: bundler-1.5.3.gem
  488. Fetching: bundler-1.5.3.gem (  5%)
  489.  
  490.  
  491. Fetching: mysql2-0.3.15.gem (100%)
  492. Building native extensions.  This could take a while...
  493. ERROR:  Error installing mysql2:
  494. ERROR: Failed to build gem native extension.
  495.  
  496.         /usr/bin/ruby1.8 extconf.rb
  497. checking for ruby/thread.h... no
  498. checking for rb_thread_blocking_region()... no
  499. checking for rb_wait_for_single_fd()... no
  500. checking for rb_hash_dup()... no
  501. checking for rb_intern3()... no
  502. checking for mysql_query() in -lmysqlclient... no
  503. checking for main() in -lm... yes
  504. checking for mysql_query() in -lmysqlclient... no
  505. checking for main() in -lz... no
  506. checking for mysql_query() in -lmysqlclient... no
  507. checking for main() in -lsocket... no
  508. checking for mysql_query() in -lmysqlclient... no
  509. checking for main() in -lnsl... yes
  510. checking for mysql_query() in -lmysqlclient... no
  511. checking for main() in -lmygcc... no
  512. checking for mysql_query() in -lmysqlclient... no
  513. *** extconf.rb failed ***
  514. Could not create Makefile due to some reason, probably lack of
  515. necessary libraries and/or headers.  Check the mkmf.log file for more
  516. details.  You may need configuration options.
  517.  
  518. Provided configuration options:
  519. --with-opt-dir
  520. --without-opt-dir
  521. --with-opt-include
  522. --without-opt-include=${opt-dir}/include
  523. --with-opt-lib
  524. --without-opt-lib=${opt-dir}/lib
  525. --with-make-prog
  526. --without-make-prog
  527. --srcdir=.
  528. --curdir
  529. --ruby=/usr/bin/ruby1.8
  530. --with-mysql-dir
  531. --without-mysql-dir
  532. --with-mysql-include
  533. --without-mysql-include=${mysql-dir}/include
  534. --with-mysql-lib
  535. --without-mysql-lib=${mysql-dir}/lib
  536. --with-mysql-config
  537. --without-mysql-config
  538. --with-mysql-dir
  539. --without-mysql-dir
  540. --with-mysql-include
  541. --without-mysql-include=${mysql-dir}/include
  542. --with-mysql-lib
  543. --without-mysql-lib=${mysql-dir}/lib
  544. --with-mysqlclientlib
  545. --without-mysqlclientlib
  546. --with-mlib
  547. --without-mlib
  548. --with-mysqlclientlib
  549. --without-mysqlclientlib
  550. --with-zlib
  551. --without-zlib
  552. --with-mysqlclientlib
  553. --without-mysqlclientlib
  554. --with-socketlib
  555. --without-socketlib
  556. --with-mysqlclientlib
  557. --without-mysqlclientlib
  558. --with-nsllib
  559. --without-nsllib
  560. --with-mysqlclientlib
  561. --without-mysqlclientlib
  562. --with-mygcclib
  563. --without-mygcclib
  564. --with-mysqlclientlib
  565. --without-mysqlclientlib
  566.  
  567.  
  568. Gem files will remain installed in /var/lib/gems/1.8/gems/mysql2-0.3.15 for inspection.
  569. Results logged to /var/lib/gems/1.8/gems/mysql2-0.3.15/ext/mysql2/gem_make.out
  570. 1 gem installed
  571. Installing ri documentation for bundler-1.5.3...
  572. Installing RDoc documentation for bundler-1.5.3...
  573. root@redmine:~# ln -s /usr/share/redmine/public /var/www
  574. root@redmine:~# sed -i '/mod_passenger.c/aPassengerDefaultUser www-data' /etc/apache2/mods-available/passenger.conf
  575. root@redmine:~# sed -i '//a\\tRailsBaseURI \/public\n\tPassengerResolveSymlinksInDocumentRoot on' /etc/apache2/sites-available/default
  576. sed: -e expression #1, char 0: no previous regular expression
  577. root@redmine:~# cat /etc/apache2/mods-available/passenger.conf
  578. <IfModule mod_passenger.c>
  579. PassengerDefaultUser www-data
  580.   PassengerRoot /usr
  581.   PassengerRuby /usr/bin/ruby
  582. </IfModule>
  583. root@redmine:~# cat /etc/apache2/sites-available/default
  584. <VirtualHost *:80>
  585. ServerAdmin webmaster@localhost
  586.  
  587. DocumentRoot /var/www
  588. <Directory />
  589. Options FollowSymLinks
  590. AllowOverride None
  591. </Directory>
  592. <Directory /var/www/>
  593. Options Indexes FollowSymLinks MultiViews
  594. AllowOverride None
  595. Order allow,deny
  596. allow from all
  597. </Directory>
  598.  
  599. ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
  600. <Directory "/usr/lib/cgi-bin">
  601. AllowOverride None
  602. Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
  603. Order allow,deny
  604. Allow from all
  605. </Directory>
  606.  
  607. ErrorLog ${APACHE_LOG_DIR}/error.log
  608.  
  609. # Possible values include: debug, info, notice, warn, error, crit,
  610. # alert, emerg.
  611. LogLevel warn
  612.  
  613. CustomLog ${APACHE_LOG_DIR}/access.log combined
  614. </VirtualHost>
  615. root@redmine:~# service apache2 restart
  616.  * Restarting web server apache2        apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
  617.  ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
  618.  
  619. [ OK ]
  620. root@redmine:~# exit
  621. logout
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Top