SHARE
TWEET

4_63

a guest Sep 18th, 2018 191 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo ChupaMeuPintoEntaoSuaV()
  2.    declare anon, i, m, f, vin5, cr, sp:inteiro;
  3.    declare s:literal;
  4.    faca
  5.          escreva("Informe o seu ano de nascimento: ");
  6.          leia(anon);
  7.          se (anon != 0) entao
  8.             se (anon < 1993) entao
  9.                vin5 <- vin5 + 1;
  10.             fimse
  11.             i <- i + 1
  12.             escreva("Informe seu sexo: ");
  13.             leia(s);
  14.             se (s == 'M') entao
  15.                m <- m + 1;
  16.             senao
  17.                  f <- f + 1;
  18.             fimse
  19.             escreva("Código de registro: ");
  20.             leia(cr);
  21.             se (cr == 0) entao
  22.                sp <- sp + 1;
  23.             fimse
  24.          fimse
  25.    enquanto (anon != 0)
  26.    escreval("A percentagem de motoristas com menos de 25 anos é: ", ((100*vin5)/i));
  27.    escreval("A percentagem de mulheres é: ", ((100*f)/i));
  28.    escreval("A percentagem de motoristas com registro fora de SP:", ((100*sp)/i));
  29. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top