SHARE
TWEET

Untitled

ralvesco Jun 22nd, 2017 491 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. ralvesco@casa:~$ yaourt -S safesignidentityclient
  2.  
  3. ==> Fazendo download do PKGBUILD de safesignidentityclient do AUR...
  4. x .SRCINFO
  5. x .gitignore
  6. x PKGBUILD
  7. denisfalqueto commented on 2017-06-21 16:20          
  8. @ralvesco: I can help you troubleshoot, but I need to know the level of familiarity with Arch that you have. Do you know well how to use pacman, makepkg and how AUR works? That will help we start.
  9.  
  10. ralvesco commented on 2017-06-21 17:44           
  11. I'm not exactly a nobbie, but I can't say that I know much of it. I'd say that I'm an intermediary user. I figure somethings out on the go, so I'd work relative well with pacman and with AUR, the first I understand better, the second more or less. For instance, I start working with pacman using the same principles that I used in apt for debian based distros, but always reading the documentation of the command, using man and searching the meaning of the orders that I give to system. As for the makepkg I think it's shell, so I can understand relatively well and I'm good researcher. :)
  12.  
  13. denisfalqueto commented on 2017-06-21 17:55          
  14. @ralvesco: Ok. I suggest using an AUR wrapper. I personally use pacaur, but you can choose any of the others (packer, yaourt, etc). By using one, you'll be a little isolated from the nuances of makepkg and downloading dependencies, without losing much power. So, could you try installing this package with an AUR wrapper of your choice? Send any errors here (use pastbin to avoid cluttering the comment session).
  15.  
  16. ralvesco commented on 2017-06-22 02:26           
  17. @denisfalqueto I've run the following command: yaourt -i safesignidentityclient
  18.  
  19. And get this first error:
  20.  
  21. openssl-0.9.8zh.tar.gz ... FALHOU (chave pública desconhecida D5E9E43F7DF9EE8C)
  22. == ERRO: Uma ou mais assinaturas PGP não puderam ser verificadas!
  23. == ERRO: Makepkg não conseguiu compilar openssl098.
  24.  
  25. After that it's a loop as you can see in the whole process (https://pastebin.com/FdjH6TWH).
  26.  
  27.  
  28. denisfalqueto commented on 2017-06-22 03:12          
  29. @ralvesco: makepkg can check digital signatures if the packages provide ways to do that. For example, openssl098 provides digital signatures for the source files and these need to be validated by a public key.
  30.  
  31. You'll need to add those keys to gpg keyring for the user running makepkg. For example, you can use:
  32.  
  33. gpg --recv-keys D5E9E43F7DF9EE8C
  34.  
  35. This will add the public key with ID D5E9E43F7DF9EE8C in gpg's keyring for the current user. Maybe you'll need to add other keys as well, with a similar command.
  36.  
  37. safesignidentityclient 3.0.101-3  (2017-03-31 03:13)
  38. ( Pacote sem suporte: Potencialmente perigoso ! )
  39. ==> Editar PKGBUILD ? [S/n] ("A" para abortar)
  40. ==> ------------------------------------------
  41. ==> n
  42.  
  43. ==> Dependências de safesignidentityclient:
  44.  - pcsclite (já instalado)
  45.  - gdbm183 (já instalado)
  46.  - openssl098 (já instalado)
  47.  - xdg-utils (já instalado)
  48.  - wxgtk2.8-light (compilando do AUR)
  49.  
  50.  
  51. ==> Continuar a compilação de safesignidentityclient ? [S/n]
  52. ==> --------------------------------------------------------
  53. ==> s
  54.  
  55. ==> Compilando e instalando pacote
  56. ==> Instalar ou compilar dependências que faltam para safesignidentityclient:
  57.  
  58. ==> Fazendo download do PKGBUILD de wxgtk2.8-light do AUR...
  59. x .SRCINFO
  60. x .gitignore
  61. x PKGBUILD
  62. x config-2.8.conf
  63. x make-abicheck-non-fatal.patch
  64. x wx-config-2.8.sh
  65. x wxGTK-2.8.12.1-r2-gcc6.patch
  66. x wxwidgets-2.8-collision.patch
  67. sl1pkn07 commented on 2015-02-09 16:04           
  68. ow men. fixed
  69.  
  70. sorry and greetings
  71.  
  72. user1549751245 commented on 2016-10-16 17:26             
  73. I get this error when compiling:
  74.  
  75. Extracting sources...
  76. - Creating working copy of wxWidgets git repo...
  77. Cloning into 'wxwidgets'...
  78. done.
  79. Switched to a new branch 'makepkg'
  80. == Starting prepare()...
  81.  
  82. *** Please tell me who you are.
  83.  
  84. Run
  85.  
  86. git config --global user.email "you@example.com"
  87. git config --global user.name "Your Name"
  88.  
  89. to set your account's default identity.
  90. Omit --global to set the identity only in this repository.
  91.  
  92. fatal: empty ident name (for (null)) not allowed
  93. == ERROR: A failure occurred in prepare().
  94. Aborting...
  95. == ERROR: Makepkg was unable to build wxwidgets-light.
  96. == Restart building wxbase-light ? [y/N]
  97.  
  98. sl1pkn07 commented on 2016-10-16 17:31           
  99. configure you git installation first
  100.  
  101. ProFfeSsoRr commented on 2017-03-06 11:48            
  102. Now this package can not build, need to add wxGTK-2.8.12.1-r2-gcc6.patch from non-light edition of this package.
  103.  
  104. geyslan commented on 2017-03-29 19:35            
  105. @ProFfeSsoRr, it's working again.
  106.  
  107. wxgtk2.8-light 2.8.12.1-10  (2017-03-29 19:30)
  108. ( Pacote sem suporte: Potencialmente perigoso ! )
  109. ==> Editar PKGBUILD ? [S/n] ("A" para abortar)
  110. ==> ------------------------------------------
  111. ==> n
  112.  
  113. ==> AVISO: Esse PKGBUILD descreve um pacote separado.
  114. ==> Opções específicas do pacote são desconhecidas
  115. ==> Dependências de wxwidgets2.8-light:
  116.  - git (já instalado) [makedepend]
  117.  - bash (já instalado) [makedepend]
  118.  - glu (já instalado) [makedepend]
  119.  - gtk2 (já instalado) [makedepend]
  120.  - libsm (já instalado) [makedepend]
  121.  - sdl (já instalado) [makedepend]
  122.  - expat (já instalado) [makedepend]
  123.  - zlib (já instalado) [makedepend]
  124.  - libjpeg-turbo (já instalado) [makedepend]
  125.  - gcc-libs-multilib (pacote encontrado) [makedepend]
  126.  
  127.  
  128. ==> Continuar a compilação de wxgtk2.8-light ? [S/n]
  129. ==> ------------------------------------------------
  130. ==> s
  131.  
  132. ==> Compilando e instalando pacote
  133. ==> Instalar ou compilar dependências que faltam para wxwidgets2.8-light:
  134. resolvendo dependências...
  135. procurando por pacotes conflitantes...
  136. :: gcc-libs-multilib e gcc-libs estão em conflito. Remover gcc-libs? [s/N] n
  137. erro: conflito de pacotes não solucionável detectado
  138. erro: falha ao preparar a transação (dependências conflitantes)
  139. :: gcc-libs-multilib e gcc-libs estão em conflito
  140. ==> Reiniciar a compilação de wxgtk2.8-light ? [s/N]
  141. ==> ------------------------------------------------
  142. ==> n
  143.  
  144. ==> Reiniciar a compilação de safesignidentityclient ? [s/N]
  145. ==> --------------------------------------------------------
  146. ==> n
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top