SHARE
TWEET

downgrading fourseven:scss error

a guest Mar 25th, 2020 697 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. myuser@MacBook-Pro imports % meteor add fourseven:scss@=4.5.4
  2.  => Errors while adding packages:            
  3.                                              
  4. While loading package fourseven:scss@4.5.4:
  5. error: Command failed: /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm rebuild --update-binary
  6. Cannot download "https://github.com/sass/node-sass/releases/download/v4.5.3/darwin-x64-72_binding.node":
  7.  
  8. HTTP error 404 Not Found
  9.  
  10. Hint: If github.com is not accessible in your location
  11. try setting a proxy via HTTP_PROXY, e.g.
  12.  
  13. export HTTP_PROXY=http://example.com:1234
  14.  
  15. or configure npm proxy via
  16.  
  17. npm config set proxy http://example.com:8080
  18. gyp info it worked if it ends with ok
  19. gyp verb cli [
  20. gyp verb cli   '/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node',
  21. gyp verb cli   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/bin/node-gyp.js',
  22. gyp verb cli   'rebuild',
  23. gyp verb cli   '--verbose',
  24. gyp verb cli   '--libsass_ext=',
  25. gyp verb cli   '--libsass_cflags=',
  26. gyp verb cli   '--libsass_ldflags=',
  27. gyp verb cli   '--libsass_library='
  28. gyp verb cli ]
  29. gyp info using node-gyp@3.6.2
  30. gyp info using node@12.16.1 | darwin | x64
  31. gyp verb command rebuild []
  32. gyp verb command clean []
  33. gyp verb clean removing "build" directory
  34. gyp verb command configure []
  35. gyp verb check python checking for Python executable "python2" in the PATH
  36. gyp verb `which` succeeded python2 /usr/local/bin/python2
  37. gyp verb check python version `/usr/local/bin/python2 -c "import platform; print(platform.python_version());"` returned: "2.7.17\n"
  38. gyp verb get node dir compiling against specified --nodedir dev files: /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle
  39. gyp verb build dir attempting to create "build" dir:
  40. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build
  41. gyp verb build dir "build" dir needed to be created?
  42. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build
  43. gyp verb build/config.gypi creating config file
  44. gyp verb build/config.gypi writing out config file:
  45. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build/config.gypi
  46. gyp verb config.gypi checking for gypi file:
  47. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/config.gypi
  48. gyp verb common.gypi checking for gypi file:
  49. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/common.gypi
  50. gyp verb gyp gyp format was not specified; forcing "make"
  51. gyp info spawn /usr/local/bin/python2
  52. gyp info spawn args [
  53. gyp info spawn args   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/gyp/gyp_main.py',
  54. gyp info spawn args   'binding.gyp',
  55. gyp info spawn args   '-f',
  56. gyp info spawn args   'make',
  57. gyp info spawn args   '-I',
  58. gyp info spawn args
  59. '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build/config.gypi',
  60. gyp info spawn args   '-I',
  61. gyp info spawn args   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/addon.gypi',
  62. gyp info spawn args   '-I',
  63. gyp info spawn args   '/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/common.gypi',
  64. gyp info spawn args   '-Dlibrary=shared_library',
  65. gyp info spawn args   '-Dvisibility=default',
  66. gyp info spawn args   '-Dnode_root_dir=/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle',
  67. gyp info spawn args   '-Dnode_gyp_dir=/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp',
  68. gyp info spawn args   '-Dnode_lib_file=/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/$(Configuration)/node.lib',
  69. gyp info spawn args
  70. '-Dmodule_root_dir=/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass',
  71. gyp info spawn args   '-Dnode_engine=v8',
  72. gyp info spawn args   '--depth=.',
  73. gyp info spawn args   '--no-parallel',
  74. gyp info spawn args   '--generator-output',
  75. gyp info spawn args   'build',
  76. gyp info spawn args   '-Goutput_dir=.'
  77. gyp info spawn args ]
  78. gyp verb command build []
  79. gyp verb build type Release
  80. gyp verb architecture x64
  81. gyp verb node dev dir /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle
  82. gyp verb `which` succeeded for `make` /usr/bin/make
  83. gyp info spawn make
  84. gyp info spawn args [ 'V=1', 'BUILDTYPE=Release', '-C', 'build' ]
  85. In file included from ../src/binding.cpp:1:
  86. In file included from ../../../../nan/nan.h:192:
  87. ../../../../nan/nan_maybe_43_inl.h:112:15: error: no member named 'ForceSet' in 'v8::Object'
  88. return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
  89. ~~~  ^
  90. In file included from ../src/binding.cpp:1:
  91. In file included from ../../../../nan/nan.h:197:
  92. In file included from ../../../../nan/nan_converters.h:59:
  93. ../../../../nan/nan_converters_43_inl.h:22:1: warning: 'ToBoolean' is deprecated: ToBoolean can never throw. Use Local version. [-Wdeprecated-declarations]
  94. X(Boolean)
  95. ^
  96. ../../../../nan/nan_converters_43_inl.h:18:12: note: expanded from macro 'X'
  97. val->To ## TYPE(v8::Isolate::GetCurrent()->GetCurrentContext())          \
  98. ^
  99. <scratch space>:10:1: note: expanded from here
  100. ToBoolean
  101. ^
  102. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2663:3: note: 'ToBoolean' has been explicitly marked deprecated here
  103. V8_DEPRECATED("ToBoolean can never throw. Use Local version.",
  104. ^
  105. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  106. declarator __attribute__((deprecated(message)))
  107. ^
  108. In file included from ../src/binding.cpp:1:
  109. In file included from ../../../../nan/nan.h:197:
  110. In file included from ../../../../nan/nan_converters.h:59:
  111. ../../../../nan/nan_converters_43_inl.h:40:1: warning: 'BooleanValue' is deprecated: BooleanValue can never throw. Use Isolate version. [-Wdeprecated-declarations]
  112. X(bool, Boolean)
  113. ^
  114. ../../../../nan/nan_converters_43_inl.h:37:15: note: expanded from macro 'X'
  115. return val->NAME ## Value(isolate->GetCurrentContext());                     \
  116. ^
  117. <scratch space>:17:1: note: expanded from here
  118. BooleanValue
  119. ^
  120. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2701:3: note: 'BooleanValue' has been explicitly marked deprecated
  121. here
  122. V8_DEPRECATED("BooleanValue can never throw. Use Isolate version.",
  123. ^
  124. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  125. declarator __attribute__((deprecated(message)))
  126. ^
  127. In file included from ../src/binding.cpp:1:
  128. In file included from ../../../../nan/nan.h:198:
  129. In file included from ../../../../nan/nan_new.h:189:
  130. ../../../../nan/nan_implementation_12_inl.h:103:42: error: no viable conversion from 'v8::Isolate *' to 'Local<v8::Context>'
  131. return scope.Escape(v8::Function::New( isolate
  132. ^~~~~~~
  133. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:186:7: note: candidate constructor (the implicit copy constructor) not
  134. viable: no known conversion from 'v8::Isolate *' to 'const v8::Local<v8::Context> &' for 1st argument
  135. class Local {
  136. ^
  137. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:186:7: note: candidate constructor (the implicit move constructor) not
  138. viable: no known conversion from 'v8::Isolate *' to 'v8::Local<v8::Context> &&' for 1st argument
  139. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:190:13: note: candidate template ignored: could not match
  140. 'Local<type-parameter-0-0>' against 'v8::Isolate *'
  141. V8_INLINE Local(Local<S> that)
  142. ^
  143. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:4276:22: note: passing argument to parameter 'context' here
  144. Local<Context> context, FunctionCallback callback,
  145. ^
  146. In file included from ../src/binding.cpp:1:
  147. In file included from ../../../../nan/nan.h:198:
  148. In file included from ../../../../nan/nan_new.h:189:
  149. ../../../../nan/nan_implementation_12_inl.h:337:37: error: too few arguments to function call, expected 2, have 1
  150. return v8::StringObject::New(value).As<v8::StringObject>();
  151. ~~~~~~~~~~~~~~~~~~~~~      ^
  152. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:5531:3: note: 'New' declared here
  153. static Local<Value> New(Isolate* isolate, Local<String> value);
  154. ^
  155. In file included from ../src/binding.cpp:1:
  156. ../../../../nan/nan.h:834:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  157. return node::MakeCallback(
  158. ^
  159. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:173:1: note: 'MakeCallback' has been explicitly marked deprecated
  160. here
  161. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  162. ^
  163. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  164. __attribute__((deprecated(message))) declarator
  165. ^
  166. In file included from ../src/binding.cpp:1:
  167. ../../../../nan/nan.h:849:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  168. return node::MakeCallback(
  169. ^
  170. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:166:1: note: 'MakeCallback' has been explicitly marked deprecated
  171. here
  172. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  173. ^
  174. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  175. __attribute__((deprecated(message))) declarator
  176. ^
  177. In file included from ../src/binding.cpp:1:
  178. ../../../../nan/nan.h:864:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  179. return node::MakeCallback(
  180. ^
  181. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:159:1: note: 'MakeCallback' has been explicitly marked deprecated
  182. here
  183. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  184. ^
  185. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  186. __attribute__((deprecated(message))) declarator
  187. ^
  188. In file included from ../src/binding.cpp:1:
  189. ../../../../nan/nan.h:911:44: error: no matching member function for call to 'ToString'
  190. v8::Local<v8::String> string = from->ToString();
  191. ~~~~~~^~~~~~~~
  192. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2668:44: note: candidate function not viable: requires single argument
  193. 'context', but no arguments were provided
  194. V8_WARN_UNUSED_RESULT MaybeLocal<String> ToString(
  195. ^
  196. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2684:31: note: candidate function not viable: requires single argument
  197. 'isolate', but no arguments were provided
  198. Local<String> ToString(Isolate* isolate) const);
  199. ^
  200. In file included from ../src/binding.cpp:1:
  201. ../../../../nan/nan.h:921:37: error: cannot initialize a parameter of type 'v8::Isolate *' with an lvalue of type 'char *'
  202. length_ = string->WriteUtf8(str_, static_cast<int>(len), 0, flags);
  203. ^~~~
  204. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2878:26: note: passing argument to parameter 'isolate' here
  205. int WriteUtf8(Isolate* isolate, char* buffer, int length = -1,
  206. ^
  207. In file included from ../src/binding.cpp:1:
  208. ../../../../nan/nan.h:1473:31: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  209. return scope.Escape(node::MakeCallback(
  210. ^
  211. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:173:1: note: 'MakeCallback' has been explicitly marked deprecated
  212. here
  213. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  214. ^
  215. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  216. __attribute__((deprecated(message))) declarator
  217. ^
  218. In file included from ../src/binding.cpp:1:
  219. ../../../../nan/nan.h:1533:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  220. New(persistentHandle)->Set(New(key).ToLocalChecked(), value);
  221. ^
  222. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  223. V8_DEPRECATED("Use maybe version",
  224. ^
  225. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  226. declarator __attribute__((deprecated(message)))
  227. ^
  228. In file included from ../src/binding.cpp:1:
  229. ../../../../nan/nan.h:1539:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  230. New(persistentHandle)->Set(key, value);
  231. ^
  232. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  233. V8_DEPRECATED("Use maybe version",
  234. ^
  235. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  236. declarator __attribute__((deprecated(message)))
  237. ^
  238. In file included from ../src/binding.cpp:1:
  239. ../../../../nan/nan.h:1545:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  240. New(persistentHandle)->Set(index, value);
  241. ^
  242. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3507:3: note: 'Set' has been explicitly marked deprecated here
  243. V8_DEPRECATED("Use maybe version",
  244. ^
  245. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  246. declarator __attribute__((deprecated(message)))
  247. ^
  248. In file included from ../src/binding.cpp:1:
  249. ../../../../nan/nan.h:1551:32: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  250. New(persistentHandle)->Get(New(key).ToLocalChecked()));
  251. ^
  252. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3553:3: note: 'Get' has been explicitly marked deprecated here
  253. V8_DEPRECATED("Use maybe version", Local<Value> Get(Local<Value> key));
  254. ^
  255. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  256. declarator __attribute__((deprecated(message)))
  257. ^
  258. In file included from ../src/binding.cpp:1:
  259. ../../../../nan/nan.h:1557:48: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  260. return scope.Escape(New(persistentHandle)->Get(key));
  261. ^
  262. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3553:3: note: 'Get' has been explicitly marked deprecated here
  263. V8_DEPRECATED("Use maybe version", Local<Value> Get(Local<Value> key));
  264. ^
  265. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  266. declarator __attribute__((deprecated(message)))
  267. ^
  268. In file included from ../src/binding.cpp:1:
  269. ../../../../nan/nan.h:1562:48: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  270. return scope.Escape(New(persistentHandle)->Get(index));
  271. ^
  272. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3557:3: note: 'Get' has been explicitly marked deprecated here
  273. V8_DEPRECATED("Use maybe version", Local<Value> Get(uint32_t index));
  274. ^
  275. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  276. declarator __attribute__((deprecated(message)))
  277. ^
  278. In file included from ../src/binding.cpp:1:
  279. In file included from ../../../../nan/nan.h:2222:
  280. ../../../../nan/nan_object_wrap.h:24:25: error: no member named 'IsNearDeath' in 'Nan::Persistent<v8::Object, v8::NonCopyablePersistentTraits<v8::Object> >'
  281. assert(persistent().IsNearDeath());
  282. ~~~~~~~~~~~~ ^
  283. /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/assert.h:93:25: note: expanded from macro 'assert'
  284. (__builtin_expect(!(e), 0) ? __assert_rtn(__func__, __FILE__, __LINE__, #e) : (void)0)
  285. ^
  286. In file included from ../src/binding.cpp:1:
  287. In file included from ../../../../nan/nan.h:2222:
  288. ../../../../nan/nan_object_wrap.h:67:18: warning: 'MarkIndependent' is deprecated: Weak objects are always considered independent. Use TracedGlobal when trying to use EmbedderHeapTracer. Use a strong handle when trying to keep an object alive.
  289. [-Wdeprecated-declarations]
  290. persistent().MarkIndependent();
  291. ^
  292. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:566:3: note: 'MarkIndependent' has been explicitly marked deprecated
  293. here
  294. V8_DEPRECATED(
  295. ^
  296. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  297. declarator __attribute__((deprecated(message)))
  298. ^
  299. In file included from ../src/binding.cpp:1:
  300. In file included from ../../../../nan/nan.h:2222:
  301. ../../../../nan/nan_object_wrap.h:124:26: error: no member named 'IsNearDeath' in 'Nan::Persistent<v8::Object, v8::NonCopyablePersistentTraits<v8::Object> >'
  302. assert(wrap->handle_.IsNearDeath());
  303. ~~~~~~~~~~~~~ ^
  304. /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/assert.h:93:25: note: expanded from macro 'assert'
  305. (__builtin_expect(!(e), 0) ? __assert_rtn(__func__, __FILE__, __LINE__, #e) : (void)0)
  306. ^
  307. In file included from ../src/binding.cpp:1:
  308. ../../../../nan/nan.h:1902:9: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  309. recv->Set(name, GetFunction(tpl).ToLocalChecked());
  310. ^
  311. ../../../../nan/nan.h:1918:8: note: in instantiation of function template specialization 'Nan::imp::SetMethodAux<v8::Local<v8::Object> >' requested here
  312. imp::SetMethodAux(recv, fn_name, t, static_cast<T*>(0));
  313. ^
  314. ../src/binding.cpp:335:8: note: in instantiation of function template specialization 'Nan::SetMethod<v8::Object, Local>' requested here
  315. Nan::SetMethod(target, "render", render);
  316. ^
  317. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  318. V8_DEPRECATED("Use maybe version",
  319. ^
  320. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  321. declarator __attribute__((deprecated(message)))
  322. ^
  323. 14 warnings and 7 errors generated.
  324. make: *** [Release/obj.target/binding/src/binding.o] Error 1
  325. gyp ERR! build error
  326. gyp ERR! stack Error: `make` failed with exit code: 2
  327. gyp ERR! stack     at ChildProcess.onExit
  328. (/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/lib/build.js:258:23)
  329. gyp ERR! stack     at ChildProcess.emit (events.js:311:20)
  330. gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)
  331. gyp ERR! System Darwin 19.3.0
  332. gyp ERR! command "/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node"
  333. "/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext="
  334. "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
  335. gyp ERR! cwd /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass
  336. gyp ERR! node -v v12.16.1
  337. gyp ERR! node-gyp -v v3.6.2
  338. gyp ERR! not ok
  339. Build failed with error code: 1
  340. npm ERR! code ELIFECYCLE
  341. npm ERR! errno 1
  342. npm ERR! node-sass@4.5.3 postinstall: `node scripts/build.js`
  343. npm ERR! Exit status 1
  344. npm ERR!
  345. npm ERR! Failed at the node-sass@4.5.3 postinstall script.
  346. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
  347.  
  348. npm ERR! A complete log of this run can be found in:
  349. npm ERR!     /Users/myuser/.npm/_logs/2020-03-25T14_49_37_709Z-debug.log
  350. Cannot download "https://github.com/sass/node-sass/releases/download/v4.5.3/darwin-x64-72_binding.node":
  351.  
  352. HTTP error 404 Not Found
  353.  
  354. Hint: If github.com is not accessible in your location
  355. try setting a proxy via HTTP_PROXY, e.g.
  356.  
  357. export HTTP_PROXY=http://example.com:1234
  358.  
  359. or configure npm proxy via
  360.  
  361. npm config set proxy http://example.com:8080
  362. gyp info it worked if it ends with ok
  363. gyp verb cli [
  364. gyp verb cli   '/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node',
  365. gyp verb cli   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/bin/node-gyp.js',
  366. gyp verb cli   'rebuild',
  367. gyp verb cli   '--verbose',
  368. gyp verb cli   '--libsass_ext=',
  369. gyp verb cli   '--libsass_cflags=',
  370. gyp verb cli   '--libsass_ldflags=',
  371. gyp verb cli   '--libsass_library='
  372. gyp verb cli ]
  373. gyp info using node-gyp@3.6.2
  374. gyp info using node@12.16.1 | darwin | x64
  375. gyp verb command rebuild []
  376. gyp verb command clean []
  377. gyp verb clean removing "build" directory
  378. gyp verb command configure []
  379. gyp verb check python checking for Python executable "python2" in the PATH
  380. gyp verb `which` succeeded python2 /usr/local/bin/python2
  381. gyp verb check python version `/usr/local/bin/python2 -c "import platform; print(platform.python_version());"` returned: "2.7.17\n"
  382. gyp verb get node dir compiling against specified --nodedir dev files: /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle
  383. gyp verb build dir attempting to create "build" dir:
  384. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build
  385. gyp verb build dir "build" dir needed to be created?
  386. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build
  387. gyp verb build/config.gypi creating config file
  388. gyp verb build/config.gypi writing out config file:
  389. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build/config.gypi
  390. gyp verb config.gypi checking for gypi file:
  391. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/config.gypi
  392. gyp verb common.gypi checking for gypi file:
  393. /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/common.gypi
  394. gyp verb gyp gyp format was not specified; forcing "make"
  395. gyp info spawn /usr/local/bin/python2
  396. gyp info spawn args [
  397. gyp info spawn args   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/gyp/gyp_main.py',
  398. gyp info spawn args   'binding.gyp',
  399. gyp info spawn args   '-f',
  400. gyp info spawn args   'make',
  401. gyp info spawn args   '-I',
  402. gyp info spawn args
  403. '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass/build/config.gypi',
  404. gyp info spawn args   '-I',
  405. gyp info spawn args   '/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/addon.gypi',
  406. gyp info spawn args   '-I',
  407. gyp info spawn args   '/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/common.gypi',
  408. gyp info spawn args   '-Dlibrary=shared_library',
  409. gyp info spawn args   '-Dvisibility=default',
  410. gyp info spawn args   '-Dnode_root_dir=/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle',
  411. gyp info spawn args   '-Dnode_gyp_dir=/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp',
  412. gyp info spawn args   '-Dnode_lib_file=/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/$(Configuration)/node.lib',
  413. gyp info spawn args
  414. '-Dmodule_root_dir=/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass',
  415. gyp info spawn args   '-Dnode_engine=v8',
  416. gyp info spawn args   '--depth=.',
  417. gyp info spawn args   '--no-parallel',
  418. gyp info spawn args   '--generator-output',
  419. gyp info spawn args   'build',
  420. gyp info spawn args   '-Goutput_dir=.'
  421. gyp info spawn args ]
  422. gyp verb command build []
  423. gyp verb build type Release
  424. gyp verb architecture x64
  425. gyp verb node dev dir /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle
  426. gyp verb `which` succeeded for `make` /usr/bin/make
  427. gyp info spawn make
  428. gyp info spawn args [ 'V=1', 'BUILDTYPE=Release', '-C', 'build' ]
  429. In file included from ../src/binding.cpp:1:
  430. In file included from ../../../../nan/nan.h:192:
  431. ../../../../nan/nan_maybe_43_inl.h:112:15: error: no member named 'ForceSet' in 'v8::Object'
  432. return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
  433. ~~~  ^
  434. In file included from ../src/binding.cpp:1:
  435. In file included from ../../../../nan/nan.h:197:
  436. In file included from ../../../../nan/nan_converters.h:59:
  437. ../../../../nan/nan_converters_43_inl.h:22:1: warning: 'ToBoolean' is deprecated: ToBoolean can never throw. Use Local version. [-Wdeprecated-declarations]
  438. X(Boolean)
  439. ^
  440. ../../../../nan/nan_converters_43_inl.h:18:12: note: expanded from macro 'X'
  441. val->To ## TYPE(v8::Isolate::GetCurrent()->GetCurrentContext())          \
  442. ^
  443. <scratch space>:10:1: note: expanded from here
  444. ToBoolean
  445. ^
  446. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2663:3: note: 'ToBoolean' has been explicitly marked deprecated here
  447. V8_DEPRECATED("ToBoolean can never throw. Use Local version.",
  448. ^
  449. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  450. declarator __attribute__((deprecated(message)))
  451. ^
  452. In file included from ../src/binding.cpp:1:
  453. In file included from ../../../../nan/nan.h:197:
  454. In file included from ../../../../nan/nan_converters.h:59:
  455. ../../../../nan/nan_converters_43_inl.h:40:1: warning: 'BooleanValue' is deprecated: BooleanValue can never throw. Use Isolate version. [-Wdeprecated-declarations]
  456. X(bool, Boolean)
  457. ^
  458. ../../../../nan/nan_converters_43_inl.h:37:15: note: expanded from macro 'X'
  459. return val->NAME ## Value(isolate->GetCurrentContext());                     \
  460. ^
  461. <scratch space>:17:1: note: expanded from here
  462. BooleanValue
  463. ^
  464. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2701:3: note: 'BooleanValue' has been explicitly marked deprecated
  465. here
  466. V8_DEPRECATED("BooleanValue can never throw. Use Isolate version.",
  467. ^
  468. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  469. declarator __attribute__((deprecated(message)))
  470. ^
  471. In file included from ../src/binding.cpp:1:
  472. In file included from ../../../../nan/nan.h:198:
  473. In file included from ../../../../nan/nan_new.h:189:
  474. ../../../../nan/nan_implementation_12_inl.h:103:42: error: no viable conversion from 'v8::Isolate *' to 'Local<v8::Context>'
  475. return scope.Escape(v8::Function::New( isolate
  476. ^~~~~~~
  477. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:186:7: note: candidate constructor (the implicit copy constructor) not
  478. viable: no known conversion from 'v8::Isolate *' to 'const v8::Local<v8::Context> &' for 1st argument
  479. class Local {
  480. ^
  481. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:186:7: note: candidate constructor (the implicit move constructor) not
  482. viable: no known conversion from 'v8::Isolate *' to 'v8::Local<v8::Context> &&' for 1st argument
  483. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:190:13: note: candidate template ignored: could not match
  484. 'Local<type-parameter-0-0>' against 'v8::Isolate *'
  485. V8_INLINE Local(Local<S> that)
  486. ^
  487. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:4276:22: note: passing argument to parameter 'context' here
  488. Local<Context> context, FunctionCallback callback,
  489. ^
  490. In file included from ../src/binding.cpp:1:
  491. In file included from ../../../../nan/nan.h:198:
  492. In file included from ../../../../nan/nan_new.h:189:
  493. ../../../../nan/nan_implementation_12_inl.h:337:37: error: too few arguments to function call, expected 2, have 1
  494. return v8::StringObject::New(value).As<v8::StringObject>();
  495. ~~~~~~~~~~~~~~~~~~~~~      ^
  496. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:5531:3: note: 'New' declared here
  497. static Local<Value> New(Isolate* isolate, Local<String> value);
  498. ^
  499. In file included from ../src/binding.cpp:1:
  500. ../../../../nan/nan.h:834:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  501. return node::MakeCallback(
  502. ^
  503. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:173:1: note: 'MakeCallback' has been explicitly marked deprecated
  504. here
  505. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  506. ^
  507. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  508. __attribute__((deprecated(message))) declarator
  509. ^
  510. In file included from ../src/binding.cpp:1:
  511. ../../../../nan/nan.h:849:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  512. return node::MakeCallback(
  513. ^
  514. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:166:1: note: 'MakeCallback' has been explicitly marked deprecated
  515. here
  516. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  517. ^
  518. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  519. __attribute__((deprecated(message))) declarator
  520. ^
  521. In file included from ../src/binding.cpp:1:
  522. ../../../../nan/nan.h:864:18: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  523. return node::MakeCallback(
  524. ^
  525. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:159:1: note: 'MakeCallback' has been explicitly marked deprecated
  526. here
  527. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  528. ^
  529. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  530. __attribute__((deprecated(message))) declarator
  531. ^
  532. In file included from ../src/binding.cpp:1:
  533. ../../../../nan/nan.h:911:44: error: no matching member function for call to 'ToString'
  534. v8::Local<v8::String> string = from->ToString();
  535. ~~~~~~^~~~~~~~
  536. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2668:44: note: candidate function not viable: requires single argument
  537. 'context', but no arguments were provided
  538. V8_WARN_UNUSED_RESULT MaybeLocal<String> ToString(
  539. ^
  540. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2684:31: note: candidate function not viable: requires single argument
  541. 'isolate', but no arguments were provided
  542. Local<String> ToString(Isolate* isolate) const);
  543. ^
  544. In file included from ../src/binding.cpp:1:
  545. ../../../../nan/nan.h:921:37: error: cannot initialize a parameter of type 'v8::Isolate *' with an lvalue of type 'char *'
  546. length_ = string->WriteUtf8(str_, static_cast<int>(len), 0, flags);
  547. ^~~~
  548. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:2878:26: note: passing argument to parameter 'isolate' here
  549. int WriteUtf8(Isolate* isolate, char* buffer, int length = -1,
  550. ^
  551. In file included from ../src/binding.cpp:1:
  552. ../../../../nan/nan.h:1473:31: warning: 'MakeCallback' is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
  553. return scope.Escape(node::MakeCallback(
  554. ^
  555. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:173:1: note: 'MakeCallback' has been explicitly marked deprecated
  556. here
  557. NODE_DEPRECATED("Use MakeCallback(..., async_context)",
  558. ^
  559. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/node.h:93:20: note: expanded from macro 'NODE_DEPRECATED'
  560. __attribute__((deprecated(message))) declarator
  561. ^
  562. In file included from ../src/binding.cpp:1:
  563. ../../../../nan/nan.h:1533:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  564. New(persistentHandle)->Set(New(key).ToLocalChecked(), value);
  565. ^
  566. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  567. V8_DEPRECATED("Use maybe version",
  568. ^
  569. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  570. declarator __attribute__((deprecated(message)))
  571. ^
  572. In file included from ../src/binding.cpp:1:
  573. ../../../../nan/nan.h:1539:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  574. New(persistentHandle)->Set(key, value);
  575. ^
  576. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  577. V8_DEPRECATED("Use maybe version",
  578. ^
  579. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  580. declarator __attribute__((deprecated(message)))
  581. ^
  582. In file included from ../src/binding.cpp:1:
  583. ../../../../nan/nan.h:1545:28: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  584. New(persistentHandle)->Set(index, value);
  585. ^
  586. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3507:3: note: 'Set' has been explicitly marked deprecated here
  587. V8_DEPRECATED("Use maybe version",
  588. ^
  589. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  590. declarator __attribute__((deprecated(message)))
  591. ^
  592. In file included from ../src/binding.cpp:1:
  593. ../../../../nan/nan.h:1551:32: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  594. New(persistentHandle)->Get(New(key).ToLocalChecked()));
  595. ^
  596. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3553:3: note: 'Get' has been explicitly marked deprecated here
  597. V8_DEPRECATED("Use maybe version", Local<Value> Get(Local<Value> key));
  598. ^
  599. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  600. declarator __attribute__((deprecated(message)))
  601. ^
  602. In file included from ../src/binding.cpp:1:
  603. ../../../../nan/nan.h:1557:48: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  604. return scope.Escape(New(persistentHandle)->Get(key));
  605. ^
  606. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3553:3: note: 'Get' has been explicitly marked deprecated here
  607. V8_DEPRECATED("Use maybe version", Local<Value> Get(Local<Value> key));
  608. ^
  609. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  610. declarator __attribute__((deprecated(message)))
  611. ^
  612. In file included from ../src/binding.cpp:1:
  613. ../../../../nan/nan.h:1562:48: warning: 'Get' is deprecated: Use maybe version [-Wdeprecated-declarations]
  614. return scope.Escape(New(persistentHandle)->Get(index));
  615. ^
  616. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3557:3: note: 'Get' has been explicitly marked deprecated here
  617. V8_DEPRECATED("Use maybe version", Local<Value> Get(uint32_t index));
  618. ^
  619. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  620. declarator __attribute__((deprecated(message)))
  621. ^
  622. In file included from ../src/binding.cpp:1:
  623. In file included from ../../../../nan/nan.h:2222:
  624. ../../../../nan/nan_object_wrap.h:24:25: error: no member named 'IsNearDeath' in 'Nan::Persistent<v8::Object, v8::NonCopyablePersistentTraits<v8::Object> >'
  625. assert(persistent().IsNearDeath());
  626. ~~~~~~~~~~~~ ^
  627. /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/assert.h:93:25: note: expanded from macro 'assert'
  628. (__builtin_expect(!(e), 0) ? __assert_rtn(__func__, __FILE__, __LINE__, #e) : (void)0)
  629. ^
  630. In file included from ../src/binding.cpp:1:
  631. In file included from ../../../../nan/nan.h:2222:
  632. ../../../../nan/nan_object_wrap.h:67:18: warning: 'MarkIndependent' is deprecated: Weak objects are always considered independent. Use TracedGlobal when trying to use EmbedderHeapTracer. Use a strong handle when trying to keep an object alive.
  633. [-Wdeprecated-declarations]
  634. persistent().MarkIndependent();
  635. ^
  636. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:566:3: note: 'MarkIndependent' has been explicitly marked deprecated
  637. here
  638. V8_DEPRECATED(
  639. ^
  640. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  641. declarator __attribute__((deprecated(message)))
  642. ^
  643. In file included from ../src/binding.cpp:1:
  644. In file included from ../../../../nan/nan.h:2222:
  645. ../../../../nan/nan_object_wrap.h:124:26: error: no member named 'IsNearDeath' in 'Nan::Persistent<v8::Object, v8::NonCopyablePersistentTraits<v8::Object> >'
  646. assert(wrap->handle_.IsNearDeath());
  647. ~~~~~~~~~~~~~ ^
  648. /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/assert.h:93:25: note: expanded from macro 'assert'
  649. (__builtin_expect(!(e), 0) ? __assert_rtn(__func__, __FILE__, __LINE__, #e) : (void)0)
  650. ^
  651. In file included from ../src/binding.cpp:1:
  652. ../../../../nan/nan.h:1902:9: warning: 'Set' is deprecated: Use maybe version [-Wdeprecated-declarations]
  653. recv->Set(name, GetFunction(tpl).ToLocalChecked());
  654. ^
  655. ../../../../nan/nan.h:1918:8: note: in instantiation of function template specialization 'Nan::imp::SetMethodAux<v8::Local<v8::Object> >' requested here
  656. imp::SetMethodAux(recv, fn_name, t, static_cast<T*>(0));
  657. ^
  658. ../src/binding.cpp:335:8: note: in instantiation of function template specialization 'Nan::SetMethod<v8::Object, Local>' requested here
  659. Nan::SetMethod(target, "render", render);
  660. ^
  661. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8.h:3498:3: note: 'Set' has been explicitly marked deprecated here
  662. V8_DEPRECATED("Use maybe version",
  663. ^
  664. /Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/include/node/v8config.h:328:29: note: expanded from macro 'V8_DEPRECATED'
  665. declarator __attribute__((deprecated(message)))
  666. ^
  667. 14 warnings and 7 errors generated.
  668. make: *** [Release/obj.target/binding/src/binding.o] Error 1
  669. gyp ERR! build error
  670. gyp ERR! stack Error: `make` failed with exit code: 2
  671. gyp ERR! stack     at ChildProcess.onExit
  672. (/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/lib/build.js:258:23)
  673. gyp ERR! stack     at ChildProcess.emit (events.js:311:20)
  674. gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)
  675. gyp ERR! System Darwin 19.3.0
  676. gyp ERR! command "/Users/myuser/.meteor/packages/meteor-tool/.1.10.1.hmdlyt.9z6em++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node"
  677. "/Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext="
  678. "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
  679. gyp ERR! cwd /Users/myuser/.meteor/packages/fourseven_scss/.4.5.4.1yaslak++os+web.browser+web.cordova/plugin.compileScssBatch.os/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1xb2uyi.wu11/node_modules/node-sass
  680. gyp ERR! node -v v12.16.1
  681. gyp ERR! node-gyp -v v3.6.2
  682. gyp ERR! not ok
  683. Build failed with error code: 1
  684. npm ERR! code ELIFECYCLE
  685. npm ERR! errno 1
  686. npm ERR! node-sass@4.5.3 postinstall: `node scripts/build.js`
  687. npm ERR! Exit status 1
  688. npm ERR!
  689. npm ERR! Failed at the node-sass@4.5.3 postinstall script.
  690. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
  691.  
  692. npm ERR! A complete log of this run can be found in:
  693. npm ERR!     /Users/myuser/.npm/_logs/2020-03-25T14_49_37_709Z-debug.log
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Top