Advertisement
Not a member of Pastebin yet?
Sign Up,
it unlocks many cool features!
- root@router:~# ubus call system board; \
- > uci export network; \
- > uci export dhcp; uci export firewall; \
- > head -n -0 /etc/firewall.user; \
- > iptables-save -c; \
- > ip -4 addr ; ip -4 ro li tab all ; ip -4 ru
- {
- "kernel": "5.4.154",
- "hostname": "cerberus",
- "system": "ARMv7 Processor rev 1 (v7l)",
- "model": "Linksys WRT1200AC",
- "board_name": "linksys,wrt1200ac",
- "release": {
- "distribution": "OpenWrt",
- "version": "21.02.1",
- "revision": "r16325-88151b8303",
- "target": "mvebu/cortexa9",
- "description": "OpenWrt 21.02.1 r16325-88151b8303"
- }
- }
- package network
- config interface 'loopback'
- option device 'lo'
- option proto 'static'
- option ipaddr '127.0.0.1'
- option netmask '255.0.0.0'
- config globals 'globals'
- option ula_prefix 'fdad:caa7:f4af::/48'
- config device
- option name 'br-lan'
- option type 'bridge'
- list ports 'lan1'
- list ports 'lan2'
- list ports 'lan3'
- list ports 'lan4'
- config interface 'lan'
- option proto 'static'
- option netmask '255.255.255.0'
- option ip6assign '60'
- list dns_search '[Redacted Domain]'
- list dns '10.1.1.3'
- list dns '1.1.1.1'
- list dns '1.0.0.1'
- option device 'br-lan.100'
- option ipaddr '10.0.0.1'
- config device
- option name 'wan'
- option macaddr '[Redacted MAC]'
- config interface 'wan'
- option device 'wan'
- option proto 'static'
- option ipaddr '[Redacted WAN IP]'
- option netmask '[Redacted]'
- option gateway '[Redacted]'
- list dns '[ISP DNS Server #1]'
- list dns '[ISP DNS Server #2]'
- config interface 'wan6'
- option device 'wan'
- option proto 'dhcpv6'
- config bridge-vlan
- option device 'br-lan'
- option vlan '3'
- list ports 'lan1:t'
- config bridge-vlan
- option device 'br-lan'
- option vlan '4'
- list ports 'lan1:t'
- config bridge-vlan
- option device 'br-lan'
- option vlan '100'
- list ports 'lan1:t'
- list ports 'lan2:u*'
- list ports 'lan3:u*'
- config bridge-vlan
- option device 'br-lan'
- option vlan '200'
- list ports 'lan1:t'
- list ports 'lan4:u*'
- config interface 'SERVER'
- option proto 'static'
- option device 'br-lan.200'
- option netmask '255.255.255.0'
- option ipaddr '10.1.1.1'
- list dns_search '[Redacted Domain]'
- list dns '10.1.1.3'
- list dns '1.1.1.1'
- list dns '1.0.0.1'
- config interface 'GUEST'
- option proto 'static'
- option device 'br-lan.3'
- option ipaddr '10.0.1.1'
- option netmask '255.255.255.0'
- list dns '10.1.1.3'
- list dns '1.1.1.1'
- list dns '1.0.0.1'
- list dns_search '[Redacted Domain]'
- config interface 'IOT'
- option proto 'static'
- option device 'br-lan.4'
- option ipaddr '10.0.2.0'
- option netmask '255.255.255.0'
- list dns '10.1.1.3'
- list dns '1.1.1.1'
- list dns '1.0.0.1'
- list dns_search '[Redacted Domain]'
- package dhcp
- config dnsmasq
- option domainneeded '1'
- option localise_queries '1'
- option rebind_protection '1'
- option rebind_localhost '1'
- option local '/lan/'
- option expandhosts '1'
- option authoritative '1'
- option readethers '1'
- option leasefile '/tmp/dhcp.leases'
- option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
- option localservice '1'
- option ednspacket_max '1232'
- option domain '[Redacted]'
- list server '10.1.1.3'
- list server '1.1.1.1'
- list server '1.0.0.1'
- config dhcp 'lan'
- option interface 'lan'
- option start '100'
- option limit '150'
- option leasetime '12h'
- option dhcpv4 'server'
- option dhcpv6 'server'
- option ra 'server'
- list ra_flags 'managed-config'
- list ra_flags 'other-config'
- list dhcp_option '6,10.1.1.3,1.1.1.1,1.0.0.1'
- config dhcp 'wan'
- option interface 'wan'
- option ignore '1'
- option start '100'
- option limit '150'
- option leasetime '12h'
- list ra_flags 'none'
- config odhcpd 'odhcpd'
- option maindhcp '0'
- option leasefile '/tmp/hosts/odhcpd'
- option leasetrigger '/usr/sbin/odhcpd-update'
- option loglevel '4'
- # EDITORS NOTE: Following this line were 13 `config host` groups which
- # I have redacted, because they detailed static IP assignments that
- # contained lots of MAC addresses, didnt think including all of it was imperative.
- # All pointed to MACs on my SERVER network and assigned them 10.1.1.X IPs.
- # Also worth noting 10.1.1.3 hosts my DNS.
- config dhcp 'SERVER'
- option interface 'SERVER'
- option leasetime '12h'
- option start '200'
- option limit '50'
- list dhcp_option '6,10.1.1.3,1.1.1.1,1.0.0.1'
- list ra_flags 'none'
- config dhcp 'GUEST'
- option interface 'GUEST'
- option start '100'
- option limit '150'
- option leasetime '12h'
- list ra_flags 'none'
- config dhcp 'IOT'
- option interface 'IOT'
- option start '100'
- option limit '150'
- option leasetime '12h'
- list ra_flags 'none'
- package firewall
- config defaults
- option input 'ACCEPT'
- option output 'ACCEPT'
- option synflood_protect '1'
- option forward 'REJECT'
- config zone
- list network 'lan'
- option input 'ACCEPT'
- option output 'ACCEPT'
- option forward 'ACCEPT'
- option name 'lan'
- config zone
- list network 'wan'
- list network 'wan6'
- option input 'REJECT'
- option output 'ACCEPT'
- option masq '1'
- option mtu_fix '1'
- option name 'wan'
- option forward 'REJECT'
- config forwarding
- option src 'lan'
- option dest 'wan'
- config rule
- option name 'Allow-DHCP-Renew'
- option proto 'udp'
- option dest_port '68'
- option target 'ACCEPT'
- option family 'ipv4'
- option src 'wan'
- config rule
- option name 'Allow-Ping'
- option proto 'icmp'
- option icmp_type 'echo-request'
- option family 'ipv4'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-IGMP'
- option proto 'igmp'
- option family 'ipv4'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-DHCPv6'
- option proto 'udp'
- option src_ip 'fc00::/6'
- option dest_ip 'fc00::/6'
- option dest_port '546'
- option family 'ipv6'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-MLD'
- option proto 'icmp'
- option src_ip 'fe80::/10'
- list icmp_type '130/0'
- list icmp_type '131/0'
- list icmp_type '132/0'
- list icmp_type '143/0'
- option family 'ipv6'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-ICMPv6-Input'
- option proto 'icmp'
- list icmp_type 'echo-request'
- list icmp_type 'echo-reply'
- list icmp_type 'destination-unreachable'
- list icmp_type 'packet-too-big'
- list icmp_type 'time-exceeded'
- list icmp_type 'bad-header'
- list icmp_type 'unknown-header-type'
- list icmp_type 'router-solicitation'
- list icmp_type 'neighbour-solicitation'
- list icmp_type 'router-advertisement'
- list icmp_type 'neighbour-advertisement'
- option limit '1000/sec'
- option family 'ipv6'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-ICMPv6-Forward'
- option dest '*'
- option proto 'icmp'
- list icmp_type 'echo-request'
- list icmp_type 'echo-reply'
- list icmp_type 'destination-unreachable'
- list icmp_type 'packet-too-big'
- list icmp_type 'time-exceeded'
- list icmp_type 'bad-header'
- list icmp_type 'unknown-header-type'
- option limit '1000/sec'
- option family 'ipv6'
- option target 'ACCEPT'
- option src 'wan'
- config rule
- option name 'Allow-IPSec-ESP'
- option proto 'esp'
- option target 'ACCEPT'
- option dest 'lan'
- option src 'wan'
- config rule
- option name 'Allow-ISAKMP'
- option dest_port '500'
- option proto 'udp'
- option target 'ACCEPT'
- option dest 'lan'
- option src 'wan'
- config rule
- option name 'Support-UDP-Traceroute'
- option dest_port '33434:33689'
- option proto 'udp'
- option family 'ipv4'
- option target 'REJECT'
- option enabled '0'
- option src 'wan'
- config include
- option path '/etc/firewall.user'
- config rule # EDITORS NOTE: honestly dont know why this is here; disabled, so ignore ig
- option name 'Allow SSH'
- option src_port '22'
- option dest_port '22'
- option target 'ACCEPT'
- option src 'lan'
- option dest 'lan'
- option enabled '0'
- config zone
- option output 'ACCEPT'
- option name 'servers'
- option log '1'
- option forward 'ACCEPT'
- option input 'REJECT'
- list network 'SERVER'
- config zone
- option output 'ACCEPT'
- option name 'guest'
- option input 'REJECT'
- list network 'GUEST'
- option forward 'ACCEPT'
- config zone
- option input 'ACCEPT'
- option output 'ACCEPT'
- option forward 'REJECT'
- option name 'iot'
- list network 'IOT'
- config forwarding
- option src 'lan'
- option dest 'iot'
- config forwarding
- option src 'lan'
- option dest 'servers'
- config forwarding
- option src 'guest'
- option dest 'wan'
- config forwarding
- option src 'servers'
- option dest 'wan'
- config rule
- option name 'Guest Allow DHCP and DNS'
- option src 'guest'
- option dest_port '53 67 68'
- option target 'ACCEPT'
- config rule
- option name 'Servers Allow DHCP'
- list proto 'udp'
- option src 'servers'
- option target 'ACCEPT'
- option dest_port '67 68'
- config redirect
- option target 'DNAT'
- option name 'Test'
- option src 'wan'
- option src_dport '8000'
- option dest_ip '10.1.1.5'
- option dest_port '8000'
- option dest 'servers' # EDITORS NOTE: Forward works when this line is set to 'lan'
- # This file is interpreted as shell script.
- # Put your custom iptables rules here, they will
- # be executed with each firewall (re-)start.
- # Internal uci firewall chains are flushed and recreated on reload, so
- # put custom rules into the root chains e.g. INPUT or FORWARD or into the
- # special user chains, e.g. input_wan_rule or postrouting_lan_rule.
- # Generated by iptables-save v1.8.7 on Mon Apr 4 13:37:48 2022
- *nat
- :PREROUTING ACCEPT [8835:1383157]
- :INPUT ACCEPT [480:64768]
- :OUTPUT ACCEPT [1959:139160]
- :POSTROUTING ACCEPT [1888:118614]
- :postrouting_guest_rule - [0:0]
- :postrouting_iot_rule - [0:0]
- :postrouting_lan_rule - [0:0]
- :postrouting_rule - [0:0]
- :postrouting_servers_rule - [0:0]
- :postrouting_wan_rule - [0:0]
- :prerouting_guest_rule - [0:0]
- :prerouting_iot_rule - [0:0]
- :prerouting_lan_rule - [0:0]
- :prerouting_rule - [0:0]
- :prerouting_servers_rule - [0:0]
- :prerouting_wan_rule - [0:0]
- :zone_guest_postrouting - [0:0]
- :zone_guest_prerouting - [0:0]
- :zone_iot_postrouting - [0:0]
- :zone_iot_prerouting - [0:0]
- :zone_lan_postrouting - [0:0]
- :zone_lan_prerouting - [0:0]
- :zone_servers_postrouting - [0:0]
- :zone_servers_prerouting - [0:0]
- :zone_wan_postrouting - [0:0]
- :zone_wan_prerouting - [0:0]
- [8835:1383157] -A PREROUTING -m comment --comment "!fw3: Custom prerouting rule chain" -j prerouting_rule
- [7294:1268406] -A PREROUTING -i br-lan.100 -m comment --comment "!fw3" -j zone_lan_prerouting
- [620:31841] -A PREROUTING -i wan -m comment --comment "!fw3" -j zone_wan_prerouting
- [921:82910] -A PREROUTING -i br-lan.200 -m comment --comment "!fw3" -j zone_servers_prerouting
- [0:0] -A PREROUTING -i br-lan.3 -m comment --comment "!fw3" -j zone_guest_prerouting
- [0:0] -A PREROUTING -i br-lan.4 -m comment --comment "!fw3" -j zone_iot_prerouting
- [6893:793114] -A POSTROUTING -m comment --comment "!fw3: Custom postrouting rule chain" -j postrouting_rule
- [2:757] -A POSTROUTING -o br-lan.100 -m comment --comment "!fw3" -j zone_lan_postrouting
- [5005:674500] -A POSTROUTING -o wan -m comment --comment "!fw3" -j zone_wan_postrouting
- [1883:117657] -A POSTROUTING -o br-lan.200 -m comment --comment "!fw3" -j zone_servers_postrouting
- [0:0] -A POSTROUTING -o br-lan.3 -m comment --comment "!fw3" -j zone_guest_postrouting
- [0:0] -A POSTROUTING -o br-lan.4 -m comment --comment "!fw3" -j zone_iot_postrouting
- [0:0] -A zone_guest_postrouting -m comment --comment "!fw3: Custom guest postrouting rule chain" -j postrouting_guest_rule
- [0:0] -A zone_guest_prerouting -m comment --comment "!fw3: Custom guest prerouting rule chain" -j prerouting_guest_rule
- [0:0] -A zone_iot_postrouting -m comment --comment "!fw3: Custom iot postrouting rule chain" -j postrouting_iot_rule
- [0:0] -A zone_iot_prerouting -m comment --comment "!fw3: Custom iot prerouting rule chain" -j prerouting_iot_rule
- [2:757] -A zone_lan_postrouting -m comment --comment "!fw3: Custom lan postrouting rule chain" -j postrouting_lan_rule
- [7294:1268406] -A zone_lan_prerouting -m comment --comment "!fw3: Custom lan prerouting rule chain" -j prerouting_lan_rule
- [1883:117657] -A zone_servers_postrouting -m comment --comment "!fw3: Custom servers postrouting rule chain" -j postrouting_servers_rule
- [0:0] -A zone_servers_postrouting -s 10.1.1.0/24 -d 10.1.1.5/32 -p tcp -m tcp --dport 8000 -m comment --comment "!fw3: Test (reflection)" -j SNAT --to-source 10.1.1.1
- [0:0] -A zone_servers_postrouting -s 10.1.1.0/24 -d 10.1.1.5/32 -p udp -m udp --dport 8000 -m comment --comment "!fw3: Test (reflection)" -j SNAT --to-source 10.1.1.1
- [921:82910] -A zone_servers_prerouting -m comment --comment "!fw3: Custom servers prerouting rule chain" -j prerouting_servers_rule
- [0:0] -A zone_servers_prerouting -s 10.1.1.0/24 -d [Redacted WAN IP]/32 -p tcp -m tcp --dport 8000 -m comment --comment "!fw3: Test (reflection)" -j DNAT --to-destination 10.1.1.5:8000
- [0:0] -A zone_servers_prerouting -s 10.1.1.0/24 -d [Redacted WAN IP]/32 -p udp -m udp --dport 8000 -m comment --comment "!fw3: Test (reflection)" -j DNAT --to-destination 10.1.1.5:8000
- [5005:674500] -A zone_wan_postrouting -m comment --comment "!fw3: Custom wan postrouting rule chain" -j postrouting_wan_rule
- [5005:674500] -A zone_wan_postrouting -m comment --comment "!fw3" -j MASQUERADE
- [620:31841] -A zone_wan_prerouting -m comment --comment "!fw3: Custom wan prerouting rule chain" -j prerouting_wan_rule
- [0:0] -A zone_wan_prerouting -p tcp -m tcp --dport 8000 -m comment --comment "!fw3: Test" -j DNAT --to-destination 10.1.1.5:8000
- [0:0] -A zone_wan_prerouting -p udp -m udp --dport 8000 -m comment --comment "!fw3: Test" -j DNAT --to-destination 10.1.1.5:8000
- COMMIT
- # Completed on Mon Apr 4 13:37:48 2022
- # Generated by iptables-save v1.8.7 on Mon Apr 4 13:37:48 2022
- *raw
- :PREROUTING ACCEPT [1786326:1882064727]
- :OUTPUT ACCEPT [5462:609475]
- :zone_guest_helper - [0:0]
- :zone_iot_helper - [0:0]
- :zone_lan_helper - [0:0]
- :zone_servers_helper - [0:0]
- [400373:49636235] -A PREROUTING -i br-lan.100 -m comment --comment "!fw3: lan CT helper assignment" -j zone_lan_helper
- [7976:995534] -A PREROUTING -i br-lan.200 -m comment --comment "!fw3: servers CT helper assignment" -j zone_servers_helper
- [0:0] -A PREROUTING -i br-lan.3 -m comment --comment "!fw3: guest CT helper assignment" -j zone_guest_helper
- [0:0] -A PREROUTING -i br-lan.4 -m comment --comment "!fw3: iot CT helper assignment" -j zone_iot_helper
- COMMIT
- # Completed on Mon Apr 4 13:37:48 2022
- # Generated by iptables-save v1.8.7 on Mon Apr 4 13:37:48 2022
- *mangle
- :PREROUTING ACCEPT [1786328:1882064819]
- :INPUT ACCEPT [4984:658861]
- :FORWARD ACCEPT [1778171:1880777067]
- :OUTPUT ACCEPT [5471:611035]
- :POSTROUTING ACCEPT [1783500:1881364282]
- [1521:85916] -A FORWARD -o wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
- [1458:81148] -A FORWARD -i wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
- COMMIT
- # Completed on Mon Apr 4 13:37:48 2022
- # Generated by iptables-save v1.8.7 on Mon Apr 4 13:37:48 2022
- *filter
- :INPUT ACCEPT [0:0]
- :FORWARD DROP [0:0]
- :OUTPUT ACCEPT [0:0]
- :banIP - [0:0]
- :forwarding_guest_rule - [0:0]
- :forwarding_iot_rule - [0:0]
- :forwarding_lan_rule - [0:0]
- :forwarding_rule - [0:0]
- :forwarding_servers_rule - [0:0]
- :forwarding_wan_rule - [0:0]
- :input_guest_rule - [0:0]
- :input_iot_rule - [0:0]
- :input_lan_rule - [0:0]
- :input_rule - [0:0]
- :input_servers_rule - [0:0]
- :input_wan_rule - [0:0]
- :output_guest_rule - [0:0]
- :output_iot_rule - [0:0]
- :output_lan_rule - [0:0]
- :output_rule - [0:0]
- :output_servers_rule - [0:0]
- :output_wan_rule - [0:0]
- :reject - [0:0]
- :syn_flood - [0:0]
- :zone_guest_dest_ACCEPT - [0:0]
- :zone_guest_forward - [0:0]
- :zone_guest_input - [0:0]
- :zone_guest_output - [0:0]
- :zone_guest_src_REJECT - [0:0]
- :zone_iot_dest_ACCEPT - [0:0]
- :zone_iot_dest_REJECT - [0:0]
- :zone_iot_forward - [0:0]
- :zone_iot_input - [0:0]
- :zone_iot_output - [0:0]
- :zone_iot_src_ACCEPT - [0:0]
- :zone_lan_dest_ACCEPT - [0:0]
- :zone_lan_forward - [0:0]
- :zone_lan_input - [0:0]
- :zone_lan_output - [0:0]
- :zone_lan_src_ACCEPT - [0:0]
- :zone_servers_dest_ACCEPT - [0:0]
- :zone_servers_forward - [0:0]
- :zone_servers_input - [0:0]
- :zone_servers_output - [0:0]
- :zone_servers_src_REJECT - [0:0]
- :zone_wan_dest_ACCEPT - [0:0]
- :zone_wan_dest_REJECT - [0:0]
- :zone_wan_forward - [0:0]
- :zone_wan_input - [0:0]
- :zone_wan_output - [0:0]
- :zone_wan_src_REJECT - [0:0]
- [58:4850] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
- [4928:654115] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
- [3178:508198] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
- [472:19228] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
- [680:91947] -A INPUT -i br-lan.100 -m comment --comment "!fw3" -j zone_lan_input
- [1013:47681] -A INPUT -i wan -m comment --comment "!fw3" -j zone_wan_input
- [57:6289] -A INPUT -i br-lan.200 -m comment --comment "!fw3" -j zone_servers_input
- [0:0] -A INPUT -i br-lan.3 -m comment --comment "!fw3" -j zone_guest_input
- [0:0] -A INPUT -i br-lan.4 -m comment --comment "!fw3" -j zone_iot_input
- [1778171:1880777067] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
- [1772402:1879907394] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
- [4535:753102] -A FORWARD -i br-lan.100 -m comment --comment "!fw3" -j zone_lan_forward
- [0:0] -A FORWARD -i wan -m comment --comment "!fw3" -j zone_wan_forward
- [1234:116571] -A FORWARD -i br-lan.200 -m comment --comment "!fw3" -j zone_servers_forward
- [0:0] -A FORWARD -i br-lan.3 -m comment --comment "!fw3" -j zone_guest_forward
- [0:0] -A FORWARD -i br-lan.4 -m comment --comment "!fw3" -j zone_iot_forward
- [0:0] -A FORWARD -m comment --comment "!fw3" -j reject
- [58:4850] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
- [5422:607585] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
- [2363:390840] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
- [3:1138] -A OUTPUT -o br-lan.100 -m comment --comment "!fw3" -j zone_lan_output
- [1718:121799] -A OUTPUT -o wan -m comment --comment "!fw3" -j zone_wan_output
- [1338:93808] -A OUTPUT -o br-lan.200 -m comment --comment "!fw3" -j zone_servers_output
- [0:0] -A OUTPUT -o br-lan.3 -m comment --comment "!fw3" -j zone_guest_output
- [0:0] -A OUTPUT -o br-lan.4 -m comment --comment "!fw3" -j zone_iot_output
- [41:13826] -A banIP -p udp -m udp --sport 67:68 --dport 67:68 -j RETURN
- [5821:247233] -A banIP -m conntrack ! --ctstate NEW -j RETURN
- [0:0] -A banIP -i wan -m set --match-set whitelist_4 src -j RETURN
- [0:0] -A banIP -o wan -m set --match-set whitelist_4 dst -j RETURN
- [17:792] -A banIP -i wan -m set --match-set darklist_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set darklist_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set edrop_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set edrop_4 dst -j REJECT --reject-with icmp-port-unreachable
- [563:23538] -A banIP -i wan -m set --match-set dshield_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set dshield_4 dst -j REJECT --reject-with icmp-port-unreachable
- [8:325] -A banIP -i wan -m set --match-set drop_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set drop_4 dst -j REJECT --reject-with icmp-port-unreachable
- [49:2200] -A banIP -i wan -m set --match-set debl_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set debl_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set feodo_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set feodo_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set firehol1_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set firehol1_4 dst -j REJECT --reject-with icmp-port-unreachable
- [2:96] -A banIP -i wan -m set --match-set iblockspy_4 src -j DROP
- [2:128] -A banIP -o wan -m set --match-set iblockspy_4 dst -j REJECT --reject-with icmp-port-unreachable
- [22:886] -A banIP -i wan -m set --match-set greensnow_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set greensnow_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set sslbl_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set sslbl_4 dst -j REJECT --reject-with icmp-port-unreachable
- [36:1785] -A banIP -i wan -m set --match-set threat_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set threat_4 dst -j REJECT --reject-with icmp-port-unreachable
- [1:52] -A banIP -i wan -m set --match-set talos_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set talos_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set tor_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set tor_4 dst -j REJECT --reject-with icmp-port-unreachable
- [0:0] -A banIP -i wan -m set --match-set yoyo_4 src -j DROP
- [1333:305013] -A banIP -o wan -m set --match-set yoyo_4 dst -j REJECT --reject-with icmp-port-unreachable
- [85:12325] -A banIP -i wan -m set --match-set voip_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set voip_4 dst -j REJECT --reject-with icmp-port-unreachable
- [110:4571] -A banIP -i wan -m set --match-set uceprotect1_4 src -j DROP
- [0:0] -A banIP -o wan -m set --match-set uceprotect1_4 dst -j REJECT --reject-with icmp-port-unreachable
- [38439:7087227] -A forwarding_lan_rule -j banIP
- [0:0] -A forwarding_wan_rule -j banIP
- [5116:755551] -A input_lan_rule -j banIP
- [12430:595172] -A input_wan_rule -j banIP
- [810:35128] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
- [80:7913] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp-port-unreachable
- [472:19228] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
- [0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
- [0:0] -A zone_guest_dest_ACCEPT -o br-lan.3 -m comment --comment "!fw3" -j ACCEPT
- [0:0] -A zone_guest_forward -m comment --comment "!fw3: Custom guest forwarding rule chain" -j forwarding_guest_rule
- [0:0] -A zone_guest_forward -m comment --comment "!fw3: Zone guest to wan forwarding policy" -j zone_wan_dest_ACCEPT
- [0:0] -A zone_guest_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
- [0:0] -A zone_guest_forward -m comment --comment "!fw3" -j zone_guest_dest_ACCEPT
- [0:0] -A zone_guest_input -m comment --comment "!fw3: Custom guest input rule chain" -j input_guest_rule
- [0:0] -A zone_guest_input -p tcp -m tcp --dport 53 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -p tcp -m tcp --dport 67 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -p tcp -m tcp --dport 68 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -p udp -m udp --dport 53 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -p udp -m udp --dport 67 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Guest Allow DHCP and DNS" -j ACCEPT
- [0:0] -A zone_guest_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
- [0:0] -A zone_guest_input -m comment --comment "!fw3" -j zone_guest_src_REJECT
- [0:0] -A zone_guest_output -m comment --comment "!fw3: Custom guest output rule chain" -j output_guest_rule
- [0:0] -A zone_guest_output -m comment --comment "!fw3" -j zone_guest_dest_ACCEPT
- [0:0] -A zone_guest_src_REJECT -i br-lan.3 -m comment --comment "!fw3" -j reject
- [0:0] -A zone_iot_dest_ACCEPT -o br-lan.4 -m comment --comment "!fw3" -j ACCEPT
- [0:0] -A zone_iot_dest_REJECT -o br-lan.4 -m comment --comment "!fw3" -j reject
- [0:0] -A zone_iot_forward -m comment --comment "!fw3: Custom iot forwarding rule chain" -j forwarding_iot_rule
- [0:0] -A zone_iot_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
- [0:0] -A zone_iot_forward -m comment --comment "!fw3" -j zone_iot_dest_REJECT
- [0:0] -A zone_iot_input -m comment --comment "!fw3: Custom iot input rule chain" -j input_iot_rule
- [0:0] -A zone_iot_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
- [0:0] -A zone_iot_input -m comment --comment "!fw3" -j zone_iot_src_ACCEPT
- [0:0] -A zone_iot_output -m comment --comment "!fw3: Custom iot output rule chain" -j output_iot_rule
- [0:0] -A zone_iot_output -m comment --comment "!fw3" -j zone_iot_dest_ACCEPT
- [0:0] -A zone_iot_src_ACCEPT -i br-lan.4 -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
- [3:1138] -A zone_lan_dest_ACCEPT -o br-lan.100 -m comment --comment "!fw3" -j ACCEPT
- [4535:753102] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
- [4449:732074] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
- [970:53173] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to iot forwarding policy" -j zone_iot_dest_ACCEPT
- [970:53173] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to servers forwarding policy" -j zone_servers_dest_ACCEPT
- [0:0] -A zone_lan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
- [0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
- [680:91947] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
- [0:0] -A zone_lan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
- [680:91947] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
- [3:1138] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
- [3:1138] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
- [680:91947] -A zone_lan_src_ACCEPT -i br-lan.100 -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
- [2308:146981] -A zone_servers_dest_ACCEPT -o br-lan.200 -m comment --comment "!fw3" -j ACCEPT
- [1234:116571] -A zone_servers_forward -m comment --comment "!fw3: Custom servers forwarding rule chain" -j forwarding_servers_rule
- [1234:116571] -A zone_servers_forward -m comment --comment "!fw3: Zone servers to wan forwarding policy" -j zone_wan_dest_ACCEPT
- [0:0] -A zone_servers_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
- [0:0] -A zone_servers_forward -m comment --comment "!fw3" -j zone_servers_dest_ACCEPT
- [57:6289] -A zone_servers_input -m comment --comment "!fw3: Custom servers input rule chain" -j input_servers_rule
- [0:0] -A zone_servers_input -p udp -m udp --dport 67 -m comment --comment "!fw3: Servers Allow DHCP" -j ACCEPT
- [0:0] -A zone_servers_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Servers Allow DHCP" -j ACCEPT
- [0:0] -A zone_servers_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
- [57:6289] -A zone_servers_input -m comment --comment "!fw3" -j zone_servers_src_REJECT
- [1338:93808] -A zone_servers_output -m comment --comment "!fw3: Custom servers output rule chain" -j output_servers_rule
- [1338:93808] -A zone_servers_output -m comment --comment "!fw3" -j zone_servers_dest_ACCEPT
- [57:6289] -A zone_servers_src_REJECT -i br-lan.200 -m limit --limit 10/sec -m comment --comment "!fw3" -j LOG --log-prefix "REJECT servers in: "
- [57:6289] -A zone_servers_src_REJECT -i br-lan.200 -m comment --comment "!fw3" -j reject
- [56:2792] -A zone_wan_dest_ACCEPT -o wan -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
- [6375:914479] -A zone_wan_dest_ACCEPT -o wan -m comment --comment "!fw3" -j ACCEPT
- [0:0] -A zone_wan_dest_REJECT -o wan -m comment --comment "!fw3" -j reject
- [0:0] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
- [0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
- [0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
- [0:0] -A zone_wan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
- [0:0] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
- [1013:47681] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
- [0:0] -A zone_wan_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Allow-DHCP-Renew" -j ACCEPT
- [98:6934] -A zone_wan_input -p icmp -m icmp --icmp-type 8 -m comment --comment "!fw3: Allow-Ping" -j ACCEPT
- [0:0] -A zone_wan_input -p igmp -m comment --comment "!fw3: Allow-IGMP" -j ACCEPT
- [0:0] -A zone_wan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
- [833:36752] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
- [1718:121799] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
- [1718:121799] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
- [833:36752] -A zone_wan_src_REJECT -i wan -m comment --comment "!fw3" -j reject
- COMMIT
- # Completed on Mon Apr 4 13:37:48 2022
- 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
- inet 127.0.0.1/8 scope host lo
- valid_lft forever preferred_lft forever
- 7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
- inet [Redacted WAN IP]/26 brd [Redacted] scope global wan
- valid_lft forever preferred_lft forever
- 16: br-lan.100@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
- inet 10.0.0.1/24 brd 10.0.0.255 scope global br-lan.100
- valid_lft forever preferred_lft forever
- 17: br-lan.200@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
- inet 10.1.1.1/24 brd 10.1.1.255 scope global br-lan.200
- valid_lft forever preferred_lft forever
- 18: br-lan.3@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
- inet 10.0.1.1/24 brd 10.0.1.255 scope global br-lan.3
- valid_lft forever preferred_lft forever
- 19: br-lan.4@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
- inet 10.0.2.0/24 brd 10.0.2.255 scope global br-lan.4
- valid_lft forever preferred_lft forever
- default via [Redacted Gateway] dev wan proto static
- 10.0.0.0/24 dev br-lan.100 proto kernel scope link src 10.0.0.1
- 10.0.1.0/24 dev br-lan.3 proto kernel scope link src 10.0.1.1
- 10.0.2.0/24 dev br-lan.4 proto kernel scope link src 10.0.2.0
- 10.1.1.0/24 dev br-lan.200 proto kernel scope link src 10.1.1.1
- [Redacted CIDR] dev wan proto kernel scope link src [Redacted WAN IP]
- broadcast 10.0.0.0 dev br-lan.100 table local proto kernel scope link src 10.0.0.1
- local 10.0.0.1 dev br-lan.100 table local proto kernel scope host src 10.0.0.1
- broadcast 10.0.0.255 dev br-lan.100 table local proto kernel scope link src 10.0.0.1
- broadcast 10.0.1.0 dev br-lan.3 table local proto kernel scope link src 10.0.1.1
- local 10.0.1.1 dev br-lan.3 table local proto kernel scope host src 10.0.1.1
- broadcast 10.0.1.255 dev br-lan.3 table local proto kernel scope link src 10.0.1.1
- local 10.0.2.0 dev br-lan.4 table local proto kernel scope host src 10.0.2.0
- broadcast 10.0.2.0 dev br-lan.4 table local proto kernel scope link src 10.0.2.0
- broadcast 10.0.2.255 dev br-lan.4 table local proto kernel scope link src 10.0.2.0
- broadcast 10.1.1.0 dev br-lan.200 table local proto kernel scope link src 10.1.1.1
- local 10.1.1.1 dev br-lan.200 table local proto kernel scope host src 10.1.1.1
- broadcast 10.1.1.255 dev br-lan.200 table local proto kernel scope link src 10.1.1.1
- broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
- local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
- local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
- broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
- broadcast [Redacted] dev wan table local proto kernel scope link src [Redacted WAN IP]
- local [Redacted WAN IP] dev wan table local proto kernel scope host src [Redacted WAN IP]
- broadcast [Redacted] dev wan table local proto kernel scope link src [Redacted WAN IP]
- 0: from all lookup local
- 32766: from all lookup main
- 32767: from all lookup default
Advertisement
Add Comment
Please, Sign In to add comment
Advertisement