daily pastebin goal
49%
SHARE
TWEET

4_23

a guest Sep 9th, 2018 142 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "4_23"
  2.       declare n, i, p:inteiro;
  3.       escreva("Informe um número inteiro: ");
  4.       leia(n);
  5.       i <- 1;
  6.       p <- 0;
  7.       se (n == 1) entao
  8.            escreval("primo.");
  9.       senao
  10.            enquanto (i <= n) faca
  11.                     se (resto(n, i) == 0) entao
  12.                        p <- p + 1;
  13.                     fimse
  14.                     i <- i + 1;
  15.            fimenquanto
  16.            se (p == 2) entao
  17.               escreval("Primo. ");
  18.            senao
  19.                 escreval("Não primo. ");
  20.            fimse
  21.       fimse
  22. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top