estevaorada

Calculadora REPITA Portugo

Sep 17th, 2021
815
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "Calculadora"
  2.  
  3. var
  4. opcao: caractere
  5. n1, n2: real
  6. inicio
  7. repita
  8.    escreval("***********************")
  9.    escreval("1 - Soma")
  10.    escreval("2 - Subtração")
  11.    escreval("3 - Multiplicação")
  12.    escreval("4 - Divisão")
  13.    escreval("5 - Exponenciação")
  14.    escreval("6 - SAIR")
  15.    escreva("Escolha uma opção: ")
  16.    leia(opcao)
  17.    // Executar apenas se a pessoa NÃO escolher 6:
  18.    se opcao<>"6" entao
  19.       // Ler os números n1 e n2:
  20.       escreva("Digite o primeiro valor: ")
  21.       leia(n1)
  22.       escreva("Digite o segundo valor: ")
  23.       leia(n2)
  24.    fimse
  25.    // Limpar a tela:
  26.    limpatela
  27.    // Verificar qual opção a pessoa escolheu:
  28.    escolha opcao
  29.     caso "1"
  30.          escreva(n1+n2)
  31.     caso "2"
  32.          escreva(n1-n2)
  33.     caso "3"
  34.          escreva(n1*n2)
  35.     caso "4"
  36.          se n2=0 entao
  37.             escreva("Não é possível dividir por zero!")
  38.          senao
  39.             escreva(n1/n2)
  40.          fimse
  41.     caso "5"
  42.          escreva(n1^n2)
  43.     caso "6"
  44.          escreva("CALCULADORA ENCERRADA!")
  45.     // Caso a pessoa não escolha uma opção valida:
  46.     outrocaso
  47.          escreva("Opção inválida!")
  48.    fimescolha
  49.    // Pular uma linha no final
  50.    escreval("")
  51.  
  52. ate opcao="6"
  53.  
  54. fimalgoritmo
RAW Paste Data