daily pastebin goal
34%
SHARE
TWEET

4_21

a guest Sep 9th, 2018 148 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "4_21"
  2.  
  3.       declare n, i, t, aux:inteiro;
  4.       escreva("Informe um número inteiro: ");
  5.       leia(n);
  6.       aux <- n;
  7.       i <- 1;
  8.       t <- 0;
  9.       enquanto (i <= n) faca
  10.                se ((resto(n, i) == 0) E (i != aux)) entao
  11.                   escreval(i);
  12.                   t <- t + i;
  13.                fimse
  14.                i <- i + 1;
  15.       fimenquanto
  16.       se (t == n) entao
  17.          escreval("Número perfeito. ");
  18.       senao
  19.            escreval("Número não perfeito. ");
  20.       fimse
  21. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top