Advertisement
Guest User

taichi CUDA on Windows problem

a guest
Mar 4th, 2020
166
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. CONSOLE OUTPUT:
  2. [Taichi] mode=release
  3. Share object taichi_core import failed. If you are on Windows, please consider installing "Microsoft Visual C++ Redistributable" (https://aka.ms/vs/16/release/vc_redist.x64.exe)
  4. Traceback (most recent call last):
  5. File "C:\code\taichi\examples\renderer.py", line 1, in <module>
  6. import taichi as ti
  7. File "C:\Program Files\Python37\lib\site-packages\taichi\__init__.py", line 1, in <module>
  8. from taichi.main import main
  9. File "C:\Program Files\Python37\lib\site-packages\taichi\main.py", line 6, in <module>
  10. from taichi.tools.video import make_video, interpolate_frames, mp4_to_gif, scale_video, crop_video, accelerate_video
  11. File "C:\Program Files\Python37\lib\site-packages\taichi\tools\video.py", line 3, in <module>
  12. import taichi.core as core
  13. File "C:\Program Files\Python37\lib\site-packages\taichi\core\__init__.py", line 1, in <module>
  14. from .util import tc_core, build, format, load_module, start_memory_monitoring, \
  15. File "C:\Program Files\Python37\lib\site-packages\taichi\core\util.py", line 176, in <module>
  16. import_tc_core()
  17. File "C:\Program Files\Python37\lib\site-packages\taichi\core\util.py", line 35, in import_tc_core
  18. raise e
  19. File "C:\Program Files\Python37\lib\site-packages\taichi\core\util.py", line 31, in import_tc_core
  20. import taichi_core as core
  21. ImportError: DLL load failed: The specified module could not be found.
  22.  
  23. PACKAGES:
  24. Requirement already satisfied: taichi-nightly-cuda-10-1 in c:\program files\python37\lib\site-packages (0.5.6)
  25. Requirement already satisfied: numpy in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (1.18.1)
  26. Requirement already satisfied: setuptools in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (41.2.0)
  27. Requirement already satisfied: pybind11 in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (2.4.3)
  28. Requirement already satisfied: astor in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (0.8.1)
  29. Requirement already satisfied: colorama in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (0.4.3)
  30. Requirement already satisfied: pytest in c:\program files\python37\lib\site-packages (from taichi-nightly-cuda-10-1) (5.3.5)
  31. Requirement already satisfied: wcwidth in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (0.1.8)
  32. Requirement already satisfied: pluggy<1.0,>=0.12 in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (0.13.1)
  33. Requirement already satisfied: importlib-metadata>=0.12; python_version < "3.8" in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (1.5.0)
  34. Requirement already satisfied: more-itertools>=4.0.0 in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (8.2.0)
  35. Requirement already satisfied: packaging in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (20.1)
  36. Requirement already satisfied: atomicwrites>=1.0; sys_platform == "win32" in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (1.3.0)
  37. Requirement already satisfied: py>=1.5.0 in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (1.8.1)
  38. Requirement already satisfied: attrs>=17.4.0 in c:\program files\python37\lib\site-packages (from pytest->taichi-nightly-cuda-10-1) (19.3.0)
  39. Requirement already satisfied: zipp>=0.5 in c:\program files\python37\lib\site-packages (from importlib-metadata>=0.12; python_version < "3.8"->pytest->taichi-nightly-cuda-10-1) (3.1.0)
  40. Requirement already satisfied: six in c:\program files\python37\lib\site-packages (from packaging->pytest->taichi-nightly-cuda-10-1) (1.14.0)
  41. Requirement already satisfied: pyparsing>=2.0.2 in c:\program files\python37\lib\site-packages (from packaging->pytest->taichi-nightly-cuda-10-1) (2.4.6)
Advertisement
RAW Paste Data Copied
Advertisement