G2A Many GEOs
SHARE
TWEET

CalculoMelhorAluno

michellipaiao Apr 7th, 2020 196 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Algoritmo "CalculoMelhorAluno"
  2. // Disciplina  :  [Linguagem e Lógica de Programação]
  3. // Professor   : Antonio Carlos Nicolodi
  4. // Descrição   : Aqui você descreve o que o programa faz! (função)
  5. // Autor(a)    : Nome do(a) aluno(a)
  6. // Data atual  : 07/04/2020
  7. Var
  8. // Seção de Declarações das variáveis
  9.       quantidade: Inteiro
  10.       nome: Caractere
  11.       nota: Real
  12.       maiorNota: Real
  13.       aluno: Inteiro
  14.       alunoMaiorNota: Caractere
  15.  
  16. Inicio
  17. // Seção de Comandos, procedimento, funções, operadores, etc...
  18.    escreval("--------------------------------------")
  19.    escreval("     Escola  Santa Paciencia          ")
  20.    escreval("--------------------------------------")
  21.  
  22.    escreva("Quantos alunos a turma tem? ")
  23.    leia(quantidade)
  24.    escreval("-----------------------------")
  25.  
  26.    aluno <- 1
  27.    enquanto(aluno <= quantidade ) faca
  28.      escreval("ALUNO ", aluno )
  29.      escreva("Nome do aluno: ")
  30.      leia(nome)
  31.  
  32.      escreva("Nota de ", nome, ": " )
  33.      leia(nota)
  34.      escreval("------------------------------")
  35.      se (nota > maiorNota) entao
  36.        alunoMaiorNota <- nome
  37.        maiorNota <- nota
  38.      fimse
  39.  
  40.      aluno <- aluno + 1
  41.    fimenquanto
  42.  
  43.    escreva("O melhor aproveitamento foi " , alunoMaiorNota , " com a nota", maiorNota)
  44.  
  45.  
  46.  
  47. Fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Top