SHARE
TWEET

Untitled

a guest May 7th, 2020 30 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. serv0 ~ # emerge --oneshot sys-apps/portage
  2. Calculating dependencies... done!
  3. [ebuild     U  ] dev-python/setuptools-44.1.0 [44.0.0] PYTHON_TARGETS="python3_7* -python3_6*"
  4. [ebuild   R    ] dev-python/certifi-2019.11.28  PYTHON_TARGETS="python3_7* -python3_6*"
  5. [ebuild   R    ] app-portage/gemato-14.3  PYTHON_TARGETS="python3_7* -python3_6*"
  6. [ebuild     U  ] sys-apps/portage-2.3.99-r2 [2.3.89-r3] PYTHON_TARGETS="python3_7* -python3_6*"
  7.  
  8. !!! Multiple package instances within a single package slot have been pulled
  9. !!! into the dependency graph, resulting in a slot conflict:
  10.  
  11. dev-python/setuptools:0
  12.  
  13.   (dev-python/setuptools-44.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
  14.     dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/certifi-2019.11.28:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)"
  15.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  16.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/certifi-2019.11.28:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)"
  17.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            
  18.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)"
  19.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  20.  
  21.   (dev-python/setuptools-44.0.0:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
  22.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gemato-14.3:0/0::gentoo, installed) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"
  23.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  24.     >=dev-python/setuptools-42.0.2[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-util/meson-0.52.1:0/0::gentoo, installed) USE="(-test)" PYTHON_TARGETS="python3_6 -python3_7"
  25.                                                                                                                                                                                                                                                                                                                                                                                                                            
  26.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/certifi-2019.11.28:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"
  27.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            
  28.     dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/certifi-2019.11.28:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"
  29.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
  30.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/mako-1.1.1:0/0::gentoo, installed) USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"
  31.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  32.     dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/file-5.37-r1:0/0::gentoo, installed) USE="python zlib -static-libs" PYTHON_TARGETS="python2_7 python3_6 -python3_7 (-python3_8)"
  33.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
  34.     >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7"
  35.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
  36.     dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7"
  37.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              
  38.  
  39. dev-python/certifi:0
  40.  
  41.   (dev-python/certifi-2019.11.28:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
  42.     >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/setuptools-44.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)"
  43.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  44.  
  45.   (dev-python/certifi-2019.11.28:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
  46.     >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/setuptools-44.0.0:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)"
  47.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
  48.  
  49. sys-apps/portage:0
  50.  
  51.   (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
  52.     sys-apps/portage (Argument)
  53.  
  54.   (sys-apps/portage-2.3.89-r3:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
  55.     sys-apps/portage[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gentoolkit-0.4.8:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python3_6 (-pypy3) -python3_7 (-python3_8)"
  56.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                
  57.     sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_6 -python3_7"
  58.                                                                                                                                                                                                                                                                                                                                                    
  59.  
  60. app-portage/gemato:0
  61.  
  62.   (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8)" pulled in by
  63.     >=app-portage/gemato-14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8)"
  64.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
  65.  
  66.   (app-portage/gemato-14.3:0/0::gentoo, installed) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 (-python3_8)" pulled in by
  67.     >=app-portage/gemato-14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.89-r3:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" PYTHON_TARGETS="python3_6 (-pypy3) -python3_7 (-python3_8)"
  68.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
  69.  
  70.  
  71. It may be possible to solve this problem by using package.mask to
  72. prevent one of those packages from being selected. However, it is also
  73. possible that conflicting dependencies exist such that they are
  74. impossible to satisfy simultaneously.  If such a conflict exists in
  75. the dependencies of two different packages, then those packages can
  76. not be installed simultaneously. You may want to try a larger value of
  77. the --backtrack option, such as --backtrack=30, in order to see if
  78. that will solve this conflict automatically.
  79.  
  80. For more information, see MASKED PACKAGES section in the emerge man
  81. page or refer to the Gentoo Handbook.
  82.  
  83.  
  84. !!! The following installed packages are masked:
  85. - x11-drivers/xf86-input-mouse-1.9.3::gentoo (masked by: package.mask)
  86. /usr/portage/profiles/package.mask:
  87. # Piotr Karbowski <slashbeast@gentoo.org> (2020-05-03)
  88. # Obsolete input drivers, use x11-drivers/xf86-input-libinput
  89. # or x11-drivers/xf86-input-evdev instead.
  90. # Removal in 30 days.
  91.  
  92. For more information, see the MASKED PACKAGES section in the emerge
  93. man page or refer to the Gentoo Handbook.
  94.  
  95. serv0 ~ #
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Top