SHARE
TWEET

Untitled

a guest Oct 17th, 2019 91 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Installing build runtime...
  2. Build runtime installed: 1013.354ms
  3. Looking up build cache...
  4. Build cache found [16.67 MB, 16781 files]
  5. Build cache unpacked: 901.220ms
  6. Installing dependencies...
  7. npm
  8.  WARN deprecated core-js@1.2.7: core-js@<2.6.8 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
  9.  
  10. > sharp@0.23.1 install /zeit/484cebdd/node_modules/sharp
  11. > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
  12.  
  13. info
  14.  
  15. sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz
  16.  
  17. > gatsby-telemetry@1.1.33 postinstall /zeit/484cebdd/node_modules/gatsby-telemetry
  18. > node src/postinstall.js
  19.  
  20.  
  21. > cwebp-bin@5.1.0 postinstall /zeit/484cebdd/node_modules/cwebp-bin
  22. > node lib/install.js
  23.  
  24.   ⚠ Command failed: /zeit/484cebdd/node_modules/cwebp-bin/vendor/cwebp -version
  25. /zeit/484cebdd/node_modules/cwebp-bin/vendor/cwebp: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
  26.  
  27.  
  28.   ⚠ cwebp pre-build test failed
  29.   ℹ compiling from source
  30.   ✔ cwebp built successfully
  31.  
  32. > mozjpeg@6.0.1 postinstall /zeit/484cebdd/node_modules/mozjpeg
  33. > node lib/install.js
  34.  
  35.   ✔ mozjpeg pre-build test passed successfully
  36.  
  37.  
  38. > pngquant-bin@5.0.2 postinstall /zeit/484cebdd/node_modules/pngquant-bin
  39. > node lib/install.js
  40.  
  41.   ✔ pngquant pre-build test passed successfully
  42.  
  43.  
  44. > gatsby-cli@2.8.2 postinstall /zeit/484cebdd/node_modules/gatsby/node_modules/gatsby-cli
  45. > node scripts/postinstall.js
  46.  
  47.  
  48. > gatsby@2.16.4 postinstall /zeit/484cebdd/node_modules/gatsby
  49. > node scripts/postinstall.js
  50.  
  51. npm WARN @pieh/friendly-errors-webpack-plugin@1.7.0-chalk-2 requires a peer of webpack@^2.0.0 || ^3.0.0 || ^4.0.0 but none is installed. You must install peer dependencies yourself.
  52. npm WARN @typescript-eslint/eslint-plugin@2.4.0 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
  53. npm WARN @typescript-eslint/parser@2.4.0 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
  54. npm WARN eslint-plugin-react-hooks@1.7.0 requires a peer of eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
  55. npm WARN mini-css-extract-plugin@0.8.0 requires a peer of webpack@^4.4.0 but none is installed. You must install peer dependencies yourself.
  56. npm WARN
  57.  optimize-css-assets-webpack-plugin@5.0.3 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.
  58. npm WARN terser-webpack-plugin@1.4.1 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.
  59. npm WARN @typescript-eslint/experimental-utils@2.4.0 requires a peer of eslint@* but none is installed. You must install peer dependencies yourself.
  60. npm WARN tsutils@3.17.1 requires a peer of typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself.
  61. npm WARN ts-pnp@1.1.4 requires a peer of typescript@* but none is installed. You must install peer dependencies yourself.
  62. npm
  63.  WARN sass-loader@7.3.1 requires a peer of webpack@^3.0.0 || ^4.0.0 but none is installed. You must install peer dependencies yourself.
  64. npm
  65.  WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/gatsby/node_modules/webpack-dev-server/node_modules/fsevents):
  66. npm WARN notsup
  67.  SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  68. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/gatsby/node_modules/watchpack/node_modules/fsevents):
  69. npm WARN
  70. notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  71. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/gatsby/node_modules/fsevents):
  72. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  73. npm WARN
  74. optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/gatsby-source-filesystem/node_modules/fsevents):
  75. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  76. npm WARN
  77.  optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/gatsby-page-utils/node_modules/fsevents):
  78. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  79. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/babel-plugin-add-module-exports/node_modules/fsevents):
  80. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  81. npm WARN
  82.  optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/@typescript-eslint/typescript-estree/node_modules/fsevents):
  83. npm
  84.  WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
  85.  
  86. added 1859 packages from 804 contributors, removed 427 packages, moved 42 packages and audited 25206 packages in 69.637s
  87. found 2 vulnerabilities (1 moderate, 1 high)
  88.   run `npm audit fix` to fix them, or `npm audit` for details
  89. Running "npm run build"
  90.  
  91. > gatsby-starter-default@0.1.0 build /zeit/484cebdd
  92. > gatsby build
  93.  
  94. ╔════════════════════════════════════════════════════════════════════════╗
  95. ║                                                                        ║
  96. ║   Gatsby collects anonymous usage analytics                            ║
  97. ║   to help improve Gatsby for all users.                                ║
  98. ║                                                                        ║
  99. ║   If you'd like to opt-out, you can use `gatsby telemetry --disable`   ║
  100. ║   To learn more, checkout https://gatsby.dev/telemetry                 ║
  101. ║                                                                        ║
  102. ╚════════════════════════════════════════════════════════════════════════╝
  103.  
  104.  ERROR
  105.  
  106. gatsby build
  107.  
  108. Build a Gatsby project.
  109.  
  110. Options:
  111.   --verbose                   Turn on verbose output  [boolean] [default: false]
  112.   --no-color, --no-colors     Turn off the color in output  [boolean] [default: false]
  113.   --prefix-paths              Build site with link paths prefixed (set pathPrefix in your gatsby-config.js).  [boolean] [default: false]
  114.   --no-uglify                 Build site without uglifying JS bundles (for debugging).  [boolean] [default: false]
  115.   --open-tracing-config-file  Tracer configuration file (OpenTracing compatible). See https://gatsby.dev/tracing  [string]
  116.   -h, --help                  Show help  [boolean]
  117.   -v, --version               Show the version of the Gatsby CLI and the Gatsby package in the current project  [boolean]
  118.  
  119.  
  120.  ERROR
  121.  
  122. There was a problem loading the local build command. Gatsby may not be installed. Perhaps you need to run "npm install"? Cannot find module 'webpack/lib/RequestShortener'
  123.  
  124.  
  125. 
  126.   Error: Cannot find module 'webpack/lib/RequestShortener'
  127.   
  128.   - loader.js:636 Function.Module._resolveFilename
  129.     internal/modules/cjs/loader.js:636:15
  130.   
  131.   - loader.js:562 Function.Module._load
  132.     internal/modules/cjs/loader.js:562:25
  133.   
  134.   - loader.js:690 Module.require
  135.     internal/modules/cjs/loader.js:690:17
  136.   
  137.   - v8-compile-cache.js:159 require
  138.     [484cebdd]/[v8-compile-cache]/v8-compile-cache.js:159:20
  139.   
  140.   - index.js:16 Object.<anonymous>
  141.     [484cebdd]/[terser-webpack-plugin]/dist/index.js:16:48
  142.   
  143.   - v8-compile-cache.js:178 Module._compile
  144.     [484cebdd]/[v8-compile-cache]/v8-compile-cache.js:178:30
  145.   
  146.   - loader.js:787 Object.Module._extensions..js
  147.     internal/modules/cjs/loader.js:787:10
  148.   
  149.   - loader.js:653 Module.load
  150.     internal/modules/cjs/loader.js:653:32
  151.   
  152.   - loader.js:593 tryModuleLoad
  153.     internal/modules/cjs/loader.js:593:12
  154.   
  155.   - loader.js:585 Function.Module._load
  156.     internal/modules/cjs/loader.js:585:3
  157.   
  158.   - loader.js:690 Module.require
  159.     internal/modules/cjs/loader.js:690:17
  160.   
  161.   - v8-compile-cache.js:159 require
  162.     [484cebdd]/[v8-compile-cache]/v8-compile-cache.js:159:20
  163.   
  164.   - cjs.js:3 Object.<anonymous>
  165.     [484cebdd]/[terser-webpack-plugin]/dist/cjs.js:3:16
  166.   
  167.   - v8-compile-cache.js:178 Module._compile
  168.     [484cebdd]/[v8-compile-cache]/v8-compile-cache.js:178:30
  169.   
  170.   - loader.js:787 Object.Module._extensions..js
  171.     internal/modules/cjs/loader.js:787:10
  172.   
  173.   - loader.js:653 Module.load
  174.     internal/modules/cjs/loader.js:653:32
  175.   
  176. 
  177. npm
  178.  ERR! code ELIFECYCLE
  179. npm
  180.  ERR! errno 1
  181. npm
  182.  ERR! gatsby-starter-default@0.1.0 build: `gatsby build`
  183. npm ERR! Exit status 1
  184. npm ERR!
  185. npm ERR! Failed at the gatsby-starter-default@0.1.0 build script.
  186. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
  187.  
  188. npm ERR! A complete log of this run can be found in:
  189. npm ERR!     /zeit/.npm/_logs/2019-10-18T02_33_42_627Z-debug.log
  190. Error: Exited with 1
  191.     at ChildProcess.child.on (/zeit/40f9385d99dd2d94/.build-utils/.builder/node_modules/@now/static-build/dist/index.js:23548:24)
  192.     at emitTwo (events.js:126:13)
  193.     at ChildProcess.emit (events.js:214:7)
  194.     at maybeClose (internal/child_process.js:925:16)
  195.     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
  196. worker exited with code 20 and signal null
  197. done
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top