SHARE
TWEET

Untitled

a guest Feb 16th, 2020 99 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1.  
  2.  
  3. -----> Ruby app detected
  4.  
  5. -----> Compiling Ruby/Rails
  6.  
  7. ###### WARNING:
  8.  
  9.        This buildpack was created as a stop-gap measure to allow running applications with Bundler 2 on Heroku.
  10.  
  11.        Heroku now supports Bundler 2 directly: https://devcenter.heroku.com/changelog-items/1563
  12.  
  13.        
  14.  
  15.        Please discontinue use of this buildpack and instead directly use the `heroku/ruby` buildpack.
  16.  
  17.        
  18.  
  19.        To remove this buildpack use the `heroku buildpacks` command to list your existing buildpacks.
  20.  
  21.        
  22.  
  23.        If you only have one buildpack listed you can run:
  24.  
  25.        
  26.  
  27.        ```
  28.  
  29.        heroku buildpacks:set heroku/ruby
  30.  
  31.        ```
  32.  
  33.        
  34.  
  35.        If you have multiple buildpacks, you'll need to add the buildpack to the correct location using
  36.  
  37.        `heroku buildpacks:add heroku/ruby -i <correct index>` and then remove this buildpack via:
  38.  
  39.        
  40.  
  41.        ```
  42.  
  43.        heroku buildpacks:remove https://github.com/bundler/heroku-buildpack-bundler2
  44.  
  45.        ```
  46.  
  47. -----> Using Ruby version: ruby-2.6.5
  48.  
  49. -----> Installing dependencies using bundler 2.0.1
  50.  
  51.        Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
  52.  
  53.        The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
  54.  
  55.        Fetching gem metadata from https://rubygems.org/............
  56.  
  57.        Fetching rake 13.0.1
  58.  
  59.        Installing rake 13.0.1
  60.  
  61.        Fetching concurrent-ruby 1.1.6
  62.  
  63.        Fetching minitest 5.14.0
  64.  
  65.        Fetching thread_safe 0.3.6
  66.  
  67.        Installing minitest 5.14.0
  68.  
  69.        Installing thread_safe 0.3.6
  70.  
  71.        Installing concurrent-ruby 1.1.6
  72.  
  73.        Fetching builder 3.2.4
  74.  
  75.        Installing builder 3.2.4
  76.  
  77.        Fetching erubi 1.9.0
  78.  
  79.        Fetching mini_portile2 2.4.0
  80.  
  81.        Installing erubi 1.9.0
  82.  
  83.        Installing mini_portile2 2.4.0
  84.  
  85.        Fetching crass 1.0.6
  86.  
  87.        Installing crass 1.0.6
  88.  
  89.        Fetching rack 2.2.2
  90.  
  91.        Installing rack 2.2.2
  92.  
  93.        Fetching nio4r 2.5.2
  94.  
  95.        Installing nio4r 2.5.2 with native extensions
  96.  
  97.        Fetching websocket-extensions 0.1.4
  98.  
  99.        Installing websocket-extensions 0.1.4
  100.  
  101.        Fetching mini_mime 1.0.2
  102.  
  103.        Fetching arel 9.0.0
  104.  
  105.        Installing mini_mime 1.0.2
  106.  
  107.        Installing arel 9.0.0
  108.  
  109.        Fetching mimemagic 0.3.4
  110.  
  111.        Installing mimemagic 0.3.4
  112.  
  113.        Fetching msgpack 1.3.3
  114.  
  115.        Installing msgpack 1.3.3 with native extensions
  116.  
  117.        Using bundler 1.17.2
  118.  
  119.        Fetching coffee-script-source 1.12.2
  120.  
  121.        Installing coffee-script-source 1.12.2
  122.  
  123.        Fetching execjs 2.7.0
  124.  
  125.        Installing execjs 2.7.0
  126.  
  127.        Fetching method_source 0.9.2
  128.  
  129.        Installing method_source 0.9.2
  130.  
  131.        Fetching thor 1.0.1
  132.  
  133.        Installing thor 1.0.1
  134.  
  135.        Fetching ffi 1.12.2
  136.  
  137.        Installing ffi 1.12.2 with native extensions
  138.  
  139.        Fetching pg 1.2.2
  140.  
  141.        Installing pg 1.2.2 with native extensions
  142.  
  143.        Fetching puma 3.12.2
  144.  
  145.        Installing puma 3.12.2 with native extensions
  146.  
  147.        Fetching rb-fsevent 0.10.3
  148.  
  149.        Installing rb-fsevent 0.10.3
  150.  
  151.        Fetching tilt 2.0.10
  152.  
  153.        Installing tilt 2.0.10
  154.  
  155.        Fetching turbolinks-source 5.2.0
  156.  
  157.        Installing turbolinks-source 5.2.0
  158.  
  159.        Fetching tzinfo 1.2.6
  160.  
  161.        Installing tzinfo 1.2.6
  162.  
  163.        Fetching nokogiri 1.10.8
  164.  
  165.        Installing nokogiri 1.10.8 with native extensions
  166.  
  167.        Fetching i18n 1.8.2
  168.  
  169.        Installing i18n 1.8.2
  170.  
  171.        Fetching rack-test 1.1.0
  172.  
  173.        Installing rack-test 1.1.0
  174.  
  175.        Fetching sprockets 3.7.2
  176.  
  177.        Installing sprockets 3.7.2
  178.  
  179.        Fetching websocket-driver 0.7.1
  180.  
  181.        Installing websocket-driver 0.7.1 with native extensions
  182.  
  183.        Fetching mail 2.7.1
  184.  
  185.        Installing mail 2.7.1
  186.  
  187.        Fetching marcel 0.3.3
  188.  
  189.        Installing marcel 0.3.3
  190.  
  191.        Fetching coffee-script 2.4.1
  192.  
  193.        Installing coffee-script 2.4.1
  194.  
  195.        Fetching uglifier 4.2.0
  196.  
  197.        Installing uglifier 4.2.0
  198.  
  199.        Fetching bootsnap 1.4.5
  200.  
  201.        Installing bootsnap 1.4.5 with native extensions
  202.  
  203.        Fetching rb-inotify 0.10.1
  204.  
  205.        Installing rb-inotify 0.10.1
  206.  
  207.        Fetching turbolinks 5.2.1
  208.  
  209.        Installing turbolinks 5.2.1
  210.  
  211.        Fetching activesupport 5.2.4.1
  212.  
  213.        Installing activesupport 5.2.4.1
  214.  
  215.        Fetching loofah 2.4.0
  216.  
  217.        Installing loofah 2.4.0
  218.  
  219.        Fetching sass-listen 4.0.0
  220.  
  221.        Fetching rails-html-sanitizer 1.3.0
  222.  
  223.        Installing sass-listen 4.0.0
  224.  
  225.        Installing rails-html-sanitizer 1.3.0
  226.  
  227.        Fetching rails-dom-testing 2.0.3
  228.  
  229.        Installing rails-dom-testing 2.0.3
  230.  
  231.        Fetching globalid 0.4.2
  232.  
  233.        Installing globalid 0.4.2
  234.  
  235.        Fetching activemodel 5.2.4.1
  236.  
  237.        Fetching jbuilder 2.10.0
  238.  
  239.        Installing activemodel 5.2.4.1
  240.  
  241.        Installing jbuilder 2.10.0
  242.  
  243.        Fetching sass 3.7.4
  244.  
  245.        Installing sass 3.7.4
  246.  
  247.        Fetching actionview 5.2.4.1
  248.  
  249.        Installing actionview 5.2.4.1
  250.  
  251.        Fetching activejob 5.2.4.1
  252.  
  253.        Installing activejob 5.2.4.1
  254.  
  255.        Fetching activerecord 5.2.4.1
  256.  
  257.        Installing activerecord 5.2.4.1
  258.  
  259.        Fetching actionpack 5.2.4.1
  260.  
  261.        Installing actionpack 5.2.4.1
  262.  
  263.        Fetching actionmailer 5.2.4.1
  264.  
  265.        Fetching actioncable 5.2.4.1
  266.  
  267.        Installing actionmailer 5.2.4.1
  268.  
  269.        Installing actioncable 5.2.4.1
  270.  
  271.        Fetching sprockets-rails 3.2.1
  272.  
  273.        Fetching railties 5.2.4.1
  274.  
  275.        Installing sprockets-rails 3.2.1
  276.  
  277.        Installing railties 5.2.4.1
  278.  
  279.        Fetching activestorage 5.2.4.1
  280.  
  281.        Installing activestorage 5.2.4.1
  282.  
  283.        Fetching coffee-rails 4.2.2
  284.  
  285.        Fetching rails 5.2.4.1
  286.  
  287.        Fetching sass-rails 5.1.0
  288.  
  289.        Installing coffee-rails 4.2.2
  290.  
  291.        Installing sass-rails 5.1.0
  292.  
  293.        Installing rails 5.2.4.1
  294.  
  295.        Bundle complete! 19 Gemfile dependencies, 60 gems now installed.
  296.  
  297.        Gems in the groups development and test were not installed.
  298.  
  299.        Bundled gems are installed into `./vendor/bundle`
  300.  
  301.        Post-install message from i18n:
  302.  
  303.        
  304.  
  305.        HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
  306.  
  307.        But that may break your application.
  308.  
  309.        
  310.  
  311.        If you are upgrading your Rails application from an older version of Rails:
  312.  
  313.        
  314.  
  315.        Please check your Rails app for 'config.i18n.fallbacks = true'.
  316.  
  317.        If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
  318.  
  319.        'config.i18n.fallbacks = [I18n.default_locale]'.
  320.  
  321.        If not, fallbacks will be broken in your app by I18n 1.1.x.
  322.  
  323.        
  324.  
  325.        If you are starting a NEW Rails application, you can ignore this notice.
  326.  
  327.        
  328.  
  329.        For more info see:
  330.  
  331.        https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
  332.  
  333.        
  334.  
  335.        Post-install message from sass:
  336.  
  337.        
  338.  
  339.        Ruby Sass has reached end-of-life and should no longer be used.
  340.  
  341.        
  342.  
  343.        * If you use Sass as a command-line tool, we recommend using Dart Sass, the new
  344.  
  345.          primary implementation: https://sass-lang.com/install
  346.  
  347.        
  348.  
  349.        * If you use Sass as a plug-in for a Ruby web framework, we recommend using the
  350.  
  351.          sassc gem: https://github.com/sass/sassc-ruby#readme
  352.  
  353.        
  354.  
  355.        * For more details, please refer to the Sass blog:
  356.  
  357.          https://sass-lang.com/blog/posts/7828841
  358.  
  359.        
  360.  
  361.        Removing bundler (2.0.1)
  362.  
  363.        Bundle completed (45.22s)
  364.  
  365.        Cleaning up the bundler cache.
  366.  
  367.        The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
  368.  
  369. -----> Installing node-v8.10.0-linux-x64
  370.  
  371. -----> Detecting rake tasks
  372.  
  373. -----> Preparing app for Rails asset pipeline
  374.  
  375.        Running: rake assets:precompile
  376.  
  377.        rake aborted!
  378.  
  379.        ArgumentError: Missing :controller key on routes definition, please check your routes.
  380.  
  381.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:329:in `check_part'
  382.  
  383.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:309:in `check_controller_and_action'
  384.  
  385.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:254:in `normalize_options!'
  386.  
  387.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:118:in `initialize'
  388.  
  389.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:71:in `new'
  390.  
  391.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:71:in `build'
  392.  
  393.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1932:in `add_route'
  394.  
  395.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1904:in `decomposed_match'
  396.  
  397.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1868:in `block in map_match'
  398.  
  399.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1862:in `each'
  400.  
  401.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1862:in `map_match'
  402.  
  403.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1610:in `match'
  404.  
  405.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1940:in `match_root_route'
  406.  
  407.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/mapper.rb:1643:in `root'
  408.  
  409.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/config/routes.rb:2:in `block in <main>'
  410.  
  411.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/route_set.rb:432:in `instance_exec'
  412.  
  413.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/route_set.rb:432:in `eval_block'
  414.  
  415.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/actionpack-5.2.4.1/lib/action_dispatch/routing/route_set.rb:414:in `draw'
  416.  
  417.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/config/routes.rb:1:in `<main>'
  418.  
  419.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:54:in `load'
  420.  
  421.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:54:in `load'
  422.  
  423.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:285:in `block in load'
  424.  
  425.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:257:in `load_dependency'
  426.  
  427.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:285:in `load'
  428.  
  429.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:41:in `block in load_paths'
  430.  
  431.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:41:in `each'
  432.  
  433.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:41:in `load_paths'
  434.  
  435.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:20:in `reload!'
  436.  
  437.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:30:in `block in updater'
  438.  
  439.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/file_update_checker.rb:83:in `execute'
  440.  
  441.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/routes_reloader.rb:10:in `execute'
  442.  
  443.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application/finisher.rb:130:in `block in <module:Finisher>'
  444.  
  445.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:32:in `instance_exec'
  446.  
  447.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:32:in `run'
  448.  
  449.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:61:in `block in run_initializers'
  450.  
  451.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:60:in `run_initializers'
  452.  
  453.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:361:in `initialize!'
  454.  
  455.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/config/environment.rb:5:in `<main>'
  456.  
  457.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
  458.  
  459.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
  460.  
  461.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
  462.  
  463.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
  464.  
  465.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
  466.  
  467.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `block in require'
  468.  
  469.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:257:in `load_dependency'
  470.  
  471.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `require'
  472.  
  473.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:337:in `require_environment!'
  474.  
  475.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:520:in `block in run_tasks_blocks'
  476.  
  477.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:62:in `block (2 levels) in define'
  478.  
  479.        /tmp/build_335e970cf23ff13840cc32e04a5e0d50/vendor/bundle/ruby/2.6.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
  480.  
  481.        Tasks: TOP => environment
  482.  
  483.        (See full trace by running task with --trace)
  484.  
  485.  !
  486.  
  487.  !     Precompiling assets failed.
  488.  
  489.  !
  490.  
  491.  !     Push rejected, failed to compile Ruby app.
  492.  
  493.  !     Push failed
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Top