This week only. Pastebin PRO Accounts Christmas Special! Don't miss out!Want more features on Pastebin? Sign Up, it's FREE!
Guest

Spring Roo1.2RC1 crash with openjdk7-macppc-fcs-fd-atomic

By: a guest on Dec 11th, 2011  |  syntax: Bash  |  size: 66.52 KB  |  views: 64  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. JAVA_HOME /usr/local/java-1.7.0
  2. ERROR: Bundle org.springframework.roo.addon.backup [9] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.backup-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [9]: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  3. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [9]: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  4.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  5.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  6.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  7.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  8.         at java.lang.Thread.run(Thread.java:655)
  9. ERROR: Bundle org.springframework.roo.addon.configurable [10] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.configurable-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [10]: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  10. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [10]: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  11.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  12.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  13.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  14.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  15.         at java.lang.Thread.run(Thread.java:655)
  16. ERROR: Bundle org.springframework.roo.addon.creator [11] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.creator-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [11]: Unable to resolve 11.0: missing requirement [11.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)])
  17. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [11]: Unable to resolve 11.0: missing requirement [11.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]
  18.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  19.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  20.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  21.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  22.         at java.lang.Thread.run(Thread.java:655)
  23. ERROR: Bundle org.springframework.roo.addon.dbre [12] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.dbre-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [12]: Unable to resolve 12.0: missing requirement [12.0] package; (&(package=org.springframework.roo.addon.jpa.identifier)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  24. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [12]: Unable to resolve 12.0: missing requirement [12.0] package; (&(package=org.springframework.roo.addon.jpa.identifier)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  25.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  26.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  27.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  28.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  29.         at java.lang.Thread.run(Thread.java:655)
  30. ERROR: Bundle org.springframework.roo.addon.dod [13] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.dod-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [13]: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  31. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [13]: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  32.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  33.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  34.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  35.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  36.         at java.lang.Thread.run(Thread.java:655)
  37. ERROR: Bundle org.springframework.roo.addon.email [14] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.email-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [14]: Unable to resolve 14.0: missing requirement [14.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  38. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [14]: Unable to resolve 14.0: missing requirement [14.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  39.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  40.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  41.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  42.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  43.         at java.lang.Thread.run(Thread.java:655)
  44. ERROR: Bundle org.springframework.roo.addon.equals [15] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.equals-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [15]: Unable to resolve 15.0: missing requirement [15.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  45. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [15]: Unable to resolve 15.0: missing requirement [15.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  46.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  47.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  48.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  49.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  50.         at java.lang.Thread.run(Thread.java:655)
  51. ERROR: Bundle org.springframework.roo.addon.finder [16] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.finder-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [16]: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  52. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [16]: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  53.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  54.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  55.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  56.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  57.         at java.lang.Thread.run(Thread.java:655)
  58. ERROR: Bundle org.springframework.roo.addon.gwt [17] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.gwt-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [17]: Unable to resolve 17.0: missing requirement [17.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  59. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [17]: Unable to resolve 17.0: missing requirement [17.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  60.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  61.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  62.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  63.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  64.         at java.lang.Thread.run(Thread.java:655)
  65. ERROR: Bundle org.springframework.roo.addon.javabean [18] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.javabean-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  66. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  67.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  68.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  69.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  70.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  71.         at java.lang.Thread.run(Thread.java:655)
  72. ERROR: Bundle org.springframework.roo.addon.jms [20] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.jms-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  73. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  74.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  75.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  76.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  77.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  78.         at java.lang.Thread.run(Thread.java:655)
  79. ERROR: Bundle org.springframework.roo.addon.jpa [21] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.jpa-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [21]: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  80. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [21]: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  81.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  82.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  83.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  84.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  85.         at java.lang.Thread.run(Thread.java:655)
  86. ERROR: Bundle org.springframework.roo.addon.jsf [22] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.jsf-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  87. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  88.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  89.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  90.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  91.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  92.         at java.lang.Thread.run(Thread.java:655)
  93. ERROR: Bundle org.springframework.roo.addon.json [23] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.json-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  94. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  95.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  96.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  97.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  98.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  99.         at java.lang.Thread.run(Thread.java:655)
  100. ERROR: Bundle org.springframework.roo.addon.layers.repository.jpa [24] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.layers.repository.jpa-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  101. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  102.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  103.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  104.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  105.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  106.         at java.lang.Thread.run(Thread.java:655)
  107. ERROR: Bundle org.springframework.roo.addon.layers.repository.mongo [25] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.layers.repository.mongo-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  108. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  109.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  110.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  111.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  112.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  113.         at java.lang.Thread.run(Thread.java:655)
  114. ERROR: Bundle org.springframework.roo.addon.layers.service [26] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.layers.service-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [26]: Unable to resolve 26.0: missing requirement [26.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  115. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [26]: Unable to resolve 26.0: missing requirement [26.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  116.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  117.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  118.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  119.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  120.         at java.lang.Thread.run(Thread.java:655)
  121. ERROR: Bundle org.springframework.roo.addon.logging [27] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.logging-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)])
  122. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]
  123.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  124.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  125.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  126.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  127.         at java.lang.Thread.run(Thread.java:655)
  128. ERROR: Bundle org.springframework.roo.addon.oscommands [28] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.oscommands-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  129. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  130.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  131.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  132.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  133.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  134.         at java.lang.Thread.run(Thread.java:655)
  135. ERROR: Bundle org.springframework.roo.addon.plural [29] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.plural-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  136. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  137.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  138.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  139.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  140.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  141.         at java.lang.Thread.run(Thread.java:655)
  142. ERROR: Bundle org.springframework.roo.addon.property.editor [30] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.property.editor-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  143. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  144.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  145.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  146.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  147.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  148.         at java.lang.Thread.run(Thread.java:655)
  149. ERROR: Bundle org.springframework.roo.addon.propfiles [31] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.propfiles-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  150. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  151.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  152.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  153.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  154.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  155.         at java.lang.Thread.run(Thread.java:655)
  156. ERROR: Bundle org.springframework.roo.addon.roobot.client [32] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.roobot.client-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.classpath.preferences)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  157. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.classpath.preferences)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  158.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  159.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  160.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  161.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  162.         at java.lang.Thread.run(Thread.java:655)
  163. ERROR: Bundle org.springframework.roo.addon.security [33] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.security-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  164. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  165.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  166.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  167.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  168.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  169.         at java.lang.Thread.run(Thread.java:655)
  170. ERROR: Bundle org.springframework.roo.addon.serializable [34] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.serializable-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  171. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  172.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  173.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  174.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  175.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  176.         at java.lang.Thread.run(Thread.java:655)
  177. ERROR: Bundle org.springframework.roo.addon.solr [35] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.solr-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [35]: Unable to resolve 35.0: missing requirement [35.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  178. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [35]: Unable to resolve 35.0: missing requirement [35.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  179.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  180.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  181.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  182.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  183.         at java.lang.Thread.run(Thread.java:655)
  184. ERROR: Bundle org.springframework.roo.addon.test [36] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.test-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  185. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  186.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  187.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  188.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  189.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  190.         at java.lang.Thread.run(Thread.java:655)
  191. ERROR: Bundle org.springframework.roo.addon.tostring [37] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.tostring-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  192. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  193.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  194.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  195.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  196.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  197.         at java.lang.Thread.run(Thread.java:655)
  198. ERROR: Bundle org.springframework.roo.addon.web.flow [38] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.web.flow-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]]])
  199. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]]]
  200.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  201.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  202.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  203.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  204.         at java.lang.Thread.run(Thread.java:655)
  205. ERROR: Bundle org.springframework.roo.addon.web.mvc.controller [39] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.web.mvc.controller-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]])
  206. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]]
  207.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  208.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  209.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  210.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  211.         at java.lang.Thread.run(Thread.java:655)
  212. ERROR: Bundle org.springframework.roo.addon.web.mvc.embedded [40] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.web.mvc.embedded-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]])
  213. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]
  214.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  215.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  216.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  217.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  218.         at java.lang.Thread.run(Thread.java:655)
  219. ERROR: Bundle org.springframework.roo.addon.web.mvc.jsp [41] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.web.mvc.jsp-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [41]: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]])
  220. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [41]: Unable to resolve 41.0: missing requirement [41.0] package; (&(package=org.springframework.roo.addon.backup)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=org.springframework.roo.project)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]
  221.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  222.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  223.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  224.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  225.         at java.lang.Thread.run(Thread.java:655)
  226. ERROR: Bundle org.springframework.roo.addon.web.selenium [42] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.addon.web.selenium-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]]])
  227. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]]]]]
  228.                 at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  229.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  230.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  231.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  232.         at java.lang.Thread.run(Thread.java:655)
  233. ERROR: Bundle org.springframework.roo.classpath [43] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.classpath-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)])
  234. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]
  235.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  236.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  237.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  238.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  239.         at java.lang.Thread.run(Thread.java:655)
  240. ERROR: Bundle org.springframework.roo.classpath.javaparser [44] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.classpath.javaparser-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [44]: Unable to resolve 44.0: missing requirement [44.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]])
  241. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [44]: Unable to resolve 44.0: missing requirement [44.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]]
  242.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  243.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  244.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  245.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  246.         at java.lang.Thread.run(Thread.java:655)
  247. ERROR: Bundle org.springframework.roo.model [51] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.model-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation))
  248. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)
  249.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  250.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  251.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  252.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  253.         at java.lang.Thread.run(Thread.java:655)                                                  
  254. 2011-dec-11 19:15:11 org.springframework.roo.felix.JdkDelegatingLogListener logNow
  255. ALLVARLIG: [org.springframework.roo.model [51]] FrameworkEvent ERROR  Downloaded 100% of favorites.json
  256. org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)                                                       Downloaded 100% of favorites.json
  257.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3Downloaded 100% of favorites.json
  258.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  259.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  260.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  261.         at java.lang.Thread.run(Thread.java:655)
  262. ERROR: Bundle org.springframework.roo.project [53] Error starting file:/Applications/springsource/spring-roo-1.2.0.RC1/bundle/org.springframework.roo.project-1.2.0.RC1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)])
  263. org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]
  264.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  265.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  266.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  267.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  268.         at java.lang.Thread.run(Thread.java:655)
  269. 2011-dec-11 19:15:11 org.springframework.roo.felix.JdkDelegatingLogListener logNow
  270. ALLVARLIG: [org.springframework.roo.project [53]] FrameworkEvent ERROR
  271. org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.annotation)]
  272.         at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
  273.         at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
  274.         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  275.         at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  276.         at java.lang.Thread.run(Thread.java:655)
  277.  
  278.  
clone this paste RAW Paste Data