Want more features on Pastebin? Sign Up, it's FREE!
Guest

pylab GTK problem

By: a guest on Oct 10th, 2012  |  syntax: Python  |  size: 3.41 KB  |  views: 46  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. (py27)tom@zeppelin:~$ pylab
  2. Python 2.7.1+ (r271:86832, Sep 27 2012, 21:12:17)
  3. Type "copyright", "credits" or "license" for more information.
  4.  
  5. IPython 0.12 -- An enhanced Interactive Python.
  6. ?         -> Introduction and overview of IPython's features.
  7. %quickref -> Quick reference.
  8. help      -> Python's own help system.
  9. object?   -> Details about 'object', use 'object??' for extra details.
  10. [TerminalIPythonApp] Error in enabling GUI event loop integration:
  11. ---------------------------------------------------------------------------
  12. ImportError                               Traceback (most recent call last)
  13. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/IPython/core/interactiveshell.pyc in enable_pylab(self, gui, import_all)
  14.    2605         ns = {}
  15.    2606         try:
  16. -> 2607             gui = pylab_activate(ns, gui, import_all, self)
  17.    2608         except KeyError:
  18.    2609             error("Backend %r not supported" % gui)
  19.  
  20. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/IPython/core/pylabtools.pyc in pylab_activate(user_ns, gui, import_all, shell)
  21.     328     """
  22.    329     gui, backend = find_gui_and_backend(gui)
  23. --> 330     activate_matplotlib(backend)
  24.    331     import_pylab(user_ns, import_all)
  25.    332     if shell is not None:
  26.  
  27. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/IPython/core/pylabtools.pyc in activate_matplotlib(backend)
  28.    221     # This must be imported last in the matplotlib series, after
  29.  
  30.    222     # backend/interactivity choices have been made
  31.  
  32. --> 223     import matplotlib.pylab as pylab
  33.    224
  34.    225     # XXX For now leave this commented out, but depending on discussions with
  35.  
  36.  
  37. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/matplotlib/pylab.py in <module>()
  38.    261 from numpy.linalg import *
  39.    262
  40. --> 263 from matplotlib.pyplot import *
  41.    264
  42.    265 # provide the recommended module abbrevs in the pylab namespace
  43.  
  44.  
  45. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/matplotlib/pyplot.py in <module>()
  46.     93
  47.     94 from matplotlib.backends import pylab_setup
  48. ---> 95 new_figure_manager, draw_if_interactive, show = pylab_setup()
  49.     96
  50.     97 @docstring.copy_dedent(Artist.findobj)
  51.  
  52. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/matplotlib/backends/__init__.pyc in pylab_setup()
  53.     23         backend_name = 'matplotlib.backends.%s'%backend_name.lower()
  54.     24     backend_mod = __import__(backend_name,
  55. ---> 25                              globals(),locals(),[backend_name])
  56.     26
  57.     27     # Things we pull in from all backends
  58.  
  59.  
  60. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/matplotlib/backends/backend_gtkagg.py in <module>()
  61.      8 from matplotlib.figure import Figure
  62.      9 from matplotlib.backends.backend_agg import FigureCanvasAgg
  63. ---> 10 from matplotlib.backends.backend_gtk import gtk, FigureManagerGTK, FigureCanvasGTK,\
  64.     11      show, draw_if_interactive,\
  65.     12      error_msg_gtk, NavigationToolbar, PIXELS_PER_INCH, backend_version, \
  66.  
  67. /home/tom/.virtualenvs/py27/local/lib/python2.7/site-packages/matplotlib/backends/backend_gtk.py in <module>()
  68.      9     import pango
  69.     10 except ImportError:
  70. ---> 11     raise ImportError("Gtk* backend requires pygtk to be installed.")
  71.     12
  72.     13 pygtk_version_required = (2,4,0)
  73.  
  74. ImportError: Gtk* backend requires pygtk to be installed.
  75.  
  76. In [1]:
clone this paste RAW Paste Data