Pastebin is 300% more awesome when you are logged in. Sign Up, it's FREE!
Guest

Untitled

By: a guest on Oct 22nd, 2010  |  syntax: None  |  size: 3.88 KB  |  hits: 74  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. Using rails (3.0.1)
  2. Using factory_girl_rails (1.0)
  3. Using haml (3.0.22)
  4. Using hashie (0.4.0)
  5. Using ruby_core_source (0.1.4)
  6. Installing linecache19 (0.5.11) with native extensions /usr/lib/ruby/1.9.1/rubygems/installer.rb:483:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
  7.  
  8. /usr/bin/ruby extconf.rb
  9. checking for vm_core.h... no
  10. checking for vm_core.h... no
  11. *** extconf.rb failed ***
  12. Could not create Makefile due to some reason, probably lack of
  13. necessary libraries and/or headers.  Check the mkmf.log file for more
  14. details.  You may need configuration options.
  15.  
  16. Provided configuration options:
  17.         --with-opt-dir
  18.         --without-opt-dir
  19.         --with-opt-include
  20.         --without-opt-include=${opt-dir}/include
  21.         --with-opt-lib
  22.         --without-opt-lib=${opt-dir}/lib
  23.         --with-make-prog
  24.         --without-make-prog
  25.         --srcdir=.
  26.         --curdir
  27.         --ruby=/usr/bin/ruby
  28.         --with-ruby-dir
  29.         --without-ruby-dir
  30.         --with-ruby-include
  31.         --without-ruby-include=${ruby-dir}/include
  32.         --with-ruby-lib
  33.         --without-ruby-lib=${ruby-dir}/lib
  34. /usr/lib/ruby/1.9.1/fileutils.rb:243:in `mkdir': Permission denied - /usr/include/ruby-1.9.1/ruby-1.9.2-p0 (Errno::EACCES)
  35.         from /usr/lib/ruby/1.9.1/fileutils.rb:243:in `fu_mkdir'
  36.         from /usr/lib/ruby/1.9.1/fileutils.rb:217:in `block (2 levels) in mkdir_p'
  37.         from /usr/lib/ruby/1.9.1/fileutils.rb:215:in `reverse_each'
  38.         from /usr/lib/ruby/1.9.1/fileutils.rb:215:in `block in mkdir_p'
  39.         from /usr/lib/ruby/1.9.1/fileutils.rb:201:in `each'
  40.         from /usr/lib/ruby/1.9.1/fileutils.rb:201:in `mkdir_p'
  41.         from /usr/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:59:in `block in create_makefile_with_core'
  42.         from /usr/lib/ruby/1.9.1/tempfile.rb:320:in `open'
  43.         from /usr/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:51:in `create_makefile_with_core'
  44.         from extconf.rb:20:in `<main>'
  45. Requesting http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p0.tar.gz
  46. Downloading http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p0.tar.gz
  47.  
  48.  
  49. Gem files will remain installed in /tmp/yaourt-tmp-asack/aur-diaspora-git/src/diaspora-gems/gems/linecache19-0.5.11 for inspection.
  50. Results logged to /tmp/yaourt-tmp-asack/aur-diaspora-git/src/diaspora-gems/gems/linecache19-0.5.11/ext/trace_nums/gem_make.out
  51.         from /usr/lib/ruby/1.9.1/rubygems/installer.rb:486:in `block in build_extensions'
  52.         from /usr/lib/ruby/1.9.1/rubygems/installer.rb:446:in `each'
  53.         from /usr/lib/ruby/1.9.1/rubygems/installer.rb:446:in `build_extensions'
  54.         from /usr/lib/ruby/1.9.1/rubygems/installer.rb:198:in `install'
  55.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/source.rb:100:in `install'
  56.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/installer.rb:55:in `block in run'
  57.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/spec_set.rb:12:in `block in each'
  58.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/spec_set.rb:12:in `each'
  59.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/spec_set.rb:12:in `each'
  60.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/installer.rb:44:in `run'
  61.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/installer.rb:8:in `install'
  62.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/cli.rb:217:in `install'
  63.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/vendor/thor/task.rb:22:in `run'
  64.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
  65.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/vendor/thor.rb:246:in `dispatch'
  66.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/lib/bundler/vendor/thor/base.rb:389:in `start'
  67.         from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.0.0/bin/bundle:13:in `<top (required)>'
  68.         from /usr/bin/bundle:19:in `load'
  69.         from /usr/bin/bundle:19:in `<main>'
  70.     Breche ab ...
  71. ==> ERROR: Makepkg was unable to build diaspora-git.