SHARE
TWEET

Rails LoadError: pg_ext, symbol not found: _environ

a guest Jul 25th, 2012 7 Never
  1.     [02:23:40] gotham-city:~/mySite rvm use jruby
  2.     Using /Users/Rege/.rvm/gems/jruby-1.6.7
  3.     [02:23:48] gotham-city:~/mySite rails server
  4.     LoadError: load error: pg_ext -- java.lang.UnsatisfiedLinkError: dlopen(/Users/Rege/.rvm/gems/jruby-1.6.7/gems/pg-0.13.2/lib/pg_ext.bundle, 9): Symbol not found: _environ
  5.       Referenced from: /Users/Rege/.rvm/rubies/ruby-1.9.2-p320/lib/libruby.1.9.1.dylib
  6.       Expected in: flat namespace
  7.      in /Users/Rege/.rvm/rubies/ruby-1.9.2-p320/lib/libruby.1.9.1.dylib
  8.       require at org/jruby/RubyKernel.java:1042
  9.        (root) at /Users/Rege/.rvm/gems/jruby-1.6.7/gems/pg-0.13.2/lib/pg.rb:4
  10.       require at org/jruby/RubyKernel.java:1042
  11.       require at /Users/Rege/.rvm/gems/jruby-1.6.7/gems/pg-0.13.2/lib/pg.rb:68
  12.          each at org/jruby/RubyArray.java:1615
  13.       require at /Users/Rege/.rvm/gems/jruby-1.6.7@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:66
  14.          each at org/jruby/RubyArray.java:1615
  15.       require at /Users/Rege/.rvm/gems/jruby-1.6.7@global/gems/bundler-1.1.3/lib/bundler/runtime.rb:55
  16.       require at /Users/Rege/.rvm/gems/jruby-1.6.7@global/gems/bundler-1.1.3/lib/bundler.rb:119
  17.        (root) at /Users/Rege/Sites/tweb/config/application.rb:7
  18.       require at org/jruby/RubyKernel.java:1042
  19.        (root) at /Users/Rege/Sites/tweb/config/application.rb:53
  20.           tap at org/jruby/RubyKernel.java:1787
  21.        (root) at /Users/Rege/.rvm/gems/jruby-1.6.7/gems/railties-3.2.1/lib/rails/commands.rb:50
  22.       require at org/jruby/RubyKernel.java:1042
  23.        (root) at script/rails:6
RAW Paste Data
Top