This week only. Pastebin PRO Accounts Christmas Special! Don't miss out!Want more features on Pastebin? Sign Up, it's FREE!
Guest

Untitled

By: a guest on Jan 30th, 2013  |  syntax: None  |  size: 11.22 KB  |  views: 80  |  expires: Never
download  |  raw  |  embed  |  report abuse  |  print
Text below is selected. Please press Ctrl+C to copy to your clipboard. (⌘+C on Mac)
  1. checking for Ruby version >= 1.8.5... -------------------- yes
  2.  
  3. --------------------
  4.  
  5. find_executable: checking for xcrun... -------------------- yes
  6.  
  7. --------------------
  8.  
  9. find_executable: checking for Magick-config... -------------------- yes
  10.  
  11. --------------------
  12.  
  13. checking for ImageMagick version >= 6.4.9... -------------------- yes
  14.  
  15. --------------------
  16.  
  17. checking for HDRI disabled version of ImageMagick... -------------------- yes
  18.  
  19. --------------------
  20.  
  21. have_header: checking for stdint.h... -------------------- yes
  22.  
  23. "xcrun cc -E -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    conftest.c -o conftest.i"
  24. checked program was:
  25. /* begin */
  26. 1: #include <stdint.h>
  27. /* end */
  28.  
  29. --------------------
  30.  
  31. have_header: checking for sys/types.h... -------------------- yes
  32.  
  33. "xcrun cc -E -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    conftest.c -o conftest.i"
  34. checked program was:
  35. /* begin */
  36. 1: #include <sys/types.h>
  37. /* end */
  38.  
  39. --------------------
  40.  
  41. have_header: checking for wand/MagickWand.h... -------------------- yes
  42.  
  43. "xcrun cc -E -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    conftest.c -o conftest.i"
  44. checked program was:
  45. /* begin */
  46. 1: #include <wand/MagickWand.h>
  47. /* end */
  48.  
  49. --------------------
  50.  
  51. have_library: checking for InitializeMagick() in -lMagickCore... -------------------- no
  52.  
  53. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagickCore  -lpthread -ldl -lobjc  "
  54. conftest.c:13:53: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  55. int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  56.                                                     ^
  57. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  58.   InitializeMagick(const char *) magick_attribute((deprecated)),
  59.   ^
  60. 1 warning generated.
  61. ld: library not found for -lMagickCore
  62. clang: error: linker command failed with exit code 1 (use -v to see invocation)
  63. checked program was:
  64. /* begin */
  65.  1: #include <assert.h>
  66.  2: #include <ctype.h>
  67.  3: #include <stdio.h>
  68.  4: #include <stdlib.h>
  69.  5: #include <math.h>
  70.  6: #include <time.h>
  71.  7: #include <stdint.h>
  72.  8: #include <sys/types.h>
  73.  9: #include <wand/MagickWand.h>
  74. 10:
  75. 11: /*top*/
  76. 12: int main() { return 0; }
  77. 13: int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  78. /* end */
  79.  
  80. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagickCore  -lpthread -ldl -lobjc  "
  81. conftest.c:13:11: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  82. int t() { InitializeMagick(); return 0; }
  83.           ^
  84. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  85.   InitializeMagick(const char *) magick_attribute((deprecated)),
  86.   ^
  87. conftest.c:13:28: error: too few arguments to function call, expected 1, have 0
  88. int t() { InitializeMagick(); return 0; }
  89.           ~~~~~~~~~~~~~~~~ ^
  90. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:308:1: note: 'InitializeMagick' declared here
  91. extern MagickExport void
  92. ^
  93. 1 warning and 1 error generated.
  94. checked program was:
  95. /* begin */
  96.  1: #include <assert.h>
  97.  2: #include <ctype.h>
  98.  3: #include <stdio.h>
  99.  4: #include <stdlib.h>
  100.  5: #include <math.h>
  101.  6: #include <time.h>
  102.  7: #include <stdint.h>
  103.  8: #include <sys/types.h>
  104.  9: #include <wand/MagickWand.h>
  105. 10:
  106. 11: /*top*/
  107. 12: int main() { return 0; }
  108. 13: int t() { InitializeMagick(); return 0; }
  109. /* end */
  110.  
  111. --------------------
  112.  
  113. have_library: checking for InitializeMagick() in -lMagick... -------------------- no
  114.  
  115. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagick  -lpthread -ldl -lobjc  "
  116. conftest.c:13:53: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  117. int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  118.                                                     ^
  119. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  120.   InitializeMagick(const char *) magick_attribute((deprecated)),
  121.   ^
  122. 1 warning generated.
  123. ld: library not found for -lMagick
  124. clang: error: linker command failed with exit code 1 (use -v to see invocation)
  125. checked program was:
  126. /* begin */
  127.  1: #include <assert.h>
  128.  2: #include <ctype.h>
  129.  3: #include <stdio.h>
  130.  4: #include <stdlib.h>
  131.  5: #include <math.h>
  132.  6: #include <time.h>
  133.  7: #include <stdint.h>
  134.  8: #include <sys/types.h>
  135.  9: #include <wand/MagickWand.h>
  136. 10:
  137. 11: /*top*/
  138. 12: int main() { return 0; }
  139. 13: int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  140. /* end */
  141.  
  142. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagick  -lpthread -ldl -lobjc  "
  143. conftest.c:13:11: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  144. int t() { InitializeMagick(); return 0; }
  145.           ^
  146. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  147.   InitializeMagick(const char *) magick_attribute((deprecated)),
  148.   ^
  149. conftest.c:13:28: error: too few arguments to function call, expected 1, have 0
  150. int t() { InitializeMagick(); return 0; }
  151.           ~~~~~~~~~~~~~~~~ ^
  152. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:308:1: note: 'InitializeMagick' declared here
  153. extern MagickExport void
  154. ^
  155. 1 warning and 1 error generated.
  156. checked program was:
  157. /* begin */
  158.  1: #include <assert.h>
  159.  2: #include <ctype.h>
  160.  3: #include <stdio.h>
  161.  4: #include <stdlib.h>
  162.  5: #include <math.h>
  163.  6: #include <time.h>
  164.  7: #include <stdint.h>
  165.  8: #include <sys/types.h>
  166.  9: #include <wand/MagickWand.h>
  167. 10:
  168. 11: /*top*/
  169. 12: int main() { return 0; }
  170. 13: int t() { InitializeMagick(); return 0; }
  171. /* end */
  172.  
  173. --------------------
  174.  
  175. have_library: checking for InitializeMagick() in -lMagick++... -------------------- no
  176.  
  177. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagick++  -lpthread -ldl -lobjc  "
  178. conftest.c:13:53: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  179. int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  180.                                                     ^
  181. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  182.   InitializeMagick(const char *) magick_attribute((deprecated)),
  183.   ^
  184. 1 warning generated.
  185. ld: library not found for -lMagick++
  186. clang: error: linker command failed with exit code 1 (use -v to see invocation)
  187. checked program was:
  188. /* begin */
  189.  1: #include <assert.h>
  190.  2: #include <ctype.h>
  191.  3: #include <stdio.h>
  192.  4: #include <stdlib.h>
  193.  5: #include <math.h>
  194.  6: #include <time.h>
  195.  7: #include <stdint.h>
  196.  8: #include <sys/types.h>
  197.  9: #include <wand/MagickWand.h>
  198. 10:
  199. 11: /*top*/
  200. 12: int main() { return 0; }
  201. 13: int t() { void ((*volatile p)()); p = (void ((*)()))InitializeMagick; return 0; }
  202. /* end */
  203.  
  204. "xcrun cc -o conftest -I. -I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin12.0 -I.  -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick    -I/usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick   conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib  -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16      -L/usr/local/Cellar/imagemagick/6.8.0-10/lib -lMagickCore-Q16    -lruby -lMagick++  -lpthread -ldl -lobjc  "
  205. conftest.c:13:11: warning: 'InitializeMagick' is deprecated [-Wdeprecated-declarations]
  206. int t() { InitializeMagick(); return 0; }
  207.           ^
  208. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:332:3: note: 'InitializeMagick' declared here
  209.   InitializeMagick(const char *) magick_attribute((deprecated)),
  210.   ^
  211. conftest.c:13:28: error: too few arguments to function call, expected 1, have 0
  212. int t() { InitializeMagick(); return 0; }
  213.           ~~~~~~~~~~~~~~~~ ^
  214. /usr/local/Cellar/imagemagick/6.8.0-10/include/ImageMagick/magick/deprecate.h:308:1: note: 'InitializeMagick' declared here
  215. extern MagickExport void
  216. ^
  217. 1 warning and 1 error generated.
  218. checked program was:
  219. /* begin */
  220.  1: #include <assert.h>
  221.  2: #include <ctype.h>
  222.  3: #include <stdio.h>
  223.  4: #include <stdlib.h>
  224.  5: #include <math.h>
  225.  6: #include <time.h>
  226.  7: #include <stdint.h>
  227.  8: #include <sys/types.h>
  228.  9: #include <wand/MagickWand.h>
  229. 10:
  230. 11: /*top*/
  231. 12: int main() { return 0; }
  232. 13: int t() { InitializeMagick(); return 0; }
  233. /* end */
  234.  
  235. --------------------
  236.  
  237. Can't install RMagick 2.13.1. Can't find the ImageMagick library or one of the dependent libraries. Check the mkmf.log file for more detailed information.
clone this paste RAW Paste Data