SHARE
TWEET

Untitled

a guest Mar 21st, 2019 83 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "jormungandr"
  2.  
  3. var
  4.    D: inteiro
  5.    VI, TJ, QM, VF: real
  6.    d_vfinals, d_vinicials, d_tjuross, d_qmesess: real
  7.    d_vfinalc, d_vinicialc, d_tjurosc, d_qmesesc: real
  8.  
  9. inicio
  10.  
  11.    d_vinicials <- VF/(1+((TJ/100)^QM))
  12.    d_tjuross <- (((VF-VI)/(VI*QM))*100)
  13.    d_qmesess <- (VF-VI)/(VI*(TJ/100)
  14.    d_vfinals <- VI*(1+((TJ/100)*QM))
  15.  
  16.    d_vinicialc <- VF/(1+((TJ/100)^QM))
  17.    d_tjurosc <- ((((VF/VI)^1)/QM) - 1)*100)
  18.    d_qmesesc <- log(VF/VI)/log(1+(TJ/100))
  19.    d_vfinalc <- VI*(1+((TJ/100)^QM))
  20.  
  21.  
  22.    escreval ("------------------------------------")
  23.    escreval (" BEM VINDO A CALCULADORA FINANCEIRA ")
  24.    escreval ("------------------------------------")
  25.  
  26.    escreval ("Por favor, informe a variável a ser calculada.")
  27.  
  28.    escreval ("----------------------------------------------------")
  29.    escreval (" [0] para calcular o valor presente (juros simples) ")
  30.    escreval (" [1] para calcular o valor presente (juros compostos) ")
  31.    escreval (" [2] para calcular a taxa de juros (juros simples) ")
  32.    escreval (" [3] para calcular a taxa de juros (juros compostos) ")
  33.    escreval (" [4] para calcular a quantidade de meses (juros simples) ")
  34.    escreval (" [5] para calcular a quantidade de meses (juros compostos) ")
  35.    escreval (" [6] para calcular o montante (juros simples) ")
  36.    escreval (" [7] para calcular o montante (juros compostos) ")
  37.    escreval ("----------------------------------------------------")
  38.  
  39.    leia (D)
  40.    se (D = 0)
  41.       escreva (" Informe a taxa de juros em %: ")
  42.       leia (TJ)
  43.       escreva (" Informe a quantidade de meses: ")
  44.       leia (QM)
  45.       escreva (" Informe o montante: ")
  46.       leia (VF)
  47.  
  48.       escreval (" O valor inicial é:", d_vinicials)
  49.  
  50.    senao
  51.       se (D = 1)
  52.  
  53.          escreva (" Informe a taxa de juros em %: ")
  54.          leia (TJ)
  55.          escreva (" Informe a quantidade de meses: ")
  56.          leia (QM)
  57.          escreva (" Informe o montante: ")
  58.          leia (VF)
  59.  
  60.          escreval (" O valor inicial é:", d_vinicialc)
  61.  
  62.  
  63.       senao
  64.          se (D = 2)
  65.             escreva (" Informe o valor inicial: ")
  66.             leia (VI)
  67.             escreva (" Informe a quantidade de meses: ")
  68.             leia (QM)
  69.             escreva ("informe o montante: ")
  70.             leia (VF)
  71.  
  72.             escreval (" A taxa de juros é:", d_tjuross)
  73.  
  74.  
  75.          senao
  76.             se (D = 3)
  77.                escreva (" Informe o valor inicial: ")
  78.                leia (VI)
  79.                escreva (" Informe a quantidade de meses: ")
  80.                leia (QM)
  81.                escreva ("informe o montante: ")
  82.                leia (VF)
  83.  
  84.                escreval (" A taxa de juros é:", d_tjurosc)
  85.  
  86.  
  87.             senao
  88.                se (D = 4)
  89.                   escreva (" Informe o valor inicial: ")
  90.                   leia (VI)
  91.                   escreva (" Informe a taxa de juros em %: ")
  92.                   leia (TJ)
  93.                   escreva ("informe o montante: ")
  94.                   leia (VF)
  95.  
  96.                   escreval (" A taxa de juros é:", d_qmesess)
  97.  
  98.  
  99.                senao
  100.                   se (D = 5)
  101.                      escreva (" Informe o valor inicial: ")
  102.                      leia (VI)
  103.                      escreva (" Informe a quantidade de meses: ")
  104.                      leia (QM)
  105.                      escreva ("informe o montante: ")
  106.                      leia (VF)
  107.  
  108.                      escreval (" A taxa de juros é:", d_qmesesc)
  109.  
  110.  
  111.                   senao
  112.                      se (D = 6)
  113.                         escreva (" Informe o valor inicial: ")
  114.                         leia (VI)
  115.                         escreva (" Informe a taxa de juros em %: ")
  116.                         leia (TJ)
  117.                         escreva (" Informe a quantidade de meses: ")
  118.                         leia (QM)
  119.  
  120.                         escreval (" O valor inicial é:", d_vfinals)
  121.  
  122.  
  123.                      senao
  124.                         se (D = 7)
  125.                            escreva (" Informe o valor inicial: ")
  126.                            leia (VI)
  127.                            escreva (" Informe a quantidade de meses: ")
  128.                            leia (QM)
  129.                            escreva ("informe o montante: ")
  130.                            leia (VF)
  131.  
  132.                            escreval (" A taxa de juros é:", d_vfinalc)
  133.  
  134.                         fimse
  135.                      fimse
  136.                   fimse
  137.                fimse
  138.             fimse
  139.          fimse
  140.       fimse
  141.    fimse
  142.  
  143. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top