Advertisement
Na_cho

Calculadora Control

Apr 7th, 2016
1,278
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Proceso Pregunta_1_Calculadora
  2.     Escribir "¿Qué operación desea realizar?";
  3.     Escribir "1)Sumar";
  4.     Escribir "2)Restar";
  5.     Escribir "3)Multiplicar";
  6.     Escribir "4)Dividir";
  7.     Leer op;
  8.     resp<-0;
  9.     Si op = 1 o op = 2 o op = 3 o op = 4 Entonces
  10.         Escribir "Ingrese el primer número";
  11.         Leer num1;
  12.         Escribir "Ingrese el segundo número";
  13.         Leer num2;
  14.         Si op = 1 Entonces
  15.             resp <- num1 + num2;
  16.         Sino
  17.             Si op = 2 Entonces
  18.                 resp <- num1 - num2;
  19.             Sino
  20.                 Si op = 3 Entonces
  21.                     resp <- num1 * num2;
  22.                 Sino
  23.                     Si num2 > 0 o num2 < 0 Entonces
  24.                         resp <- num1 / num2;
  25.                     Sino
  26.                         Escribir "Error: División por cero";
  27.                     Fin Si
  28.                 Fin Si
  29.             Fin Si
  30.         Fin Si
  31.     Sino
  32.         Escribir "Error: Opción incorrecta"
  33.     Fin Si
  34.     Escribir "El resultado es: ", resp;
  35. FinProceso
Advertisement
RAW Paste Data Copied
Advertisement