daily pastebin goal
17%
SHARE
TWEET

Untitled

a guest Feb 22nd, 2019 70 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. &НаКлиенте
  2. Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
  3.     СтандартнаяОбработка = Ложь;    
  4.     ИсточникНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСхемы);    
  5.     ОбработкаРасшифровкиКД = Новый ОбработкаРасшифровкиКомпоновкиДанных(АдресДанныеРасшифровки, ИсточникНастроек);          
  6.     ВыполненноеДействие = Неопределено;    
  7.     ПараметрДействия    = Неопределено;    
  8.     ОбработкаРасшифровкиКД.ВыбратьДействие(Расшифровка, ВыполненноеДействие, ПараметрДействия);          
  9.     Если ВыполненноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда                      
  10.         Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда                                  
  11.             ОткрытьЗначение(ПараметрДействия);                            
  12.         Иначе
  13.             Парам = Новый Структура;
  14.             Парам.Вставить("ВнешниеНаборыДанных", ПолучитьИзВременногоХранилища(АдресВнешниеНаборыДанных));
  15.             Парам.Вставить("НаименованиеОтчета",  НаименованиеОтчета);
  16.             Парам.Вставить("ПолноеНаименованиеОтчета", ПолноеНаименованиеОтчета);
  17.             Схема = АдресСхемы;
  18.             Парам.Вставить("Схема", Схема);
  19.             Парам.Вставить("ИмяТекущегоВарианта", ИмяТекущегоВарианта);
  20.             Парам.Вставить("СформироватьПриОткрытии", Истина);
  21.             Парам.Вставить("Расшифровка", Новый ОписаниеОбработкиРасшифровкиКомпоновкиДанных(АдресДанныеРасшифровки,     Расшифровка, ПараметрДействия));
  22.             ОткрытьФорму("ОбщаяФорма.mavОбщаяФормаОтчетаУправляемая", Парам, ,Истина)
  23.         КонецЕсли;                  
  24.     КонецЕсли;
  25. КонецПроцедуры
  26.  
  27.  
  28. &НаСервере
  29. Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  30.    
  31.     ВнешниеНаборыДанных = Неопределено;
  32.     Параметры.Свойство("ВнешниеНаборыДанных",       ВнешниеНаборыДанных);
  33.     Параметры.Свойство("ПолноеНаименованиеОтчета",     ПолноеНаименованиеОтчета);
  34.     Параметры.Свойство("ИмяТекущегоВарианта",       ИмяТекущегоВарианта);
  35.     Параметры.Свойство("АдресХраненияФормы",     АдресХраненияФормы);
  36.     Расшифровка = Неопределено;
  37.     Параметры.Свойство("Расшифровка",               Расшифровка);
  38.     Параметры.Свойство("СформироватьПриОткрытии",   СформироватьПриОткрытии);
  39.     ЭтаФорма.Заголовок = ПолноеНаименованиеОтчета;
  40.    
  41.     АдресВнешниеНаборыДанных = ПоместитьВоВременноеХранилище(ВнешниеНаборыДанных, УникальныйИдентификатор);
  42.     НаименованиеОтчета = Параметры.НаименованиеОтчета;
  43.    
  44.     Схема = Параметры.Схема;
  45.     Если ТипЗнч(Схема) <> Тип("СхемаКомпоновкиДанных") Тогда
  46.         Схема = ПолучитьИзВременногоХранилища(Схема);
  47.     КонецЕсли;
  48.     АдресСхемы = ПоместитьВоВременноеХранилище(Схема, УникальныйИдентификатор);
  49.     ИнициализироватьКомпоновщик(КомпоновщикНастроек, АдресСхемы);  
  50.    
  51.     //TODO проверить, может нужно для расшифровки
  52.     //TODO проверить, может при пустых настройках требуется.
  53.     //скорее всего дублируется в других местах
  54.     //Если ЗначениеЗаполнено(ИмяТекущегоВарианта) Тогда
  55.     //  ВыбранныйВариант = Схема.ВариантыНастроек.Найти(ИмяТекущегоВарианта);
  56.     //  Если ВыбранныйВариант = Неопределено Тогда
  57.     //      ВыбранныйВариант = Схема.ВариантыНастроек[0];
  58.     //      ИмяТекущегоВарианта = Схема.ВариантыНастроек[0].Имя;
  59.     //  КонецЕсли;
  60.     //  КомпоновщикНастроек.ЗагрузитьНастройки(ВыбранныйВариант.Настройки);
  61.     //  НаименованиеТекущегоВарианта = ВыбранныйВариант.Представление;
  62.     //КонецЕсли;
  63.    
  64.     Если Расшифровка <> Неопределено Тогда
  65.         УжеЕстьНастройки = Истина;
  66.         НаименованиеТекущегоВарианта = "Расшифровка";
  67.         ИмяТекущегоВарианта = "";
  68.         ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(Расшифровка.Данные);
  69.         ОбработкаРасшифровки =  Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровкиОбъект, Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСхемы));
  70.         РезультирующиеНастройки = ОбработкаРасшифровки.ПрименитьНастройки(Расшифровка.Идентификатор, Расшифровка.ПрименяемыеНастройки);
  71.         Если ТипЗнч(РезультирующиеНастройки) = Тип("НастройкиКомпоновкиДанных") Тогда
  72.             КомпоновщикНастроек.ЗагрузитьНастройки(РезультирующиеНастройки);
  73.         ИначеЕсли ТипЗнч(РезультирующиеНастройки) = Тип("ПользовательскиеНастройкиКомпоновкиДанных") Тогда
  74.             КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(РезультирующиеНастройки);
  75.         КонецЕсли;
  76.     КонецЕсли;
  77.    
  78. КонецПроцедуры
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top