SHARE
TWEET

RM

dayona Jun 19th, 2019 76 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. PS C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp> npm install
  2.  
  3. > grpc@1.18.0 install C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc
  4. > node-pre-gyp install --fallback-to-build --library=static_library
  5.  
  6. node-pre-gyp WARN Using request for node-pre-gyp https download
  7. node-pre-gyp WARN Tried to download(404): https://node-precompiled-binaries.grpc.io/grpc/v1.18.0/node-v72-win32-x64-unknown.tar.gz
  8. node-pre-gyp WARN Pre-built binaries not found for grpc@1.18.0 and node@12.4.0 (node-v72 ABI, unknown) (falling back to source compile with node-gyp)
  9. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  10. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  11. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  12. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  13. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  14. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  15. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  16. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  17. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  18. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  19. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  20. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  21. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  22. Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
  23. Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch.
  24. MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location
  25. of the component to the system path if it is installed elsewhere.  [C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\build\binding.sln]
  26. MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location
  27. of the component to the system path if it is installed elsewhere.  [C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\build\binding.sln]
  28. MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location
  29. of the component to the system path if it is installed elsewhere.  [C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\build\binding.sln]
  30. MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location
  31. of the component to the system path if it is installed elsewhere.  [C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\build\binding.sln]
  32. MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location
  33. of the component to the system path if it is installed elsewhere.  [C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\build\binding.sln]
  34. gyp ERR! build error
  35. gyp ERR! stack Error: `C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe` failed with exit code: 1
  36. gyp ERR! stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
  37. gyp ERR! stack     at ChildProcess.emit (events.js:200:13)
  38. gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
  39. gyp ERR! System Windows_NT 10.0.17763
  40. gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "build" "--fallback-to-build" "--library=static_library" "--module=C:\\Users\\Cranium PC\\Downloads\\magnoapp-master\\magnoapp\\node_modules\\grpc\\src\\node\\extension_binary\\node-v72-win32-x64-unknown\\grpc_node.node" "--module_name=grpc_node" "--module_path=C:\\Users\\Cranium PC\\Downloads\\magnoapp-master\\magnoapp\\node_modules\\grpc\\src\\node\\extension_binary\\node-v72-win32-x64-unknown" "--napi_version=4" "--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v72"
  41. gyp ERR! cwd C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc
  42. gyp ERR! node -v v12.4.0
  43. gyp ERR! node-gyp -v v3.8.0
  44. gyp ERR! not ok
  45. node-pre-gyp ERR! build error
  46. node-pre-gyp ERR! stack Error: Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js build --fallback-to-build --library=static_library --module=C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\src\node\extension_binary\node-v72-win32-x64-unknown\grpc_node.node --module_name=grpc_node --module_path=C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\src\node\extension_binary\node-v72-win32-x64-unknown --napi_version=4 --node_abi_napi=napi --napi_build_version=0
  47. --node_napi_label=node-v72' (1)
  48. node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\node_modules\node-pre-gyp\lib\util\compile.js:83:29)
  49. node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:200:13)
  50. node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:1021:16)
  51. node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)
  52. node-pre-gyp ERR! System Windows_NT 10.0.17763
  53. node-pre-gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\Cranium PC\\Downloads\\magnoapp-master\\magnoapp\\node_modules\\grpc\\node_modules\\node-pre-gyp\\bin\\node-pre-gyp" "install" "--fallback-to-build" "--library=static_library"
  54. node-pre-gyp ERR! cwd C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc
  55. node-pre-gyp ERR! node -v v12.4.0
  56. node-pre-gyp ERR! node-pre-gyp -v v0.12.0
  57. node-pre-gyp ERR! not ok
  58. Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js build --fallback-to-build --library=static_library --module=C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\src\node\extension_binary\node-v72-win32-x64-unknown\grpc_node.node --module_name=grpc_node --module_path=C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp\node_modules\grpc\src\node\extension_binary\node-v72-win32-x64-unknown --napi_version=4 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v72' (1)npm WARN @babel/plugin-external-helpers@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  59. npm WARN @babel/plugin-proposal-class-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  60. npm WARN @babel/plugin-proposal-object-rest-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  61. npm WARN @babel/plugin-proposal-optional-chaining@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  62. npm WARN @babel/plugin-syntax-class-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  63. npm WARN @babel/plugin-syntax-dynamic-import@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  64. npm WARN @babel/plugin-syntax-flow@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  65. npm WARN @babel/plugin-syntax-jsx@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  66. npm WARN @babel/plugin-syntax-nullish-coalescing-operator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  67. npm WARN @babel/plugin-syntax-object-rest-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  68. npm WARN @babel/plugin-syntax-optional-chaining@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  69. npm WARN @babel/plugin-transform-arrow-functions@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  70. npm WARN @babel/plugin-transform-async-to-generator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  71. npm WARN @babel/plugin-transform-block-scoping@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  72. npm WARN @babel/plugin-transform-classes@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  73. npm WARN @babel/plugin-transform-computed-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  74. npm WARN @babel/plugin-transform-destructuring@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  75. npm WARN @babel/plugin-transform-exponentiation-operator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  76. npm WARN @babel/plugin-transform-flow-strip-types@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  77. npm WARN @babel/plugin-transform-for-of@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  78. npm WARN @babel/plugin-transform-function-name@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  79. npm WARN @babel/plugin-transform-literals@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  80. npm WARN @babel/plugin-transform-modules-commonjs@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  81. npm WARN @babel/plugin-transform-object-assign@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  82. npm WARN @babel/plugin-transform-parameters@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  83. npm WARN @babel/plugin-transform-react-display-name@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  84. npm WARN @babel/plugin-transform-react-jsx@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  85. npm WARN @babel/plugin-transform-react-jsx-source@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  86. npm WARN @babel/plugin-transform-regenerator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  87. npm WARN @babel/plugin-transform-shorthand-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  88. npm WARN @babel/plugin-transform-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  89. npm WARN @babel/plugin-transform-template-literals@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  90. npm WARN @babel/plugin-transform-unicode-regex@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  91. npm WARN @babel/register@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  92. npm WARN @babel/plugin-proposal-class-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  93. npm WARN @babel/plugin-proposal-object-rest-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  94. npm WARN @babel/plugin-proposal-optional-chaining@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  95. npm WARN @babel/plugin-syntax-class-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  96. npm WARN @babel/plugin-syntax-flow@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  97. npm WARN @babel/plugin-syntax-jsx@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  98. npm WARN @babel/plugin-syntax-object-rest-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  99. npm WARN @babel/plugin-syntax-optional-chaining@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  100. npm WARN @babel/plugin-transform-arrow-functions@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  101. npm WARN @babel/plugin-transform-block-scoping@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  102. npm WARN @babel/plugin-transform-classes@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  103. npm WARN @babel/plugin-transform-computed-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  104. npm WARN @babel/plugin-transform-destructuring@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  105. npm WARN @babel/plugin-transform-exponentiation-operator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  106. npm WARN @babel/plugin-transform-flow-strip-types@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  107. npm WARN @babel/plugin-transform-for-of@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  108. npm WARN @babel/plugin-transform-function-name@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  109. npm WARN @babel/plugin-transform-literals@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  110. npm WARN @babel/plugin-transform-modules-commonjs@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  111. npm WARN @babel/plugin-transform-object-assign@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  112. npm WARN @babel/plugin-transform-parameters@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  113. npm WARN @babel/plugin-transform-react-display-name@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  114. npm WARN @babel/plugin-transform-react-jsx@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  115. npm WARN @babel/plugin-transform-react-jsx-source@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  116. npm WARN @babel/plugin-transform-regenerator@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  117. npm WARN @babel/plugin-transform-shorthand-properties@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  118. npm WARN @babel/plugin-transform-spread@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  119. npm WARN @babel/plugin-transform-sticky-regex@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  120. npm WARN @babel/plugin-transform-template-literals@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  121. npm WARN @babel/plugin-transform-unicode-regex@7.0.0-beta.47 requires a peer of @babel/core@7.0.0-beta.47 but none is installed. You must install peer dependencies yourself.
  122. npm WARN react-native-elements@0.19.1 requires a peer of react-native-vector-icons@^4.2.0 but none is installed. You must install peer dependencies yourself.
  123. npm WARN react-native-firebase@5.1.0 requires a peer of react@>= 16.5.0 but none is installed. You must install peer dependencies yourself.
  124. npm WARN react-native-firebase@5.1.0 requires a peer of react-native@>= 0.57.0 but none is installed. You must install peer dependencies yourself.
  125. npm WARN react-native-otp-inputs@0.7.0 requires a peer of react-native@^0.53.0 but none is installed. You must install peer dependencies yourself.
  126. npm WARN react-native-scalable-image@0.4.0 requires a peer of react@^15.4 but none is installed. You must install peer dependencies yourself.
  127. npm WARN react-native-scalable-image@0.4.0 requires a peer of react-native@^0.41.2 but none is installed. You must install peer dependencies yourself.
  128. npm WARN react-native-webview@5.6.2 requires a peer of react-native@>=0.57 <0.60 but none is installed. You must install peer dependencies yourself.
  129. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
  130. npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
  131.  
  132. npm ERR! code ELIFECYCLE
  133. npm ERR! errno 1
  134. npm ERR! grpc@1.18.0 install: `node-pre-gyp install --fallback-to-build --library=static_library`
  135. npm ERR! Exit status 1
  136. npm ERR!
  137. npm ERR! Failed at the grpc@1.18.0 install script.
  138. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
  139.  
  140. npm ERR! A complete log of this run can be found in:
  141. npm ERR!     C:\Users\Cranium PC\AppData\Roaming\npm-cache\_logs\2019-06-19T05_49_01_118Z-debug.log
  142. PS C:\Users\Cranium PC\Downloads\magnoapp-master\magnoapp>
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top