daily pastebin goal
0%
SHARE
TWEET

Untitled

a guest Mar 20th, 2017 150 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. 13:43:25 joseph@Delli ~ yaourt linux-vfio
  2. 1 aur/linux-vfio 4.10.4-1 (32) (3.81)
  3.     The Linux kernel and modules with patches to enable GPU passthrough with KVM
  4. 2 aur/linux-vfio-docs 4.10.4-1 (32) (3.81)
  5.     Kernel hackers manual - HTML documentation that comes with the Linux-vfio kernel
  6. 3 aur/linux-vfio-headers 4.10.4-1 (32) (3.81)
  7.     Header files and scripts for building modules for Linux-vfio kernel
  8. 4 aur/linux-vfio-lts 4.9.15-1 (7) (0.63)
  9.     The Linux kernel and modules with patches to enable GPU passthrough with KVM
  10. 5 aur/linux-vfio-lts-docs 4.9.15-1 (7) (0.63)
  11.     Kernel hackers manual - HTML documentation that comes with the Linux-vfio-lts kernel
  12. 6 aur/linux-vfio-lts-headers 4.9.15-1 (7) (0.63)
  13.     Header files and scripts for building modules for Linux-vfio-lts kernel
  14. ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
  15. ==> -------------------------------------------------------
  16. ==> 1
  17.  
  18.  
  19. ==> Downloading linux-vfio PKGBUILD from AUR...
  20. x .SRCINFO
  21. x .gitignore
  22. x 99-linux.hook
  23. x PKGBUILD
  24. x README
  25. x add-acs-overrides.patch
  26. x change-default-console-loglevel.patch
  27. x config
  28. x config.x86_64
  29. x i915-vga-arbiter.patch
  30. x linux.install
  31. x linux.preset
  32. markzz commented on 2017-03-05 20:44                    
  33. I have built kernel 4.10.1 with some updated patches and if you would like to test them out (and please do), you can find both binary and source packages here [1]. I especially would like people who rely on the i915 arbitration patch to test it since I don't use that part.
  34.  
  35. As always, test at your own risk.
  36.  
  37. [1] http://duna.markzz.net/linux-vfio-4.10/
  38.  
  39. Spartus commented on 2017-03-15 15:50                    
  40. Um,I just got a new system with IOMMU and wanted to install this... it has been compiling for 4 hours now. Is this normal? Certainly not what I expected.
  41.  
  42. Update: ended in failure...
  43.  
  44. CC      drivers/md/dm-log-userspace.mod.o
  45. LD [M]  drivers/md/dm-log-userspace.ko
  46. CC      drivers/md/dm-log-writes.mod.o
  47. LD [M]  drivers/md/dm-log-writes.ko
  48. CC      drivers/md/dm-log.mod.o
  49. LD [M]  drivers/md/dm-log.ko
  50. CC      drivers/md/dm-mirror.mod.o
  51. gcc: internal compiler error: Segmentation fault (program cc1)
  52. Please submit a full bug report,
  53. with preprocessed source if appropriate.
  54. See https://bugs.archlinux.org/ for instructions.
  55. make[1]: *** [scripts/Makefile.modpost:114: drivers/md/dm-mirror.mod.o] Error 4
  56. make: *** [Makefile:1198: modules] Error 2
  57. == ERROR: A failure occurred in build().
  58. Aborting...
  59. == ERROR: Makepkg was unable to build linux-vfio.
  60. == Restart building linux-vfio ? [y/N]
  61.  
  62. markzz commented on 2017-03-15 17:30                    
  63. Spartus: On a slow computer, this will take a while to compile.
  64.  
  65. Spartus commented on 2017-03-16 02:14                    
  66. Thanks markzz. While I do appreciate that compile time is directly a function of computer speed, of course, it seems especially long for a brand new Ryzen 7 (although I fear baiting a conversation of AMD vs. Intel). Regardless, does 4+ hours seem reasonable based on other's experience?
  67.  
  68. markzz commented on 2017-03-16 02:53                    
  69. Spartus: You shouldn't need this package if you're using an AMD chip. That is one of the few advantages of them (I kid I kid). ;-)
  70.  
  71. On a side note, it takes me over an hour on my i7-4790K and I usually set it to compile when I go to bed.
  72.  
  73. I also do provide this package on my repository, in the case you do actually need this package and you don't want to take the time to compile it (scroll down in the comments feed for more info).
  74.  
  75. linux-vfio 4.10.4-1  (2017-03-20 16:54)
  76. ( Unsupported package: Potentially dangerous ! )
  77. ==> Edit PKGBUILD ? [Y/n] ("A" to abort)
  78. ==> ------------------------------------
  79. ==> y
  80.  
  81. ==> WARNING: This PKGBUILD describes a split package.
  82. ==> Specific package options are unknown
  83. ==> linux-vfio dependencies:
  84.  - xmlto (already installed) [makedepend]
  85.  - docbook-xsl (already installed) [makedepend]
  86.  - kmod (already installed) [makedepend]
  87.  - inetutils (already installed) [makedepend]
  88.  - bc (already installed) [makedepend]
  89.  - libelf (already installed) [makedepend]
  90.  
  91.  
  92. ==> Continue building linux-vfio ? [Y/n]
  93. ==> ------------------------------------
  94. ==>
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top