SHARE
TWEET

4_46

a guest Aug 27th, 2018 174 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "semnome"
  2. var
  3.    num, valor:inteiro
  4.    resultado:caracter
  5. inicio
  6.       escreval("Digite um valor Decimal: ")
  7.       leia(num)
  8.       valor <- (num)
  9.       enquanto (num > 0) faca
  10.                escolha (num%8)
  11.                        caso 1
  12.                        resultado <- ("1" + resultado)
  13.                        caso 2
  14.                        resultado <- ("2" + resultado)
  15.                        caso 3
  16.                        resultado <- ("3" + resultado)
  17.                        caso 4
  18.                        resultado <- ("4" + resultado)
  19.                        caso 5
  20.                        resultado <- ("5" + resultado)
  21.                        caso 6
  22.                        resultado <- ("6" + resultado)
  23.                        caso 7
  24.  
  25.                        resultado <- ("7" + resultado)
  26.               fimescolha
  27.               num <- (num \ 8)
  28.      fimenquanto
  29.      escreval (resultado)
  30. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top