SHARE
TWEET

5_11

a guest Sep 17th, 2018 166 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "5_11"
  2. var
  3.    m: vetor[0..10, 0..10] de inteiro
  4.    l, c, s, ss:inteiro
  5. inicio
  6.       l <- 0
  7.       enquanto (l <= 10) faca
  8.                c <- 0
  9.                enquanto (c <= 10) faca
  10.                         escreva("Digite o valor da posição [",l,", ",c,"]: ")
  11.                         leia(m[l, c])
  12.                         c <- c + 1
  13.                fimenquanto
  14.                l <- l + 1
  15.       fimenquanto
  16.       ss <- 0
  17.       s <- 0
  18.       l <- 0
  19.       enquanto (l <= 10) faca
  20.                c <- 0
  21.                enquanto (c <= 10) faca
  22.                         se (l = c) entao
  23.                            s <- s + m[l, c]
  24.                         fimse
  25.                         se (l+c = 10) entao
  26.                            ss <- ss + m[l, c]
  27.                         fimse
  28.                         c <- c + 1
  29.                fimenquanto
  30.                l <- l + 1
  31.       fimenquanto
  32.       escreval("A soma dos elementos da diagonal primária é igual a: ", s)
  33.       escreval("A soma dos elementos da diagonal secundária é igual a: ", ss)
  34. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top