SHARE
TWEET

Untitled

a guest Aug 11th, 2018 94 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "semnome"
  2. // Função :
  3. // Autor :
  4. // Data : 19/05/2012
  5. // Seção de Declarações
  6. var
  7. pato,valorfim:inteiro
  8. inicio
  9. escreval("Quantos patos a mamãe patinho tinha?")
  10. leia(pato)
  11. valorfim <- pato
  12. enquanto (pato<>0) faca
  13. se(pato>1) entao
  14. escreval("====================================")
  15. escreval(pato," patinhos foram passear")
  16. escreval("além das montanhas, para brincar.")
  17. escreval("A mamãe gritou: quá, quá, quá, quá")
  18. pato <- pato-1
  19. escreval("mas só ",pato," patinho(s) voltaram(ou) de lá.")
  20. fimse
  21. se(pato=1) entao
  22. escreval("====================================")
  23. escreval(pato," patinho foi passear")
  24. escreval("além das montanhas, para brincar.")
  25. escreval("A mamãe gritou: quá, quá, quá, quá")
  26. pato <- pato-1
  27. escreval("mas nenhum patinho voltou de lá.")
  28. fimse
  29. se(pato=0) entao
  30. escreval("====================================")
  31. escreval("A mamãe patinho foi procurar")
  32. escreval("Além das montanhas")
  33. escreval("Na beira do mar")
  34. escreval("A mamãe gritou: quá, quá, quá, quá")
  35. escreval("E os ",valorfim," patinhos voltaram de lá")
  36. fimse
  37. fimenquanto
  38. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top