daily pastebin goal
57%
SHARE
TWEET

Untitled

a guest Dec 10th, 2018 73 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. PROCÉDURE AttribuerDossard()
  2.  
  3. HLitPremier(Coureur_Course)
  4.  
  5. SI Coureur_Course.NumDossard = 0 ALORS
  6.     i est un entier = 1
  7.    
  8.     POUR TOUT Coureur_Course SUR points DEPUISFIN
  9.         Coureur_Course.NumDossard = i
  10.         HModifie(Coureur_Course)
  11.         i++
  12.     FIN
  13. FIN
  14.  
  15. //---------------------------------
  16.  
  17. PROCÉDURE AttribuerTempsDepart()
  18.  
  19. HLitPremier(Coureur_Course)
  20. HLitPremier(Course)
  21.  
  22. SI HeureVersEntier(Coureur_Course.heureDépart) = 0 ALORS
  23.     i est un entier = HeureVersEntier(Course.heureDépart)
  24.     nDeli est un entier = HeureVersEntier(Course.deltadépart)
  25.    
  26.     POUR TOUT Coureur_Course SUR NumDossard DEPUISFIN
  27.         Coureur_Course.heureDépart=EntierVersHeure(i)
  28.         HModifie(Coureur_Course)
  29.         i += nDeli
  30.     FIN
  31. FIN
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top