Advertisement
Guest User

darts

a guest
Oct 23rd, 2014
267
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. ΑΛΓΟΡΙΘΜΟΣ Darts
  2.  
  3. Ρ[1] ← 7
  4. Ρ[2] ← 15
  5. Ρ[3] ← 19
  6. Ρ[4] ← 23
  7. Ρ[5] ← 29
  8. Ρ[6] ← 37
  9.  
  10. ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
  11. Δ[i] ← 1
  12. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  13.  
  14. Πλ ← 0
  15. ΟΣΟ Δ[1] <= 6 ΕΠΑΝΑΛΑΒΕ
  16. Άθρ ← 0
  17. ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
  18. Άθρ ← Άθρ + Ρ[Δ[i]]
  19. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  20. ΑΝ Άθρ = 100 ΤΟΤΕ
  21. Πλ ← Πλ + 1
  22. ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
  23. ΕΜΦΑΝΙΣΕ Ρ[Δ[i]], " "
  24. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  25. ΕΜΦΑΝΙΣΕ ""
  26. ΤΕΛΟΣ_ΑΝ
  27. Δ[6] ← Δ[6] + 1
  28. k ← 7
  29. ΓΙΑ i ΑΠΟ 6 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ -1
  30. ΑΝ Δ[i] > 6 ΤΟΤΕ
  31. Δ[i] ← 1
  32. Δ[i - 1] ← Δ[i - 1] + 1
  33. k ← i
  34. ΤΕΛΟΣ_ΑΝ
  35. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  36. ΓΙΑ i ΑΠΟ k ΜΕΧΡΙ 6
  37. ΑΝ Δ[i] < Δ[i-1] ΤΟΤΕ
  38. Δ[i] ← Δ[i-1]
  39. ΤΕΛΟΣ_ΑΝ
  40. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  41. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  42. ΕΜΦΑΝΙΣΕ "Πλήθος : ", Πλ
  43. ΤΕΛΟΣ Darts
Advertisement
RAW Paste Data Copied
Advertisement