DemAl

Убрать лишние символы в строке

Jul 22nd, 2021
1,508
Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1.  Функция УбратьЛишниеСимволы(Строка1) Экспорт
  2.     НовСтрока = "";
  3.     ПравильныеСимволы = "QWERTYUIOPASDFGHJKLZXCVBNMqwertyuiopasdfghjklzxcvbnmЙЦУКЕНГШЩЗХЪФЫВАПРОЛДЖЭЯЧСМИТЬБЮйцукенгшщзхъфывапролджэячсмитьбю";
  4.     Для Сч = 1 по СтрДлина(Строка1) Цикл
  5.         ТекСимв = Сред(Строка1, Сч, 1);
  6.         Если Найти(ПравильныеСимволы, ТекСимв) > 0 Тогда
  7.             НовСтрока = НовСтрока + ТекСимв;
  8.         КонецЕсли;
  9.     КонецЦикла;
  10.    
  11.     Возврат НовСтрока;
  12.    
  13. КонецФункции  
RAW Paste Data