SHARE
TWEET

Untitled

a guest Sep 20th, 2019 87 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. ```Algoritmo "Sistema de vendas"
  2.  
  3. Var
  4.    valor1, valor2,totalCompra,valorParcelas,quantParcelas,valorJuros,compraJuros,valorTotalJuros:real
  5.    formaPagamento,valorBandeira:caractere
  6.  
  7. Inicio
  8.  
  9.    escreval ("----------------------------------------------------------")
  10.    escreval ("--------------------Sistema de vendas---------------------")
  11.    escreval ("----------------------------------------------------------")
  12.    escreval
  13.  
  14.    escreval ("Digite o primeiro valor em R$:")
  15.    leia (valor1)
  16.    escreval ("Digite o segundo valor em R$:")
  17.    leia (valor2)
  18.    totalCompra:= valor1+valor2
  19.    escreval
  20.  
  21.    escreval ("----------------------------------------------------------")
  22.    escreval ("--------------------Formas de pagamento-------------------")
  23.    escreval ("----------------------------------------------------------")
  24.  
  25.    escreval ("Crédito")
  26.    escreval ("Debito")
  27.    escreval ("Dinheiro")
  28.    escreval
  29.  
  30.    escreval("Que forma de pagamento deseja utilizar?")
  31.    leia (formaPagamento)
  32.  
  33.    escolha formaPagamento
  34.  
  35.    caso "Crédito"
  36.       valorJuros:= (12/100)
  37.       compraJuros:= (valorJuros * totalCompra)
  38.       valorTotalJuros:= (compraJuros + totalCompra)
  39.       escreval
  40.       escreval ("----------------------------------------------------------")
  41.       escreval ("--------------------Bandeira dos cartões------------------")
  42.       escreval ("----------------------------------------------------------")
  43.  
  44.       escreval ("Hiper")
  45.       escreval ("Visa")
  46.       escreval ("Master")
  47.       escreval
  48.       escreval("Com que cartão deseja pagar?")
  49.       leia (valorBandeira)
  50.       escreval
  51.  
  52.       se (valorBandeira = "Hiper") e (totalCompra > 200) entao
  53.          quantParcelas:=10
  54.          valorParcelas:= (totalCompra / quantParcelas)
  55.          escreval("Quantidade de parcelas:",quantParcelas)
  56.          escreval("Valor das parcelas",valorParcelas)
  57.          escreval("Valor total:",valorTotalJuros)
  58.       senao
  59.          se (valorBandeira = "Visa") e (totalCompra > 200) entao
  60.             quantParcelas:=8
  61.             valorParcelas:= (totalCompra / quantParcelas)
  62.             escreval("Quantidade de parcelas:",quantParcelas)
  63.             escreval("Valor das parcelas",valorParcelas)
  64.             escreval("Valor total:",valorTotalJuros)
  65.          senao
  66.             se (valorBandeira = "Master") e (totalCompra > 200) entao
  67.                quantParcelas:=6
  68.                valorParcelas:= (totalCompra / quantParcelas)
  69.                escreval("Quantidade de parcelas:",quantParcelas)
  70.                escreval("Valor das parcelas",valorParcelas)
  71.                escreval("Valor total:",valorTotalJuros)
  72.             senao
  73.                escreval ("Não é possivel parcelar")
  74.             fimse
  75.          fimse
  76.  
  77.       fimse
  78.  
  79.    caso "Debito"
  80.       escreval("Valor total da compra: R$",totalCompra)
  81.  
  82.    caso "Dinheiro"
  83.       escreval("Valor total da compra: R$",totalCompra)
  84.  
  85.    fimescolha
  86.  
  87.  
  88.  
  89. Fimalgoritmo```
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top