SHARE
TWEET

Test

a guest Sep 10th, 2018 129 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. Процедура OK(Кнопка)
  2.    
  3.     Для Каждого Клиент Из Справочники.Клиенты Цикл
  4.         Попытка
  5.            
  6.             Если МетаданныеВыбор = Неопределено Тогда
  7.                 ВызватьИсключение("Не выбраны метаданные регламентного задания.");
  8.             КонецЕсли;
  9.            
  10.             Если РегламентноеЗадание = Неопределено Тогда
  11.                 РегламентноеЗадание = РегламентныеЗадания.СоздатьРегламентноеЗадание(МетаданныеВыбор);
  12.             КонецЕсли;
  13.            
  14.             РегламентноеЗадание.Наименование = Наименование;
  15.             РегламентноеЗадание.Ключ = Ключ;
  16.             РегламентноеЗадание.Использование = Использование;
  17.             РегламентноеЗадание.ИмяПользователя = Клиент;
  18.             РегламентноеЗадание.КоличествоПовторовПриАварийномЗавершении = КоличествоПовторовПриАварийномЗавершении;
  19.             РегламентноеЗадание.ИнтервалПовтораПриАварийномЗавершении = ИнтервалПовтораПриАварийномЗавершении;
  20.             РегламентноеЗадание.Расписание = Расписание;
  21.            
  22.             РегламентноеЗадание.Записать();
  23.            
  24.             Закрыть(Истина);
  25.            
  26.         Исключение   
  27.            
  28.             ПоказатьИнформациюОбОшибке(ИнформацияОбОшибке());
  29.            
  30.         КонецПопытки;
  31.     КонецЦикла;  
  32. КонецПроцедуры
  33.  
  34.  
  35. Процедура ОтправкаПисьма(Получатель)
  36.     Профиль = Новый ИнтернетПочтовыйПрофиль;
  37.     Профиль.АдресСервераSMTP = "АдресСервераSMTP";
  38.     Профиль.ПользовательSMTP = "ПользовательSMTP";
  39.     Профиль.ПарольSMTP = "Пароль";
  40.     Профиль.ИспользоватьSSLSMTP = Истина;
  41.     Профиль.ПортSMTP = "Порт";
  42.     Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
  43.  
  44.     Письмо = Новый ИнтернетПочтовоеСообщение;
  45.     Текст = Письмо.Тексты.Добавить("Тело письма");
  46.     Текст.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
  47.     Письмо.Тема = "Тема письма";
  48.     Письмо.Отправитель = "Адрес отправителя";
  49.     Письмо.ИмяОтправителя = "Имя отправителя";
  50.     Письмо.Получатели.Добавить(Получатель.ЭлектронныйАдрес);
  51.     Письмо.Вложения.Добавить(Новый ДвоичныеДанные(ПолучитьПечатнуюФорму(Получатель)),"имя файла"); 
  52.    
  53.     Почта = Новый ИнтернетПочта;    
  54.     Попытка
  55.        Почта.Подключиться(Профиль);
  56.        Сообщить("Подключено");
  57.     Исключение
  58.        Сообщить("Не удалось подключиться к серверу");
  59.        Сообщить(ОписаниеОшибки());
  60.     КонецПопытки;
  61.     Попытка
  62.        Почта.Послать(Письмо);
  63.        Сообщить("Письмо отправлено");
  64.     Исключение
  65.        Сообщить("Не удалось отправить письмо");
  66.        Сообщить(ОписаниеОшибки());
  67.     КонецПопытки;
  68.    
  69.     Почта.Отключиться();
  70.     Сообщить("Соединение завершено");
  71. КонецПроцедуры
  72.  
  73.  
  74. Функция ПолучитьПечатнуюФорму(Клиент)
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
Not a member of Pastebin yet?
Sign Up, it unlocks many cool features!
 
Top