SHARE
TWEET

Untitled

a guest Sep 16th, 2019 97 Never
Not a member of Pastebin yet? Sign Up, it unlocks many cool features!
  1. algoritmo "ex03_repREF"
  2. // Renato ex03_repeticaoREFORÇO
  3.  
  4. var
  5. entrada: inteiro
  6. base, altura: real
  7.  
  8. inicio
  9.  
  10. repita
  11.  
  12. escreval("Digite qual forma você quer calcular:")
  13. escreval("1 - área de um triângulo")
  14. escreval("2 - área de um círculo")
  15. escreval("3 - área de um cubo")
  16. escreval("4 - área de um cilindro")
  17. leia(entrada)
  18.  
  19. escolha(entrada)
  20.  
  21. caso(1)
  22.        escreval("Digite a base")
  23.        leia(base)
  24.        escreval("Digite a altura")
  25.        leia(altura)
  26.        escreval("Área do triângulo: ", (base*altura)/2)
  27.        
  28. caso(2)
  29.        escreval("Digite o raio")
  30.        leia(base)
  31.        escreval("Área do círculo: ", (base*base*Pi))
  32.        caso(3)
  33.        escreval("Digite a medida da aresta")
  34.        leia(base)
  35.        escreval("Área do cubo: ", (6*(base*base)))
  36.        
  37. caso(4)
  38.        escreval("Digite o raio")
  39.        leia(base)
  40.        escreval("Digite a altura")
  41.        leia(altura)
  42. escreval("Área do cilindro: ", ((2*(Pi)*(base)*(altura))+((Pi)*(base*base))))
  43.  
  44. outrocaso
  45.          escreval("Entrada inválida!")
  46.          
  47. fimescolha
  48.  
  49. escreval("Continuar? 1 para sim, 0 para não")
  50. leia(entrada)
  51.  
  52. se(entrada)=(0) entao
  53.                 interrompa
  54. fimse
  55.  
  56. ate 0=1
  57.  
  58. escreval("Operação finalizada pelo usuário.")
  59. fimalgoritmo
RAW Paste Data
We use cookies for various purposes including analytics. By continuing to use Pastebin, you agree to our use of cookies as described in the Cookies Policy. OK, I Understand
 
Top